troubleshooting Question

CUCM 6.1 Music on Hold

Avatar of Humongous
Humongous asked on
RoutersVoice Over IP
12 Comments2 Solutions1374 ViewsLast Modified:
I have MOH setup and running internally.  I now need to set it up so external callers will hear it while they are waiting.  I have included our core router configuration and our internet router configuration.  Let me know if you need more info.  I am pretty sure I have to bind MOH to an interface to get it going, but I am not sure what - if anything else - has to be done.  TIA!
INTERNET ROUTER - 3745
 
 
Building configuration...
 
Current configuration : 3313 bytes
!
! NVRAM config last updated at 11:45:26 est Wed Jan 14 2009 by 
!
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname Internet
!
boot-start-marker
boot system flash:c3745-spservicesk9-mz.124-23.bin
boot-end-marker
!
card type t1 0 0
card type t1 0 1
logging buffered 4096 debugging
logging console emergencies
!
no aaa new-model
memory-size iomem 25
clock timezone est -5
clock summer-time EDT recurring
no network-clock-participate slot 1 
no network-clock-participate slot 2 
no network-clock-participate slot 3 
no network-clock-participate wic 0 
no network-clock-participate wic 1 
voice-card 1
 no dspfarm
!
voice-card 2
 dspfarm
!
voice-card 3
 dspfarm
!
ip cef
!
!
!
!
no ip domain lookup
!
 
username cs privilege 15 password 7 <removed>
username admin privilege 15 password 7 <removed>
!
!
controller T1 0/0
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 1 timeslots 1-24 speed 64
!
controller T1 0/1
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 1 timeslots 1-24 speed 64
!
controller T1 0/2
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 1 timeslots 1-24 speed 64
!
controller T1 0/3
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 1 timeslots 1-24 speed 64
!
controller T1 2/0
 framing sf
 linecode ami
!
controller T1 2/1
 framing sf
 linecode ami
!
controller T1 3/0
 framing sf
 linecode ami
!
controller T1 3/1
 framing sf
 linecode ami
!
!
!
!
interface Multilink1
 description TC MLPPP
 ip address 207.xxx.xxx.xxx 255.255.255.252
 ip access-group 109 in
 ppp multilink
 ppp multilink fragment delay 500
 ppp multilink group 1
!
interface FastEthernet0/0
 ip address 64.xxx.xxx.xxx 255.255.255.240 secondary
 ip address 66.xxx.xxx.xxx 255.255.255.240
 duplex auto
 speed auto
!
interface Serial0/0:1
 description TWTC Multilink Interface #1
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1:1
 description TWTC Multilink Interface #2
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/2:1
 description TWTC Multilink Interface #3
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3:1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 207.xxx.xxx.xxx
!
!
no ip http server
no ip http secure-server
!
access-list 109 deny   53 any any
access-list 109 deny   55 any any
access-list 109 deny   77 any any
access-list 109 deny   pim any any
access-list 109 permit ip any any
!
!
!
control-plane
!
banner motd ^C
-------------------------------------------------------------------------
 
--------------------------------------------------------------------------
^C
!
line con 0
 exec-timeout 5 0
 logging synchronous
 login local
line aux 0
 exec-timeout 5 0
 logging synchronous
 login local
line vty 0 4
 exec-timeout 5 0
 logging synchronous
 login local
!
ntp clock-period 17179616
ntp server 192.5.41.209
!
end
 
 
 
 
 
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2009.10.23 13:18:01 =~=~=~=~=~=~=~=~=~=~=~=
CORE ROUTER - 3845
 
 
User Access Verification
 
 
Username: rrrr
Password: 
EastMain_3845#show ver
Cisco IOS Software, 3800 Software (C3845-SPSERVICESK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Wed 30-Apr-08 20:18 by prod_rel_team
 
ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
 
EastMain_3845 uptime is 31 weeks, 4 days, 14 hours, 18 minutes
System returned to ROM by reload at 22:52:58 EDT Sun Mar 15 2009
System restarted at 22:54:37 EDT Sun Mar 15 2009
System image file is "flash:c3845-spservicesk9-mz.124-15.T5.bin"
 
 
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
 
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
 
If you require further assistance please contact us by sending email to
export@cisco.com.
 
Cisco 3845 (revision 1.0) with 224256K/37888K bytes of memory.
Processor board ID FTX1214A2NF
2 Gigabit Ethernet interfaces
18 Serial interfaces
13 Channelized T1/PRI ports
DRAM configuration is 64 bits wide with parity enabled.
479K bytes of NVRAM.
62720K bytes of ATA System CompactFlash (Read/Write)
 
Configuration register is 0x2102
 
EastMain_3845#show run
Building configuration...
 
Current configuration : 9534 bytes
!
! Last configuration change at 13:04:14 EDT Fri Oct 23 2009 by admin
! NVRAM config last updated at 20:05:47 EDT Mon Jul 20 2009 by admin
!
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname EastMain_3845
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
card type t1 0 1
card type t1 0 2
card type t1 1 0
card type t1 1 1
card type t1 2 0
card type t1 2 1
logging buffered 4096 warnings
enable password 7 104D000A0618
!
no aaa new-model
clock timezone est -5
clock summer-time EDT recurring
no network-clock-participate slot 1 
no network-clock-participate slot 2 
no network-clock-participate wic 0 
no network-clock-participate wic 1 
no network-clock-participate wic 2 
dot11 syslog
ip wccp 25
!
!
ip cef
!
!
no ip domain lookup
ip domain name .org
ip multicast-routing 
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
 
crypto pki trustpoint TP-self-signed-3899871635
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3899871635
 revocation-check none
 rsakeypair TP-self-signed-3899871635
!
!
crypto pki certificate chain TP-self-signed-3899871635
 certificate self-signed 01
  
  	quit
!
!
 
archive
 log config
  hidekeys
!
!
controller T1 0/0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 0/0/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 0/1/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 0/1/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 0/2/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 1/0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 1/0/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 1/1/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 1/1/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 2/0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 2/0/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 2/1/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 2/1/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24
!
!
class-map match-all mediumpriority
 match access-group 151
class-map match-all highpriority
 match access-group 150
class-map match-all l3-to-l2-voice
 match ip dscp ef 
class-map match-all l2-to-l3-voice
 match cos  5 
class-map match-all l3-to-l2-control
 match ip dscp af31 
class-map match-all l2-to-l3-control
 match cos  3 
!
!
policy-map output-l3-to-l2
 class l3-to-l2-voice
  set cos 5
 class l3-to-l2-control
  set cos 3
policy-map input-l2-to-l3
 class l2-to-l3-voice
  set ip dscp ef
 class l2-to-l3-control
  set ip dscp af31
policy-map 896Voice
 class highpriority
  priority 896
 class mediumpriority
  bandwidth 154
 class class-default
  fair-queue
policy-map voicepriority
 class highpriority
  priority 768
 class mediumpriority
  bandwidth percent 10
 class class-default
  fair-queue
!
!
!
!
!
interface Loopback0
 ip address 10.239.201.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface GigabitEthernet0/0
 description LAN Connection to  Core
 ip address 10.239.1.1 255.255.255.0
 ip wccp 25 redirect out
 duplex full
 speed 100
 media-type rj45
!
interface GigabitEthernet0/0.101
 encapsulation dot1Q 101
 ip address 10.239.101.1 255.255.255.0
 ip helper-address 10.239.1.35
 ip pim sparse-dense-mode
 service-policy input input-l2-to-l3
 service-policy output output-l3-to-l2
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface Serial0/0/0:1
 description connection to LP
 ip address 10.239.110.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 service-policy output 896Voice
!
interface Serial0/0/1:1
 description connection to Mo
 ip address 10.239.111.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 service-policy output 896Voice
!
interface Serial0/1/0:1
 description connection to Dr
 ip address 10.239.112.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 service-policy output 896Voice
!
interface Serial0/1/1:1
 description connection to Ea
 ip address 10.239.113.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 service-policy output 896Voice
!
interface Serial0/2/0:1
 description to We
 ip address 10.239.119.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 load-interval 30
 service-policy output 896Voice
!
interface Serial1/0/0:1
 description connection to Le
 ip address 10.239.120.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial1/0/1:1
 description connection to Camp
 ip address 10.239.122.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial1/1/0:1
 description connection to Easts
 ip address 10.239.123.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial1/1/1:1
 description connection to High
 ip address 10.239.114.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial2/0/0:1
 description connection to Thurs
 ip address 10.239.115.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial2/0/1:1
 description connection to Arro
 bandwidth 1544
 ip address 10.239.116.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial2/1/0:1
 description connection to Bay
 ip address 10.239.117.1 255.255.255.0
 ip pim sparse-dense-mode
 no ip mroute-cache
 serial restart-delay 0
 service-policy output 896Voice
!
interface Serial2/1/1:1
 no ip address
!
router eigrp 100
 network 10.0.0.0
 auto-summary
!
no ip classless
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.239.1.3
ip route 10.1.0.0 255.255.0.0 10.239.1.11
ip route 10.2.0.0 255.255.0.0 10.239.1.11
ip route 10.50.0.0 255.255.0.0 10.239.1.11
ip route 10.239.18.0 255.255.255.0 10.239.1.11
!
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip pim rp-address 10.239.201.1
ip pim send-rp-announce Loopback0 scope 16
!
access-list 10 permit 10.239.0.0 0.0.255.255
access-list 11 permit 10.239.1.0 0.0.0.255
access-list 23 permit 10.239.125.0 0.0.0.255 log
access-list 23 permit 10.239.1.0 0.0.0.255 log
access-list 150 permit ip any any dscp ef
access-list 151 permit ip any any dscp af31
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
!
!
!
!
!
banner motd ^CC
 -- --------------------------------------------------------------
 
--------------------------------------------------------------
^C
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 password
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17180219
ntp server 192.5.41.209
!
end
 
EastMain_3845#           exit
ASKER CERTIFIED SOLUTION
hus1984

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 2 Answers and 12 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 12 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros