Slow Netgear WNDR3700 wireless N speeds

BTMExpert
BTMExpert used Ask the Experts™
on
I set up my WNDR3700 Netgear and have it connected to my gigabit iomega home media server and macbook air


but I can't seem to get a transfer speed of more then 5 MB/s

according to this review it should be much faster
http://www.smallnetbuilder.com/wireless/wireless-reviews/30925-start-your-buying-netgear-wndr3700-reviewed
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Well your 5 MB/s is about 40 Mbps... (mega bytes vs mega bits)... so it doesn't seem that awful to me compared to a lot of their charts.

Author

Commented:
but I thought it would go 300 Mbps

and 40 is alot lower then 300

Commented:
That is just maximum theoretical throughput. There is some overhead in network connections that takes up some of the other data - not to mention signal strength and other things.

Not to mention that specific router is "dual band" and their estimate of 350 mbps is actually a combined throughput if both wireless bands are operating at the same time. (top of page 5)
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

Author

Commented:
ok I just turned off WPA and my speed jumped up to 11 MBps

Author

Commented:
ok I turned on WPA2 on wireless N and now it seems to stay around 9MBps

Commented:
Well 9 MB/s would get you around 72 Mbps... so that's quite a bit better than where you were and close to the higher end of some of their charts.

Author

Commented:
is there anything I can do to eek out more performance between the macbook air and router?

Commented:
Is your bluetooth on? Apparently having that on and the wireless can take away a tiny bit of performance... of course, if you need to use the bluetooth, you're kind of limited there. But Apple does have an article for it, if you can try any of the solutions.

http://support.apple.com/kb/TS1809

I would also make sure your software is completely up to date using the Software Update. There have been a few updates here and there for some hardware that will improve performance as well.

Author

Commented:
yep uptodate on software update and never have BT turned on
Hi,

You'll need to check whether the client TCP/IP properties such as MTU (Maximum Transmission Unit) are configured in-line with your Internet speed.

Warm regards,
Sarang

Author

Commented:
my internet speed isn't slow its my transfer rate from one computer to the other would I check on the MTU on the router or on the macbook air
That will be on your client, not the router. Sorry for not making that clear earlier.

Regards,
Sarang

Author

Commented:
yep checked and they are both set to MTU 1500
You may check your settings with one of the system optimization utilities, if you have access to one.
They typically have a section for Internet Speed Optimization.

Author

Commented:
this isn't an internet issue its a network transfer speed from one computer to the other
OK.
Basically Internet optimization is just a name; what is basically done by these utilities is the optimization of settings of your network card, depending on your network connection speeds. (Dial-up/ DSL/ T1/ LAN, etc.)
You may also find this link useful for a few real world experience:
http://forums.whirlpool.net.au/forum-replies-archive.cfm/982074.html

Author

Commented:
I have been able to get up to 11.4 MB peak  which is the same as 91 Mb which is still no where near 300 Mb

does the macbook air have a 5 ghz wireless n card?
is there any way to make sure I am connecting using the 5 ghz connection? or is there a way to see at what rate I am connected? from the macbook air

on windows machines it will normally tell you the speed your connected at but I don't see that anywhere in OSX
Jackie Man IT Manager
Top Expert 2010

Commented:
What is the distance between your Macbook Air and Netgear WNDR3700?

Which OS X version are you using? Do you have another Macbook or iMac running at your home?

The slow performance seems to come from the network driver of your Macbook AIr.

From my findings, it seems that the network driver in your Macbook air is outdated and the driver restrict the speed of wireless network connection and make it not possible to run in 5 ghz mode (it is a bug, I think).

Try to locate a newer driver for wireless network and you shall be fine.

Source: http://forums.macrumors.com/showthread.php?t=578932

Author

Commented:
I am about 15 feet away with line of site

I am on leopard and this is the only mac I have

which driver version are they discussing and how can I tell if I a have the same driver?
Jackie Man IT Manager
Top Expert 2010

Commented:
Can you see the "5 ghz" status light on the front panel of WNDR3700 is ON?
WNDR3700-SM-28May09.pdf
Front-Panel-of-WNDR3700.jpg
Jackie Man IT Manager
Top Expert 2010

Commented:
Do you know your version of OS X? If no, please follow the procedure below to check.

1. Click the Apple menu
2. Select About this Mac
3. The version number will be displayed on the second line of text

After knowing the version, I will try to locate a suitable driver for you.

Author

Commented:
the light is lite and solid blue

I have 10.5.8

my nic card is this

  Wireless Card Type:      AirPort Extreme  (0x14E4, 0x8B)
  Wireless Card Locale:      USA
  Wireless Card Firmware Version:      Broadcom BCM43xx 1.0 (5.10.91.19)
  Current Wireless Network:      HomeN
  Wireless Channel:      161
Jackie Man IT Manager
Top Expert 2010

Commented:
According to the threads in a discussion forum, the update of OS X 10.5.8 has restricted the connection to 802.11n router. So, you are running at 802.11g now (automatically fall back to 802.11g as your router is operated in a dual mode of 802.11g / 802,11n). So, the speed is much lower than you expect.

Source: http://www.xlr8yourmac.com/feedback/OSX_10_5_8_feedback.html

I am still looking for a fix for the above and will keep you informed.

Author

Commented:
if I was to upgrade to snow leopard would it fix the speed issue?
Jackie Man IT Manager
Top Expert 2010

Commented:
DO NOT Upgrade to Snow Leopard. There are many threads of wifi problems in discussion forum.

Is the problem occurred after updating to 10.5.8?
Jackie Man IT Manager
Top Expert 2010

Commented:
Maybe you can set your router to sue 5 GHz mode only as there is an article saying that there is interference between 2.4 GHz and 5 GHz for Macbook Air.

Source: http://www.macworld.com/article/131878/2008/01/macbookair.html

P.S. I do not own a Macbook and only had an old iMac (manufactured in 1998) which I did not use now. My answer above is just from my PC knowledge about Wifi.

Author

Commented:
I need the other antenna on because thats how my other devices like iphone and other computers hook up
this macbook air is the only device I have that is N as of right now

is there any settings you would recommend on the WNDR3700 Netgear to accomplish what your talking about but still allow my other devices to hook up?
Jackie Man IT Manager
Top Expert 2010

Commented:
If you will NOT run your Macbook Air with battery (i.e. no power adapter attached), you need NOT rollback the driver to the status of 10.5.7 as the driver issue only affect the network speed when no power adapter is attached.

In order to benchmark your Airport client speed of your Macbook Air, it is better that you go to http://speedtest.net/ to test your connection speed with battery and with power adapter.

From the attached review of a Netgear WNDR3700 (in Chinese only, sorry), it seems that you are using single antennae of your router (11Mb/s = 90Mbps). Besides, from the User manual, it says that in order to prevent interference from other devices, you need to set the router to Channels 1, 6, and 11.

Finally, according to a review of Macbook Air by engadget.com, Macbook air  transferred data at about 3-4MBps, and your results of 11MBps is not bad at all. Of course, you got a much advanced router than D-Link Wireless N router.

Source:  http://www.engadget.com/2008/01/25/macbook-air-review/
Netgear-WNDR3700.pdf

Author

Commented:
so test it with the power cord
and then unplug the cord and test it again

on speedtest.net?

Jackie Man IT Manager
Top Expert 2010

Commented:
Furthermore, I locate a setting of Airport Express for enabling the "Use wide channels" option in the AirPort Utility when using the 5 GHz radio.

-> AirPort Utility > Manual Setup > Wireless tab > Wireless Options -> enable the "Use wide channels" option

Source: http://discussions.apple.com/thread.jspa?messageID=9957638

I have no more idea and cannot test the results and there is no special setting of the router if you want to use a mixed mode of 801.11g and 802.11n.

Wish you get a boost in the performance of your iomega home media server.
Jackie Man IT Manager
Top Expert 2010

Commented:
so test it with the power cord
and then unplug the cord and test it again
on speedtest.net?
YES

Commented:
"I have been able to get up to 11.4 MB peak  which is the same as 91 Mb which is still no where near 300 Mb"

Like I already said... the 300Mbps is a COMBINED total of the two radios. So one system working on 2.4GHz and one other system working on 5GHz. You're not going to come anywhere near that.

Throughput of an 802.11n connection is typically 50-160 Mbps. But I wouldn't ever count on that 160 because it is merely theoretical.

Honestly if you're in the 90s... that is GOOD.

http://en.wikipedia.org/wiki/IEEE_802.11#802.11n
http://80211n.com/80211n-speed.html

Author

Commented:
so they are saying 150 Mb/s over 5Ghz
and 150 Mb/s over 2.4Ghz

on this review http://www.smallnetbuilder.com/wireless/wireless-reviews/30925-start-your-buying-netgear-wndr3700-reviewed

when they talk about getting connected at 300Mb/s is their card connected over 5ghz and 2.4ghz at the same time?
can one actually transfer a file at 300Mb/s when one is connected at that speed

on the forum where they reviewed it they keep mentioning being connected at 300Mb/s
http://forums.smallnetbuilder.com/showthread.php?t=2190&page=19

Jackie Man IT Manager
Top Expert 2010

Commented:
It is the difference between a PC and a Mac. In Windows XP or Vista, it will show a theoretical value in the connection icon and it is not the actual speed of connection.

Maybe the Wifi N driver of Macbook Air is still draft N standard.

It is a compatibility issue between the router and your Macbook Air.
IT Manager
Top Expert 2010
Commented:
As explained earlier, you need to switch to 5Ghz N-only mode if you want higher speed. For details, please see http://forums.macrumors.com/showthread.php?t=646758 and http://arstechnica.com/apple/news/2008/02/optimize-your-network-to-keep-up-with-the-macbook-air.ars 

But, you cannot do that due to the need to connect to iPhone and other device. There are interference between 2.4GHz and 5GHz and there are many home appliance which make use of the 2.4GHz such as indoor wireless telephone.

Your results is already good.

Author

Commented:
when I go to my aiport utility it doesn't give me the ability to enable the "Use wide channels" option

if I were to do that would it increase my speed?

Author

Commented:
hmm wow look at these numbers
http://arstechnica.com/apple/news/2007/06/speed-test-airport-extreme-lives-up-to-its-name.ars

I am starting to think that this 90 Mb/s issue is a Apple issue not a netgear issue
Jackie Man IT Manager
Top Expert 2010

Commented:
Yes, you are correct. You may need a Netgear IEEE802.11n USB adaptor.

I do not own a Macbook and cannot help you to dig out the option. The forum just mention about "Manual Setup > Wireless tab > Wireless Options".

Author

Commented:
maybe I should repost this with a new focus using the info that has now been uncovered about macbooks
Jackie Man IT Manager
Top Expert 2010

Commented:
What you should look is the figures in the second table below. The first table describes about the wired Gigabit LAN and LAN connection.

Connection      GHz band      Max Mbps      MB/s      Mbps      Avg sec
802.11n-only      5      300      11      92      33
802.11a/n      5      300      11      92      34
802.11n-only      2.4      130      8.8      74      44
802.11b/g/n      2.4      130      9      75      45
Wireless g-to-n      2.4      130      2.1      18      174
UFO 802.11g      2.4      54      3.3      28      109

From the above, your results of 11MB/s should be OK.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial