ActiveSync 0x85010014 over the air

Justin Goo
Justin Goo used Ask the Experts™
on
Hi gang,

I've got a client, who is using a Verizon mobile phone running Windows Mobile 6 on it.   We set it up so that he could connect to the Exchange Server over the air.   The server is a Windows 2003 SBS machine running Exchange 2003.  

Everything was working perfectly.   Until he decided he wanted to back up his files onto his PC.   So when he connected the PC USB Cable, he set up a second sync source (the PC).  

Now when he tries to ActiveSync over the air, we get an error code: 0x85010014

We tried deleting both sync sources and recreating the Exchange sync, but it didn't fix the problem.
We took it down to Verizon and tried a hard reset of the phone, but again it didn't fix the problem.  Verizon even tried configuring some brand new phones, but it didn't work, so they are saying the problem is on our end. But our end WAS working, so I don't really think it's a problem with the Exchange Server.

Anyone got any ideas?   It's really frustrating him.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
/Exchange has SSL required in IIS?
Justin GooPresident

Author

Commented:
I tried it both ways, with required SSL turned on, and then tried turning it off.  It didn't work either way.   So I turned it back on again.
Commented:
It can't be on.  It won't work, unless you do a series of registry hacks and creating a NON-SSL version.

Follow this, then look at the event log for errors when you try an dsync.

http://support.microsoft.com/kb/817379
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Justin GooPresident

Author

Commented:
Yes, but it didn't work when I turned it off either.

Plus the sync was working before.
Awarded 2009
Top Expert 2010

Commented:
Double check your server settings against this document from alanhardisty: http://www.it-eye.co.uk/faqs/readQuestion.php?qid=1

there is no need to make any registry changes to make this work.

If your using a self signed SSL certificate then you will run in to problems. Godaddy.com have some great offers on SSL certificates at the moment.

If you don't have an SSL Certificate and you turn SSL on then it won't work!

Commented:
MS KB 817379
0x85010014 is HTTP 500 error message if we check the IIS logs.

To further isolate the issue, could you try and create a new profile for Exchange ActiveSync on the Mobile Device for another user (new user mayb) and check if the same code is returned.

You can also run a ActiveSync test at https://testexchangeconnectivity.com and let us know the results.

Let us know how it goes.

Justin GooPresident

Author

Commented:
I ran the connectivity test at https://testexchangeconnectivity.com

Here are the results:
Testing Exchange ActiveSync
 Exchange ActiveSync test Failed
 Test Steps
 Attempting to resolve the host name lkhawaii.com in DNS.
 Host successfully resolved
 Additional Details
 IP(s) returned: 64.65.85.74

Testing TCP Port 443 on host lkhawaii.com to ensure it is listening and open.
 The port was opened successfully.
Testing SSL Certificate for validity.
 The certificate passed all validation requirements.
 Test Steps
 Validating certificate name
 Successfully validated the certificate name
 Additional Details
 Found hostname lkhawaii.com in Certificate Subject Common name

Validating certificate trust for Windows Mobile Devices
 The test passed with some warnings encountered. Please expand additional details.
 Additional Details
 Certificate is only trusted on Windows Mobile 5.0 AKU2 (MSFP) and later. Windows Mobile 5.0 devices will not be able to sync. Root = E=info@valicert.com, CN=http://www.valicert.com/, OU=ValiCert Class 2 Policy Validation Authority, O="ValiCert, Inc.", L=ValiCert Validation Network

Testing certificate date to ensure validity
 Date Validation passed. The certificate is not expired.
 Additional Details
 Certificate is valid: NotBefore = 7/31/2009 1:36:57 AM, NotAfter = 7/31/2011 1:36:57 AM"



Testing Http Authentication Methods for URL https://lkhawaii.com/Microsoft-Server-Activesync/
 Http Authentication Methods are correct
 Additional Details
 Found all expected authentication methods and no disallowed methods. Methods Found: Basic

Attempting an ActiveSync session with server
 Errors were encountered while testing the ActiveSync session
 Test Steps
 Attempting to send OPTIONS command to server
 OPTIONS response was successfully received and is valid
 Additional Details
 Headers received: MicrosoftOfficeWebServer: 5.0_Pub
Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Tue, 27 Oct 2009 00:13:11 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET



Attempting FolderSync command on ActiveSync session
 FolderSync command test failed
  Tell me more about this issue and how to resolve it
 Additional Details
 Exchange ActiveSync returned an HTTP 500 response.
Justin GooPresident

Author

Commented:
It did turn out to be KB817379.
Which really makes no sense, because it WAS working about 2 months ago.   I have no idea what changed, but after going through the KB again, it started working again.  So I'm confused.  But as long as it's working I'm fine...

Thanks Guys.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial