AIX -oslevel errors

sgangenamoni
sgangenamoni used Ask the Experts™
on
Hello
I am having some issue with some module not loaded
root@cscp06sam001 # oslevel -s
Could not load program /usr/opt/freeware/bin/rpm:
        Dependent module /sybase/OCS-12_0/lib/libintl.a(libintl.so.1) could not be loaded.
        Member libintl.so.1 is not found in archive
6100-03-01-0921

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2013
Top Expert 2013
Commented:
Hi,

please check your LIBPATH setting.
 
It seems that your LIBPATH variable points to a path containing a libintl which came with Sybase.

It looks quite like you issued the oslevel command as a Sybase DB user, and not root - root should never have a nonstandard LIBPATH (i.e. variable should be unset).

So please try the oslevel command as root. If it doesn't work either, unset root's LIBPATH (now and for the future) and try again.

wmp




Top Expert 2015
Commented:
LIBPATH=/usr/lib oslevel -r
Most Valuable Expert 2013
Top Expert 2013

Commented:
/usr/lib is a standard location - no need to put it in LIBPATH unless you want a different location to be searched first.
oslevel -r shows the  Maintenance Level (Technology Level since 5300-05 or so),
oslevel -s shows the Service Level.
Top Expert 2015

Commented:
Main problem is that LIBPATH of /usr/lib is prepended by /sybase/OCS-12_0/lib
Resetting helps...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial