ClickOnce Publish error

TaibaDXB
TaibaDXB used Ask the Experts™
on
Hi.
I am trying Visual studio 2010 Beta 2, I have opened our application in VS 2010, everything works fine, but when I try to publish our application using ClickOnce I get the following error:
"Error      150      MSB3134: The permission set requested by the application exceeded the permissions allowed by the Internet or Intranet zones. Select Full Trust or to continue using partial trust, define your custom permission set in the Security Page of the Project Designer"
I have selected Full Trust but I am still getting this error!!
Any idea what is happening?
Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you tried running VS2010 as Adminstrator?

Author

Commented:
Thanks for your reply.
I have tried it as Administrator, but it is giving the same error.
I created a new default windows forms application & tried to publish it & the publish was successful.
I can publish my application from VS2008 successfully on the same computer!!
sounds like something got corrupted in your project settings.
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

Mohamed OsamaSenior IT Consultant

Commented:
Please take a look at the below link , should hel;p you solve the corrupt security settings in your application
http://blogs.msdn.com/krimakey/archive/2009/05/20/where-did-my-permission-set-controls-go.aspx


Author

Commented:
I have already checked this article before, but this one doesn't apply to my case because I am already using the Full Trust option.

Commented:
At the time of publishing the application the certification key is generated in setup. If that is different then also you can not publish it from other machine.
In newer application, setup is published from your own machine first time so its working fine.
Commented:
The problem is solved by only deleting:
app.manifest
which is located in the Properties folder!!
It seems it is a small bug of VS 2010 Beta 2 !!!
Thank you all.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial