vSphere 4 "HA and Network redundancy"

Quixtos
Quixtos used Ask the Experts™
on
Hello,

pls help me, i need a guide how i must configure each host in my cluster to enable ha. if i want to enable ha on my cluster i recive the messages.

Insufficiet resources to satisfy HA fialover level on cluster host.domain.local in domain.local
Unable to contact a primery HA agent in cluster host.domain.local in domain.local
HA agent on xxx.xxx.xxx.xxx in cluster host.domain.local in domain.local has an error:
cmd addnode failed for secondary node: Internal AAE Error - agent could not start.: Unknown HA error

pls help me i want to go HOME! :)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
first make sure you have dns setup on both hosts and entries in your DSN zone for both esx servers. Then make sure you can ping them by name.

Then have a look at this
http://www.virtualizationadmin.com/articles-tutorials/vmware-esx-articles/vmotion-drs-high-availability/configure-vmware-high-availability-vmha.html

Author

Commented:
i have create the cluster using only the ip adresses of the 2 esx hosts. is it necessary to use a dns name for each server to activate the ha feature? If yes i think i must recreate the cluster using dns names.
Commented:
the esx servers need to be able to talk to each other via host name(dns).

Or you can modify the local "host" file on each esx box. No need to recreate the cluster though. Using the ip to build the cluster is fine. But for HA to work name resolution has to be functional on both esx hosts.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
ok then i must check the hosts. sorry i´am not a vmware professional :(

back soon with more information

Author

Commented:
oh my god! by default the esx server refuse access with putty? i use my root user and password but i cannot login.

Commented:
that is correct. you can either create a new user the VIC and allow root access. Or change the access for root.

See this http://communities.vmware.com/thread/72736

Author

Commented:
ok. i´am now in the office to configure the hosts files. i set up the hosts file for each host an can ping from esx1 the esx2 and from esx2 the esx1.

now i try to enable ha. i hope it will work now but "Configuring HA" hung by 84%. Not good.

Author

Commented:
ok now i recive the following message in VSphere Client (Cluster)

Configuration Issues
Insufficient recources to satisfy HA failover level on cluster.domain.local in domain.local
Host xxx.xxx.xxx.xxx currently has no management network redundancy

Author

Commented:
My Network config on each host.
network.png

Author

Commented:
for a non linux guy it is not easy to understand.

Commented:
do you have another phyiscal nic that you can add to vswitch0?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial