how to access the shell of a centos VM in VPC2007 without networking?

xoundboy
xoundboy used Ask the Experts™
on
I have just installed a Centos 5.3 VM under VPC2007 and I then set the runlevel in inittab to 5 so that it reboots into Gnome. Unfortunately VPC doesn't display the Gnome desktop because it doesn't support 24bit graphics so I can't actually use the VPC console to control this VM now - the display is screwed up. Also, networking has not been configured so I can't login to the shell either to edit eh /etc/X11 file to change the bit depth of the Centos display. Now I'm completely stuck! Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
1- use the boot media (iso file) of your distro to access root shell.

2- edit /etc/inittab file. Look for the following line
id:5:initdefault:
Change the 5 to 3. Save and restart.

You will now boot each time to level 3. If you don't have the media, use boot options in Grub. Type "Single" and enter to boot into Single mode.

Author

Commented:
Hi

thanks for the response and sorry for the delay

I've just tried both of your approaches but can't get either one to work.

I mounted the Centos install CD but couldn't find a way of accessing the root shell - all I could see is different installation methods - no way of just booting the existing install

I tried typing Single into the grub command line but it says unrecognised command.

Author

Commented:
yes, that worked! great! thanks a lot

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial