troubleshooting Question

only legacy NIC works in VM for hyper-v

Avatar of thefumbler
thefumbler asked on
Networking Hardware-OtherMicrosoft Virtual Server
12 Comments1 Solution1722 ViewsLast Modified:
Only the legacy Network adapter seems to work for my Hyper-V VM install not the regular VM Network Adapter.  

I'm using 64 bit Windows 2008 SP1 on an HPML370 G6 with a 4 port HP NC375i (Integrated Quad Port Multifunction Gigabit Server Adapter)  and Hyper-V with ALL patches installed.    I first tried install a brand new VM with a XP 64 bit OS (eventually discovered I had to install SP2 before integration services could be installed) and have since backed down to with a WinXP 32 bit OS  where integration services installs immediately just to rule out any driver issues, but neither of which seems to work with the virtual network adapter.  

I have one port for the physical box and one port for the vm, and have tried combining and switching ports and different network configurations but no matter what I do, I only have very basic network connectivity such as ping, but no web browsing, ftp or telnet to any ports on any server I've tried, on the host or on the subnet or on the internet.   I'm obtaining network settings via DHCP which retrieves settings fine and is similar to all other working physical clients.   So WINS and DNS work and I can ping local and internet hosts successfully with either a FQDN or a netbios name (for local).   All firewalls are turned off for testing and the physical switch is a simple gigabit switch with no vlans at all except the default.

Though I tried removing the network adapter from system devices in the vm, in the end the temporary solution for the 32bit OS to get it working was to remove the VM Network Adapter and install the legacy Network Adapter - once I did that full network connectivity was restored - for example I was able to apply all patches.   I even tried one last time after all patches were installed to remove the legacy and use the regular adapter and it still did not work.  

Why does the regular vm network adapter NOT work?     I would like to get this working for the 64 bit eventually and I believe I tried it but don't think the legacy adapter worked -is it even supported with XP 64 bit OS vm?
ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 1 Answer and 12 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 12 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros