Nortel Contivity VPN Client problem under Windows 7

Firebladeboy1993
Firebladeboy1993 used Ask the Experts™
on
Hi There,

I'm trying to migrate a few of my critical apps to Win 7.  All seems decent so far apart from a VPN  Client called Contivity from Nortel.  When I run this (in whatever compatibility mode) I get a 10048 Failed to Create socket message.

I realise from research that something else is using an address that Contivity is trying to use but my question is how can I find out what so I can disable it?

Thanks in advance,

KGW
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dmitriy Ilyinsenior system administrator

Commented:
Create socket failed with 10048.

This problem generally will occur whenever you have another VPN client software installed on the system. The most noted conflicting clients are: AOL, Cisco VPN Client(s), SSH Sentinel and PGP.

Action
1. Removing these clients will in most cases, resolve the issue.
============================================================

If you have not such apps (see above), then trobleshuting must something like following:
1. Open TCPView (sysinternals) and search apps that hold 500, 47 ports or port that you configured in NC VPN.
2. Search exe file that open this port
3. Rename/uninstall relaited app.
4. reboot.

Author

Commented:
Hi and thanks for th suggestions.  I don't have any of those apps installed.
Sorry, where do I find TCPView?  Also I don't know the ports that Nortel Contivity client uses, they aren't specifically manually configured. I'll try and research that and post further. Cheers, KGW
Dmitriy Ilyinsenior system administrator

Commented:
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Author

Commented:
OK, here's what TCP View told me:

System:4      TCP      KenWilliams-PC:wsd      KenWilliams-PC:0      LISTENING      
[System Process]:0      TCP      KenWilliams-PC:wsd      localhost:49523      TIME_WAIT      
[System Process]:0      TCP      KenWilliams-PC:wsd      localhost:49524      TIME_WAIT      
[System Process]:0      TCP      KenWilliams-PC:wsd      localhost:49522      TIME_WAIT      
svchost.exe:1396      UDP      KenWilliams-PC:ws-discovery      *:*            
svchost.exe:1396      UDP      KenWilliams-PC:ws-discovery      *:*            
svchost.exe:3400      UDP      KenWilliams-PC:ws-discovery      *:*            
svchost.exe:3400      UDP      KenWilliams-PC:ws-discovery      *:*            
svchost.exe:3400      UDP      KenWilliams-PC:ssdp      *:*            
svchost.exe:3400      UDP      kenwilliams-pc:ssdp      *:*            
System:4      TCP      kenwilliams-pc:netbios-ssn      KenWilliams-PC:0      LISTENING      
System:4      UDP      kenwilliams-pc:netbios-ns      *:*            
System:4      UDP      kenwilliams-pc:netbios-dgm      *:*            
System:4      TCP      KenWilliams-PC:microsoft-ds      KenWilliams-PC:0      LISTENING      
svchost.exe:1504      UDP      KenWilliams-PC:llmnr      *:*            
svchost.exe:1256      UDP      KenWilliams-PC:isakmp      *:*            
svchost.exe:1256      UDP      KenWilliams-PC:ipsec-msft      *:*            
svchost.exe:1028      TCP      KenWilliams-PC:epmap      KenWilliams-PC:0      LISTENING      
svchost.exe:1176      UDP      KenWilliams-PC:bootpc      *:*            
svchost.exe:1176      UDP      KenWilliams-PC:bootpc      *:*            
svchost.exe:1396      UDPV6      kenwilliams-pc:62501      *:*            
svchost.exe:1396      UDP      KenWilliams-PC:62500      *:*            
iexplore.exe:3916      UDP      KenWilliams-PC:61699      *:*            
svchost.exe:1396      UDPV6      kenwilliams-pc:61532      *:*            
svchost.exe:1396      UDP      KenWilliams-PC:61531      *:*            
iexplore.exe:2824      UDP      KenWilliams-PC:58568      *:*            
svchost.exe:3400      UDPV6      kenwilliams-pc:58275      *:*            
svchost.exe:3400      UDP      KenWilliams-PC:58274      *:*            
svchost.exe:1176      UDPV6      kenwilliams-pc:546      *:*            
svchost.exe:3400      UDP      KenWilliams-PC:54040      *:*            
svchost.exe:3400      UDP      kenwilliams-pc:54039      *:*            
svchost.exe:3400      UDPV6      kenwilliams-pc:54037      *:*            
System:4      TCPV6      kenwilliams-pc:5357      kenwilliams-pc:0      LISTENING      
svchost.exe:1504      UDPV6      kenwilliams-pc:5355      *:*            
svchost.exe:1256      UDPV6      kenwilliams-pc:500      *:*            
services.exe:528      TCP      KenWilliams-PC:49156      KenWilliams-PC:0      LISTENING      
services.exe:528      TCPV6      kenwilliams-pc:49156      kenwilliams-pc:0      LISTENING      
lsass.exe:536      TCP      KenWilliams-PC:49155      KenWilliams-PC:0      LISTENING      
lsass.exe:536      TCPV6      kenwilliams-pc:49155      kenwilliams-pc:0      LISTENING      
svchost.exe:1256      TCP      KenWilliams-PC:49154      KenWilliams-PC:0      LISTENING      
svchost.exe:1256      TCPV6      kenwilliams-pc:49154      kenwilliams-pc:0      LISTENING      
svchost.exe:1176      TCP      KenWilliams-PC:49153      KenWilliams-PC:0      LISTENING      
svchost.exe:1176      TCPV6      kenwilliams-pc:49153      kenwilliams-pc:0      LISTENING      
wininit.exe:420      TCP      KenWilliams-PC:49152      KenWilliams-PC:0      LISTENING      
wininit.exe:420      TCPV6      kenwilliams-pc:49152      kenwilliams-pc:0      LISTENING      
svchost.exe:1256      UDPV6      kenwilliams-pc:4500      *:*            
System:4      TCPV6      kenwilliams-pc:445      kenwilliams-pc:0      LISTENING      
svchost.exe:1396      UDPV6      kenwilliams-pc:3702      *:*            
svchost.exe:1396      UDPV6      kenwilliams-pc:3702      *:*            
svchost.exe:3400      UDPV6      kenwilliams-pc:3702      *:*            
svchost.exe:3400      UDPV6      kenwilliams-pc:3702      *:*            
svchost.exe:3400      UDPV6      kenwilliams-pc:1900      *:*            
svchost.exe:1028      TCPV6      kenwilliams-pc:135      kenwilliams-pc:0      LISTENING      
avgemc.exe:2056      TCP      KenWilliams-PC:10110      KenWilliams-PC:0      LISTENING      
svchost.exe:3400      UDPV6      [0:0:0:0:0:0:0:1]:54038      *:*            
svchost.exe:3400      UDPV6      [0:0:0:0:0:0:0:1]:1900      *:*            

It looks like Port 500 is allocated but inactive. It will tell me nothing about the process that's allocated that port nor allow me to terminate it. I suspect that may the Contivity service anyway.  47 doesn't appear to be mentioned.  Can anyone throw any more light on this?

Thanks,

KGW
Dmitriy Ilyinsenior system administrator

Commented:
hm... can you disable IPv6?
(http://www.mydigitallife.info/2007/09/09/disable-and-turn-off-ipv6-support-in-vista/) reboot and try to run NC VPN again?

Author

Commented:
It seems you can't stop that process running, even when IPv6 is disabled.  I disabled it globally via a DWORD in the system registry and also simply unchecked it as a protocol running on the network connections concerned. After trying that, the port still shows as allocated to the same process on TCP View and I get the same result trying to run the Contivity VPN client.
OK. Solved the problem.  I downloaded a Vista version of the Contivity Client and, by running that in XP SP3 Compatibility mode (note running it in Vista mode woudn't work - it stopped at the "Checking for banner text" stage),  I've got it working.

Thanks for the suggestions anyway.

KGW

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial