troubleshooting Question

Cisco VPN between PIX and ASA

Avatar of Bob
BobFlag for United States of America asked on
RoutersVPNCisco
44 Comments1 Solution747 ViewsLast Modified:
I am trying to create a VPN between a Cisco Pix and an ASA5505.

Being the complete novice that I am, I believe I have bungled it pretty good.

The folowing code is what I currently have.

Any assistance will be greatly appreciated.
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxx encrypted
passwd xxxxx  encrypted
hostname TWS-Pix
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside permit icmp any any
access-list TWS permit ip 172.16.1.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list LocalToChxxxxx permit ip 172.16.1.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 111.111.111.111 255.255.255.248
ip address inside 172.16.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list TWS
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outside in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set RosenbergSA-set esp-des esp-md5-hmac
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp key ******** address 222.222.222.222 netmask 255.255.255.0
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 1000
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 60
terminal width 80
: end
TWS-Pix(config)#
 
 
 
 
 
ASA Version 7.2(4)
!
hostname Chxxxxxxxxxx
enable password xxxxx encrypted
passwd xxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 222.222.222.222 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list outside extended permit ip any any
access-list split standard permit 192.168.0.0 255.255.255.0
access-list CH extended permit ip 192.168.0.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list outside_TWS_cryptomap extended permit ip 192.168.0.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list outside_in extended permit ip any any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNAccess 172.16.111.1-172.16.111.253 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list CH
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 1 set pfs
crypto dynamic-map outside_dyn_map 1 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 1 set reverse-route
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto map outside_TWS_map 91 match address outside_TWS_cryptomap
crypto map outside_TWS_map 91 set pfs group1
crypto map outside_TWS_map 91 set peer 111.111.111.111
crypto map outside_TWS_map 91 set transform-set ESP-3DES-SHA
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.0.0 255.255.255.0 inside
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 20
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.0.100-192.168.0.199 inside
dhcpd dns 192.168.0.50 4.2.2.2 interface inside
dhcpd wins 192.168.0.50 interface inside
dhcpd enable inside
!
group-policy Chxxxxxxxxxx internal
group-policy Chxxxxxxxxxx attributes
 dns-server value 192.168.0.50 4.2.2.2
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split
 default-domain value Chxxxxxxxxs
tunnel-group DefaultL2LGroup ipsec-attributes
 isakmp keepalive threshold 20 retry 2
tunnel-group DefaultRAGroup ipsec-attributes
 isakmp keepalive threshold 20 retry 2
tunnel-group Chxxxxxxxxxx type ipsec-ra
tunnel-group Chxxxxxxxxxx general-attributes
 address-pool VPNAccess
 default-group-policy Chxxxxxxxxxx
tunnel-group Chxxxxxxxxxx ipsec-attributes
 pre-shared-key *
 isakmp keepalive threshold 20 retry 2
tunnel-group 111.111.111.111 type ipsec-l2l
tunnel-group 111.111.111.111 ipsec-attributes
 pre-shared-key *
!
!
prompt hostname context
 
: end
Chxxxxxxxx#
ASKER CERTIFIED SOLUTION
bignewf

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 44 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 44 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros