troubleshooting Question

Yum Dependency Problem - Newer Version Already Installed

Avatar of flashjordan
flashjordan asked on
InstallationLinux Distributions
2 Comments2 Solutions1282 ViewsLast Modified:

I'm trying to install ImageMagick using "yum install ImageMagick", this appears to work fine, except it fails because:
package ghostscript-8.64-9.3.el5.x86_64 (which is newer than ghostscript-8.15.2-9.11.el5.i386) is already installed

Why is it failing because I have a newever version?

I can't uninstall this version because I need this new version and not the old version, plus I remember is being extremely difficult to install so I don't want to remove it and have to go through that again.

I know that ImageMagick runs with my version of ghostscript because I was running it before, I just removed ImageMagick and now I want to install it again.

How can I force ImageMagick to install?


Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 2 Answers and 2 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 2 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros