We help IT Professionals succeed at work.

Network doesnt work on restricted user first logon

tarcis
tarcis asked
on
747 Views
Last Modified: 2012-05-08
I have a weird problem.

I have set up several computers to automatically log in with a restricted user.
Sometimes (not always) when they turn on the computer for the first time, the network does not work.
It seems that it cannot get an IP from the DHCP server, but if I log off the restricted user and logon to an administrative account, the network starts working again.

Also if they restart the computer the network works again.

I tried setting a fixed ip, but the problem persists (except that it doesnt show the getting ip icon, the network just doesnt work).

BTW, this is happening on XP PRO machines.
Comment
Watch Question

It would appear the NIC is not getting a proper IP in the time allotted and as a restricted user they are not able to attempt to repair the connection (one of many possible scenarios)

Open the Event Log for System (Administrative Tools > Event Viewer > System) and post anything related
Do the same for Application
Is this Wired or Wireless connection?

Author

Commented:
It happens both on wired and wireless connections.

On the eventviewer I couldnt find anything related to that.

There are lots of erros like these on SYSTEM
SOURCE: DCOM
Id: 10005
Erro "O servio no pode ser iniciado porque est desativado ou no tem dispositivos ativados associados. " no DCOM na tentativa de iniciar o servio MDM com argumentos "" para iniciar o servidor:
{0C0A3666-30C9-11D0-8F20-00805F2CD064}

Para obter mais informaes, visite o Centro de ajuda e suporte em http://go.microsoft.com/fwlink/events.asp

But I think its only because I disabled MDM to save memory.

Dont forget that even if I specify a fixed IP the problem persists.
and the problem resolves itself on 1 or 2 restarts.
CERTIFIED EXPERT

Commented:
Can be something hardware related. Network card or cable or switch.

Author

Commented:
Yeah I thought so, BUT

4 computers are presenting this issue.
2 are on the same 8 port hub which is connect to a 24port switch, so I exchanged the hub for a 8 port switch, but problem persisted.
1 is on the same 24port switch but connected directly, and has the problem.

And the last computer is not on this network at all, its wireless using a TPlink usb adapter connect to a dlink DI-524.

BTW, thank you experts for trying to help, please dont run out of answers!! hehehe
CERTIFIED EXPERT

Commented:
4 computers out of how many?
Is Windows XP Pro updated to SP3?
Can you run couple of tests when the restricted user is auto logged in and the network is not functioning?
1. Without logging the user out run "ipconfig /all" command and post the results. You may have to use runas command, like this:
runas /user:Administrator "ipconfig /all"
2. Let the computer sit for 10 minutes then run
runas /user:Administrator "ipconfig /release"
runas /user:Administrator "ipconfig /renew"
see if this gets you on the network
How about log off that restricted user, log on again using that restricted user to make sure it does not work with the restricted user, and it works with administrative user.
It may give you the false impression when you immediately log in using the administrator account.
I doubt it's hardware failure if that many devices with those variables all show the same issue.

Sound like an odd configuration or malfunction of some type.

We could keep trouble shooting if you would like but there is a chance it will come down to reinstalling windows on those PC's.
Just putting that out there now, it may take a very long time to figure out the exact glitch if you are pressed for time I recommend reinstalling windows then all updates and service packs as this will most likely resolve the issue, if it does not that also helps determine what is causing the problem.

I will keep thinking on this

Author

Commented:
Thanks for all the replys, sorry it took me a while to answer, I was out today.

Let me see if I can answer all questions:

"4 computers out of how many?" : 20
"Is Windows XP Pro updated to SP3?" : Yes on some, im not sure if all are SP3, I will check

I will run the ipconfig tests and the logoff and log back on with restricted user tomorrow, great ideas.

Thanks for the tip stealth, but Im actually looking for a solution, there is no hurry on resolving this if it could happen again.

Thanks again experts
I understand where you are coming from tarcis just wanted to put that out there in case you had a time crunch.

Are these computers all part of a domain or a work group?
When you say restricted user account I assume that means there a work group and your using the windows restricted user setting.

Where is the DHCP server (part of a router or on a server)?
If router what brand/model?

Just as another test if you take one of the accounts that does this, change them from restricted user to power user can you replicate the problem with that account?
Also are all 4 PC's on the same address scheme?
For instance all four are 192.168.1.2-6 or 3 are 192.168.1.2-5 and one is 10.1.0.5

Author

Commented:
Are these computers all part of a domain or a work group?

Workgroup
15 are at one office where there is a domain controller, but the computers are not registered on the domain,
they just have local accounts with same name and password of the user accounts on the file server(dc).
The users are limited users on the local computer (builtin windows xp pro limited user) and same user name is limited user (built in windows server) on the file server.
I tried changing the users to power user locally, but problem persists.

The DHCP server is a DLINK WBR-2310 sending 192.168.7.50-192.168.7.100 on 255.255.255.0

Now for the interesting part.
5 computers are on another office, using workgroup
and all of them have admin rights locally, except the computer with the wireless connection, which is a limited user and is the computer that is experiencing this problem. This computer connects wirelessly to a Di-524 with dhcp disabled, so it just acts as a Access Point to a Routed SpeedTouch 510 ADSL modem with DHCP enabled, sending 192.168.1.50-192.168.1.200 on 255.255.255.0

Just remember that even If I specify a fixed ip, the problem does not go away.
When the problem happens, IF its on DHCP, the icon of the boucing yellow ball beside the clock indicating that windows is renewing the ip never stops, so I dont get a ip.
IF its a fixed ip, there is no indication of the problem, but network doesnt work, I cant ping or access the gateway, or other network resources.

Please remind me IF i forgot to answer any questions.
Thanks again.
CERTIFIED EXPERT

Commented:
Did you try physically unplugging the network cable and plugging it back in - does it clear the problem?
If not, then how about disabling network adapter then reenabling it? Or running "Repair" on it, which is essentially the same thing? For this you will probably have to use "Run As" command.
First I do have to recommend that with that many PC's you move over to a Domain, much less headache.

Do they all do this at the same time or some one day others the next kind of thing?

Does your switch have line test capabilities (to check quality of lines)?
If so test when connected and test when unable to connect

Go to Properties for one of the network cards on the PC's with issues - what connections are checked?
Client for Microsoft Networks, AEGIS, TCP/IP......

Is Windows firewall service running on these PC's?
(usually not a problem but I have seen weird things happen with windows build in firewall)

Author

Commented:
All right ! I got some news.

First thing, I confused my self on explaining some simptoms.
The bouncing ball when trying to renew the address stops after some time, and it a yellow triangle appears saying "Null conectivity or limited".

I ipconfiged /all and got ip 0.0.0.0 but DHCP and DNS server read: 192.168.7.1 (routers address).
When I tried clicking to repair the connection (on the limited/power user) i got "windows cannot repair because the following action could not be completed: renewing your ip address.

I tried calling CMD and typing ipconfig /renew and got a weird response:

error renewing interface local area connection: the system cannot find the specified file.
OMG!

Author

Commented:
I tried loging off the limited user, but when I try to log on again, the textbox for typing the password doesnt allow me to type!!!!!

I managed to logon by pressing cntrl+alt+del twice and typing manually the user name and password
did that lots of times with the limited user and didnt solve the problem

so I logged on the administrator and tried typing ipconfig /renew
got the same error message saying the system cannot find the specified file

so I unplugged the netword cable and pluged it in again, and guess what ?

the network started working again without me pressing anything
Based on the last result it makes me want to say bad NIC or Cat5 cable

Try taking some cable from one of the working PC's and switch it, see if that fixes it, that would tell us if it's the cable or NIC. Switching switches rules out the port on the switch.

Here is the KB on that error: http://support.microsoft.com/kb/915159

Author

Commented:
funny thing is this only happens if the computer is shutdown, I can restart it hundreds of times the problem does not happen again, but if I shutdown, the problem comes back sometimes (not everytime, but really often)

I am thinking the error about the DHCP service is a result of the cable/Nic failing in the connection.

I suggest switching NIC (network interface cards) and cable with a known working PC and see if that fixes it, if so then we can put the old cable on and if it still doesnt give the same results then we know it's the NIC that was bad.

Otherwise I will start investigating the DHCP error but we should rule out the hardware before proceeding
CERTIFIED EXPERT

Commented:
Looking to see if "DHCP Client service" is started is a good idea (per stealthwifi12's post).
I would also reinstall NIC drivers. Maybe updated ones...
Maximus5328 has a good point, try removing the drivers and installing updated ones for the nic before swapping out cards (should be easier)

P.S Please do not award me points once this is completed, Maximus can have them if you wish, I do not need them just want to see you get this solved :)
Almost forgot, under an admin account make sure the DHCP service is set to Automatic not manual and go to Start > Run > MSCONFIG
Services Tab > DHCP should be checked

Author

Commented:
It cant be drivers, cable or NIC, because one of the computers is WIRELESS and has the same problem.

I also already updated the NICs drivers, reinstalled and changed switch and cable.
Still same problem.

Also DHCP is checked on all pcs on msconfig.

All pcs are SP3 and the problem also happens with fixed ip
When the issue happens is DHCP running?

Control Panel > Administrative Tools > Services
&
MSCONFIG Services Tab
CERTIFIED EXPERT

Commented:
Can you confirm that the network comes right back up when the network cable get reconnected? Does this work 100% of the time?
I know that you don't think that this is a hardware problem but do try to replace the NIC in one of the problem computers. So we just stop thinking about it and move on.
tarcis any update on this?

Author

Commented:
Sorry experts, I havent been able to attend this workplace in person, I was working from a remote location, so all configs, and checks were easy to do.

I promisse I will try to replace the NIC as soon as I can, and since I am not there phisically I havent checked to see if DHCP is running when the problem happens, since I do not have remote access to the computer when it doesnt work FOR NOW.

Please check back before the end of the week for the updates.

Thanks for your patience.

Author

Commented:
News:

When the problem happens, DHCP service is AUTOMATIC and STARTED.
If I remove the cable and plug it in again, network comes back.

On 2 computers there is a new event on event viewer
A translation i made to the problem is:
O system restore filter encountered an unexpected error "0xC0000001" when processing the file "on volume 'HarddiskVolume1". Monitoring of the volume was interrupted.

"O filtro da restauração do sistema encontrou o erro inesperado '0xC0000001' ao processar o arquivo '' no volume 'HarddiskVolume1'.  O monitoramento do volume foi interrompido.

Para obter mais informações, visite o Centro de ajuda e suporte em http://go.microsoft.com/fwlink/events.asp.
"
Source: sr
id: 1

I Tried switching network cables but problem persist.
When the user have admin rights this does not happen.
CERTIFIED EXPERT
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
we´ll do!

THINK EXPERTS THINK!!!
=D
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Sorry guys, I took a little 2 week vacation, but Im back now, I will return ASAP!
Any updates on this?

Author

Commented:
I did not try reparing the XP instalattion yet.
I replaced the NIC on 1 pc and the problem persisted.

I did not try chkdsk yet.

sorry guys, this time of the year its a little slow.

Author

Commented:
Ok, sorry it took me so long.

I tried chkdsk and did not help.
The only thing I havent tried is reparing the windows installation (but thats exactly what I did not want to do, so I came here for help).

If I change the user to administrator instead of restricted or power user, the problem goes away.
Any more ideas ?

Thanks again for the patience.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks kev, stealth and max were great, but I have a feeling its a windows issue.
Since this happens also on a wireless client.

I'll try the duplex things.

Thank you all for helping, even if I dont resolve my issue I will split points for you guys
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.