We help IT Professionals succeed at work.

Exchange 2007 - SMTP Receive Connector responds with private IP address

Mc2102
Mc2102 asked
on
1,036 Views
Last Modified: 2012-05-08
Hello,

I am running Exchange Server 2007 and I the following problem. The default Receive Connector called mail.domain responds with its public IP address when I connect to it and run a HELO.
Then I have a second Receive Connector called smtp.domain.com but this one responds with its private IP address when I connect to it and it also adds the private IP address into the mail header. That is a problem since I need to relay mails to external IP addresses and the sender address will contain domain names which are not the domain names the Exchange server belongs to. And NO I am not using the server to send out spam!!!!!!

What do I need to do so the Receive Connector for smtp.domain.com responds with the public IP address?

Thank you
Mc2102
Comment
Watch Question

In Exchange Management Console
expand Server configuration
click on Hub Transport
Find your Receive Connector in the bottom pane
right click
properties
on the general tab fill in the domain name you want in the text box "Specify the FQDN this connector...."

Expert of the Quarter 2009
Expert of the Year 2009
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
I beg to differ - I am running SP1 here and what I describe above is enabled and able to be done. Thus changing the FQDN the server answers as.

I'm not sure where you get "You cannot set it to another name" as you clearly can.
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Exchange 2007 Sp1 and higher will not allow the receive connector to be set to anything other than blank, netbios or the server's FQDN. Try setting it and then apply the settings. It will not let you continue.
If you are seeing something different then your server is not working correctly.

The SEND connector will allow you to put anything you like in as the FQDN.

Simon.
I does allow it here and this MS article seems to agree with me
http://technet.microsoft.com/en-us/library/aa996395.aspx
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
You should get an error along these lines if you change the FQDN to something other than the values I have outlined.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

set-receiveconnector
Failed
Error:
When the AuthMechanism parameter on a Receive connector is set to the value ExchangeServer, you must set the FQDN parameter on the Receive connector to one of the following values: the FQDN of the transport server "server3.example.co.uk", the NetBIOS name of the transport server "SERVER3", or $null.

--------------------------------------------------------
OK
--------------------------------------------------------

Now of course, if you have gone against the best practises and modified the Default Receive Connector and removed the Exchange server authentication from the connector you will not get the error.

From http://technet.microsoft.com/en-us/library/bb125140.aspx

"Dont modify the FQDN value on the default Receive connector named Default <Server Name> that is automatically created on Hub Transport servers. If you have multiple Hub Transport servers in your Exchange organization and you change the FQDN value on the Default <Server Name> Receive connector, internal mail flow between Hub Transport servers will fail. "

Simon.
No modification, multiple receive connectors like the questioner.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.