We help IT Professionals succeed at work.

problems with owa and exchange publishing services

867 Views
Last Modified: 2012-05-08
hi I'm having problem with publishing services of exchange 2007. until yesterday has all worked fine. my system is made of two virtual machine with sbs 2008, the first one, and windows 2003 R2 with isa 2006, the second one. isa 2006 publish all the services of exchange 2007. from yesterday all the services (owa, rww, activesync, outllok anywhere) no more function.
I don't think is an isa problem because it does not function also from inside. when I try to navigate from the network in https://nameserver.dnsname.local/owa or https://remote.publicname/owa the response is "impossible to load web page.
obviously all the services work fine
 I think it can be something with certificate or IIS but I don't know where I can begin to debug for error
can someone give me Ideas
thanks in advance
Comment
Watch Question

CERTIFIED EXPERT

Commented:
Have a look at the IIS log files on the OWA server.  See if the requests are reaching the server.
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Check these in IIS

1) Autodiscover: Basic and Integrated authentication   SSL Optional
2) EWS : Integrated authentication                            NO SSL
3) Exadmin : Basic and Integrated authentication       NO SSL
4) Exchange : Basic and Integrated authentication      SSL Optional
5) Exchweb : Basic and Integrated authentication       NO SSL
6) Microsoft-Server-ActiveSync: Basic authentication   SSL Optional
7) OAB : Integrated authentication                             NO SSL
8) OWA : Basic authentication                                 SSL Optional
9) Public : Basic and Integrated authentication          SSL Optional


What about https://localhost/owa on Exchange 2007 ?

Author

Commented:
thanks for the quick answer
for all the sites ssl was required so I turned off for ews, exadmin ecc. as Narayan has adviced. for ews and oab was also basic  enabled. where optional, I left ssl turned on. the sites https://localhost/owa give the same error
when in IIS I double click on the sites IIS gives me an error. for example double click on exchweb and iis says "impossible to find a part of the path \\.\backofficestorage\vr.local\exchweb
for the logs, Leederbyshire, can you please me say where I have to turn on logging or where can I find the logs. thanks
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Use the Cmdlets given in this article and reset the virtual directories :
http://support.microsoft.com/kb/941201

Author

Commented:
Hi, I followed the first step, that is deleted and recreated the web sites. nothing changed
in the second step, when I digit cscript adsutil.vbs get w3svc\anonymoususerpass it returns
the paramenter anonymoususerpass in not set in the node. the same answer for wamuserpass
so I didn't finished step 2. have I to set this parameter, and how?
thanks
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
ok you just had to use the cmdlets mentioned there nothing else.

go to https://localhost/owa on exchange server itself and see what happens.

Author

Commented:
so, it is not easy to follow because it is not the same. so, I skipped the 2 steps because the parameter was not set, the 3° step say to look for the anonymoususer use, but the answer is that windows has not found anonymoususers in any node under w3svc, so I skip it
the 4° step says to look for a folder number  8.0.685.24 and to set anonymous access (so I understood because the steps are for iis 6). I have 5 folder under owa with number
8.1.240.5
8.1.340.0
8.1.359.2
8.1.375.2
8.1.393.1
only in the last the anonymous  authentication  is the only enabled. the other ones have only based authentication enabled as you told me before, and I left them so. the auth folder, is only anonimous authehticated
the 5* say to look for the domain account used for anonymous access. I don't know if It's right: I double clicked on 8.1.393.1 folder-->autenthication-->anonimous authentication-->modify. here as user I read IUSR, but I don't have any such user in my ADUC. here I have only IUSR_WIN-0DHSJN9X24 that is the random name that sbs gives himself in the first part of installation. this account can access to any computer in domain.
 can have something to do with certificate and this account?
anyway, nothing changed
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
if your exchange isnot the DC than you will have i user account in local machine.
what is the status now what happens if you type https://localhost/owa

Author

Commented:
my exchange IS my DC because I have a sbs 2008, and sbs 2008 install DC and Exchange 2007 in only one machine.
when I try to type https://localhost/owa it says "impossible to show the web page
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.