We help IT Professionals succeed at work.

RemoteApp Disconnected - "remote computer could not be found"

18,617 Views
Last Modified: 2013-11-21
Have just set up a Server 2008 R2 machine with Remote Desktop Services.  It's all running on the one server, just for a single application, which works fine locally and when using Remote Desktop Web Access on the local network.

However, when accessing it over the Internet, you can log on to RD Web Access fine, but when running the RemoteApp you get the message:

RemoteApp Disconnected
The remote computer could not be found. Please contact your helpdesk about this error.

The application and all Remote Desktop services are on a single machine - so I can't see it being a DNS issue.  I temporarily opened the firewall to the machine on all ports, no change.

I'm currently accessing it by IP address, but in the future we will use a DNS name.  Again, I don't think this is relevant, but am not certain.

How can I enable the RemoteApp to function outside the local network?

Thanks
Comment
Watch Question

CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
David HaycoxConsultant Engineer

Author

Commented:
Ok, looks promising, but now it says:

"This computer can't connect to the remote computer because the Terminal Services Gateway server address requested and the certificate subject name do not match."

This is true, they don't.  So how can I either disable this security check, or generate a new self-signed certificate with the correct name?

Thanks again
CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
Can you set up a HOST file on the computer you are using to point to the name of certificate?
David HaycoxConsultant Engineer

Author

Commented:
I just figured it out - installed Remote Desktop Gateway and there's an option in there to generate your own self-signed certificate.  The HOST file method may have worked, but I need it to work for a user to test, and would rather not mess with  their HOSTS file.

Still, you answered the question, so you get the points.  Thanks for the quick response - just what I needed!
Guys... So to run RDweb over the internet you have to configure the RDgateway Role..?

Possibly a silly question... Sorry
David HaycoxConsultant Engineer

Author

Commented:
Well, it worked for me.  This was only for testing, we subsequently got a proper SSL certificate.  In any case it doesn't do any harm to install the gateway role, even if you're not using it.
I do have a third party certain... I have manage to get this working without a gateway role configured. It was quite easy to sort.
Ok, I know this one haas been closed for a while, but I'm getting the same message. I do have a third party cert and have Remote Desktop Gateway install and configured. Any ideas on what can be the problem??? I am thinking there is one step I left out somewhere. Please help!!
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.