We help IT Professionals succeed at work.

How do I get my Exchange 2010 server to redirect my OWA clients to Exchange 2007

ITS_Admin
ITS_Admin asked
on
31,820 Views
Last Modified: 2012-05-08
I have just installed Exchange 2010 and moved some mailboxes. If you go to the the https:\\exchange2010\owa for those mailboxes it works. If someone goes there and their mailbox is on an exchange 2007 they don't get redirected to that server, and it says they are supposed to. They get the message " Your request couldn't be completed because no server with the correct security settings was found to handle the request. If the problem continues, contact your helpdesk.".

Any Ideas????

Thanks

Comment
Watch Question

CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
I am not 100% sure but the scenario in a mixed 2007/2003 environment is that you eed to use a 2007 CAS server to proxy for the 2003 server if the CAS has the mailbox role on it then it will not proxy requests.

Try setting up a seperate CAS server with 2010 Client Access Role and see if you use that server for OWA if it will proxy for the 2007 server.
Are your virtual directories set up correctly? This article has info on that (and other steps required for coexistance between 2010 adn 2007): http://technet.microsoft.com/en-us/library/dd351133(EXCHG.140).aspx
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Remove SSL from OWA virtual in Exchange 2007 IIS.
and have basic+integrated authentication on OWA virtual directory.
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Check this Article it describes what we need here :
http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/f1910303-170a-44ae-84a0-ffe32aa51ecf

Author

Commented:
The article at social.technet.microsoft talks about exchange 2010 and 2003. I want all my users to be able to go to my exchange 2010 servers owa and if they are on exchange 2007 be redirected to that server. I have made a legacy.domain.edu record that points to my exchange 2007 server. But I still get the error. Do I need to  use the Set-OWAVirtualDirectory -Exchange2003URL parameter on the exchange 2010 server even if the other server is a 2007 server???

Thanks
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Yes you will have to set Set-OWAVirtualDirectory -Exchange2003URL

Author

Commented:
So I do :

Set-OWAVirtualDirectory -Identity "2010owa\owa (Default Web Site)" -Exchange2003URL https://2003owa.domain.edu/owa

On my exchange 2010 server??

I did that and still get "Your request couldn't be completed because no server with the correct security settings was found to handle the request" when I use the 2010 url to access a mailbox on a 2003 server.The 2010 site does work for mailboxes on that server but it wil take a while to move people over.


CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
Are you in a position to try the seperate CAS solution?

Author

Commented:
By separate do you mean multiple urls for people to go to?? I hate to do that after I just got people used to one. It says this should work so I will keep at it for a while longer.
The 2003 server at least gives you a neat little page that says you should use a new url to get your email if you go to the 2003 server but are on 2010. But that isn't great either because that leaves me with multiple urls again.

CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
No I mean a seperate CAS server that can proxy for all the servers.
So it doesn't have a mailbox role.

Author

Commented:
I could probably just set up a virtual one during the transition, Can it be 2010?? Without the mailbox role does it work better??
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Have you created the host entry for 2003owa.domain.edu.

type https://2003owa.domain.edu/owa and see waht comes up.

that name (https://2003owa.domain.edu/owa) needs to be resolved in order to be accessed and should point to you CAS 2007 server
CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
I know there was a limitation in Exchange 2007 where if it had the mailbox role it wouldn't proxy for Exchange 2003 it could be the same with 2010 I am not sure.

Setup a 2010 CAS and see if it helps, worst comes to the worst you just uninstall it if it doesn't work.

Author

Commented:
Reply to Narayan_singh:
Yes it is in the host table and comes right up and I can log into the 2007 owa. It's the actual name of the server and the certificate is valid for that.
Thanks
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
On exchange 2007 set you owa external URL as https://2003owa.domain.edu/owa (legacy URL)

and make sure there is SSL enabled on OWA virtual directory in Ex2007
Narayan_singhIT Engineer
CERTIFIED EXPERT

Commented:
Clarification set the External OWA URL as https://2003owa.domain.edu/owa (legacy URL)
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
You will need to have a separate server holding just the CAS role to support both Exchange 2007 and Exchange 2010 mailboxes on the same server. A single machine is not going to be enough.
Once you have moved all content you can return to a single machine holding all of the roles.

Simon.
CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
Thanks Simon, that's what I thought but wasn't sure as I have not used Exchange 2003/2007/2010 in a single environment.

Author

Commented:
I have created the standalone CAS server in exchange 2010 and I still get the same error.  have attached the error from ie below. It is able to bring up a mailbox from my new 2010 server, but just errors on any mailbox from and of the 2007 servers.


cas2010.JPG
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
The text of the error code cannot be read. Can you not copy and paste the error message?

Simon.

Author

Commented:
There error is:

 " Your request couldn't be completed because no server with the correct security settings was found to handle the request. If the problem continues, contact your helpdesk.".

Expert of the Quarter 2009
Expert of the Year 2009

Commented:
That would tend to point to a problem with the server with the mailbox on it.
Normally I suggest that the virtual directories are reset. If you are doing a proxy then ensure that the other servers do NOT have an External URL configured either.

Simon.

Author

Commented:
Actually I just checked and my current 2007 server did not have an external url defined. I just put one in and now the redirection works perfectly. If I go to the 2010 owa and try a mialbox that is on that server I get a 2010 owa, if it is on the 2007 server I end up logged in on the 2007 owa. I guess because I just had the 1 cas before it never needed to have one.

Steve
Expert of the Quarter 2009
Expert of the Year 2009
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Yes I put in the name of the server https://server.domain.org on the 2007 cas server and moved the ip associated with https://email.domain.org over to the 2010 and entered that there. The certificate has all the "subject Alternate Names" on it and both ips are accessable through https off compus. So it all seems to work now.
It does change the name in the browser for the mailboxes on the 2007 server but it is the result I was looking for....

Steve
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
"It does change the name in the browser for the mailboxes on the 2007 server but it is the result I was looking for...."

That means it isn't proxying, it is redirecting.
If that is all that you wanted it to do then you didn't need a separate CAS.
The separate CAS solution is for when you want a single URL for all mailbox types.

Simon.

Author

Commented:
These answere helped me find the correct screens to use to obtain my result. They came quickly and helped alot.

Commented:
I had this problem on my installation of exchange 2010/2003, and i moved the mailboxes to the 2010 server and the problem is gone.
I also had this problem which was resolved when moving the mailboxes as said above (the next step in the document). When you do this the users mailboxes will change to 'user mailbox' in exchange. Before you do this they will say 'Legacy Mailbox'.

Also, if you go to Users and Groups in the SBS console you will notice that the Legacy mailbox user accounts are not there so you cannot edit any owa settings in the Shared Folders and Websites heading.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.