We help IT Professionals succeed at work.

Mikrotik pppoe ospf question

1,342 Views
Last Modified: 2013-12-14
Hello Experts !

I have implemented pppoe with OSPF, it works well with one subnet added, how can i add more subnet to the ospf ?

This enables OSPF for the 10.0.110.0/24 network.
/routing ospf area add area-id=0.0.0.110 name=public_110
/routing ospf network add area=public_110 network=10.0.110.0/24
/routing ospf area range add area=public_110 range 10.0.110.0/24 cost=default advertise=yes

Suppose i want to add this ranges ?

xx.xxx.160.0
xx.xxx.161.0
xx.xxx.162.0
xx.xxx.163.0

and how many concurrent connection RB1000 support ?

Thanks a lot !
Comment
Watch Question

Commented:
can we see a show run

Author

Commented:
its a mikrotik !
/routing ospf network
add network=xx.xxx.160.0/24 area=backbone
add network=xx.xxx.161.0/24 area=backbone
add network=xx.xxx.163.0/24 area=backbone

Author

Commented:
i have added the above range already and now i want to add more ranges, why should i all to backbone?

thanks for the answer.
It does not have to be backbone, that is OSPF area 0.  Just put it in there since I don't really know the network there.  All you have to do is the following:
/routing ospf network
add network=x.x.x.x/24 area=public

do this for any network you are sure you want OSPF to advertise to it's neighbors.

Author

Commented:
http://wiki.mikrotik.com/wiki/OSPF_and_PPPoE_Setup
this is waht i have followed, now i need to add some more ranges.
Okay, I am tracking.  Do the following:
/routing ospf area range add area=public_110 range X.X.X.0/24 cost=default advertise=yes
/routing ospf area range add area=public_110 range X.X.X.0/24 cost=default advertise=yes
/routing ospf area range add area=public_110 range X.X.X.0/24 cost=default advertise=yes

Change the area=public_110 to the area you are using.  Then change the range to be whatever range you wish it to be.  "public_110" is just the area id that is assigned here.  it can be whatever you want it to be.

Author

Commented:
/routing ospf area add area-id=0.0.0.110 name=public_110
/routing ospf network add area=public_110 network=10.0.110.0/24
/routing ospf area range add area=public_110 range 10.0.110.0/24 cost=default advertise=yes

i have the above added, I need to add more rages, so all i do :-

/routing ospf area range add area=public_110 range X.X.X.0/24 cost=default advertise=yes
/routing ospf area range add area=public_110 range X.X.X.0/24 cost=default advertise=yes
/routing ospf area range add area=public_110 range X.X.X.0/24 cost=default advertise=yes

so i keep the public_110 name as it is ?

thanks a lot for your time.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
all worked
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.