We help IT Professionals succeed at work.

Need help with WSDL Introspection Wizard in Flex

702 Views
Last Modified: 2013-11-21
Hi, I'm trying to access a Webservice through Flex Builder 3, in an Adobe AIR program I wrote. The website I'm accessing has a specified WSDL file for its webservice:

http://fedexifc.infousa.com/Vision/FedExInfoConnectVisionService.asmx?WSDL
 
However, when I use the Introspection Wizard in FB3, it gives me an error when I try to generate the code for that wsdl file: "Unable to load the WSDL. Specify another URI."
 
Can anyone tell me what the problem is, and how I can get around this error?
 
Thanks,
 
Jeremy
Comment
Watch Question

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
It works when I browse to the link in both browsers, and I can see the source code.

Someone mentioned that I have to use a cross domain policy to access that link--how do I go about doing that?

Commented:
I don't think you need to do this - a cross domain policy file is needed, but only on the server you're trying to connect to. As I can use the introspection wizard successfully against the URL you have provided, why might you need to do something different with cross domain policy files?

Commented:
Hm, read somewhere that in some cases you need to directly add the domain to your Flex whitelist.

Check here for some details about how you might try this out:
http://kb2.adobe.com/cps/192/tn_19251.html

Author

Commented:
I added this to my flex-config.xml (whitelist) file:

<web-service-proxy>
      <whitelist>
      <unnamed>
      <url>http://*</url>
      <url>https://*</url>
      </unnamed>
      </whitelist>
   </web-service-proxy>      

But I still get the same error when I try to generate the code from the WSDL file. I can't figure out for the life of me why I can't generate this code...

Author

Commented:
I can't import any WSDL file, even the generic http://www.webservicex.net/WeatherForecast.asmx?WSDL that many examples on the subject use. It seems like its a problem on my side, but any idea what it could be?

I also added this to my flex-config.xml file in the <web-service-proxy> tag:

<named>
            <service name="infoUSAWS">
              <wsdl>http://fedexifc.infousa.com/Vision/FedExInfoConnectVisionService.asmx?WSDL</wsdl>
                    <endpoints>
                    <endpoint>http://fedexifc.infousa.com/Vision/FedExInfoConnectVisionService.asmx</endpoint>
                    </endpoints>
                    <use-custom-authentication>true</use-custom-authentication>
                    <allow-unnamed-access>true</allow-unnamed-access>
              </service>
      </named>

Commented:
Have you had any further progress with this?

Author

Commented:
No, I still haven't figured out why it won't generate the code. I have used a third-party proxy generator instead to convert the wsdl file but I'm not sure how useful it is in my Flex application.

I will try to invoke the Flex generator over the weekend at a different location (home instead of work) to see if its the server that is blocking access to the wsdl.

Commented:
Any luck?

Author

Commented:
Yes, was able to access it at home. Figured out that it was my company's firewall preventing access to an unauthorized web service.

Author

Commented:
Network problems, specifically a company firewall blocking access. Thanks for the help.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.