SBS2008 losing gateway address after restart

I have a client with a HP ML330G6 with built-in NC326i Dual port NIC. Broadcom Driver 12.2.0.3. I have used the SBS 2008 internet connection wizzard to connect to the internet. The router (DSL-G604T) is set to manual configuration as I don't trust SBS to set it up.
Everytime I restart the computer, it loses its gateway address. Rerunning the wizzard fixes the problem.
Has anyone had this problem before? I found a link with someone having this problem, but upgrading the NIC driver to 12.2.0.3. fixed it for him.
BTW. I have disabled the 2nd NIC in windows and unclicked any services that were associated with it.
LVL 1
ralfalpertAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

crossfiredCommented:
I have had this problem before. The gateway reverting to blank indicates a conflict. If you go to the properties of the network adapter; you have a static IP set with DNS and DHCP pointing to the server IP itself, right?? In addition, The interfaces tab of dns should have the static IP of the NIC checked. Uncheck any other addresses that may conflict. start;>administative tools->dns - then right click the server name and go to properties -> interfaces tab. That said and correct , run the wizzard and you should not have the gateway falling out.... Unless your router configuration is wrong. Your router should not be doing DHCP and the server should have root hints populeted in the DNS properties... You can add the DNS entries the forwarders tab.... That is not recommended any  more, however, that may be a work around,,,,, And last but not least.... go to SBS console-> Network -> connectivity tab... Now look to the right... Run the Fix my Network wizzard and then the connect to internet wizzard and see if that does not fix this issue.
I hope this helps,

Louis
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cybis1Commented:
We had a similar problem and it was caused by the anti virus program (in our case it was AVG).  We uninstalled AVG and everything worked properly...the wizzard found the router and all the settings were kept  even after reboots.
0
ralfalpertAuthor Commented:
I have found the problem. Following Crossfired lead, I checked all settings. In the end, the problem was caused by the fact that when Windows 2008 SBS was installed on the ML150, both network cards were active. When we finally assigned the fixed IP address to what we considered NIC 1 we must have upset SBS. While all was working, every restart removed the gateway address. Crossfired's hit about the Fix my Network wizzard lead us in the end to try to move the LAN functionality to NIC 2 and disable NIC 1. It still complained about a NIC being disables, so we enabled NIC 1  again and gave it some random subnet. All is good now.

Thanks to all.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

ralfalpertAuthor Commented:
The solution showed the way to a resolution of the problem.
0
andrewnaarCommented:
We noticed something similar too. It may be related to Service Pack 2 installation. I have seen a lot of posts on the net about this.
The following solution worked a treat for us. Courtesy of

http://www.netsetman.com/support/viewtopic.php?pid=832

1. Open the registry with regedit.exe
2. Go to the path: HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/
3. Here you'll need to select the CLSID of your networkadapter where you change the settings. You'll probably recognize it by looking at the value IPAddress that will have the IP of this adapter.
4. Open the value "DefaultGateway" by doubleclicking it. You will see a list of all the gateways that disappeared! (maybe in your case it will be only one, in my case there were due to lots of testing several addresses) Very likely, the first line will be empty. I'm not sure, how this little flaw can make such a big problem. However, if you manually remove this first empty line, click OK and reboot your system everything should be working fine again.

0
tomcahillCommented:
andrewnaar,

Thank you so much for your post.  I had a ML350 G6 doing the same thing and followed your steps to resolve it.


You Da Man!
0
Gordon710Commented:
Hi
I had the same problem and made the registry change that andrewnaar suggested. Shut down restarted, strraight on the net.
That tip alone will more than pay for my subscription
Gordon
0
EXEWACommented:
Andrewnar.

Fantastic, this worked for Windows 7 as well.... brilliant... My wife is so happy with you

ciao
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.