application pool being auto-stopped when enabled for 32 Bit applications

Hello,

does anyone know why the ApplicationPool in IIS 7 is being stopped ONCE I enable it for 32 bit support ?

I see the following Error in the Event viewer:

The Module DLL 'C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number.

I hope someone can help....

I am using Windows 2008 Enterprise R2 with Exchange 2010 installed on it....

Thank You
Best regards
FalconQAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

david_sanjeevCommented:
if you want to run ASP.NET 1.1 and ASP.NET 2.0 at the same time, you must run IIS in 32-bit mode.

Please refer microsoft article http://support.microsoft.com/kb/894435

Thanks
David
0
FalconQAuthor Commented:
hello David,

thank You for reply !!

I found the solution for this problem. I am using only .Net 2.0 at the time so that was not a problem.
Not sure why this happens but in my case I got the error described below:

The Module DLL 'C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll' could not be loaded due to a configuration problem

and I found some articles where the people have another errors like for example one below:

The Module DLL C:\Windows\system32\RpcProxy\RpcProxy.dll failed to load could not be loaded due to a configuration problem

and it could be another dll`s too... depending on our installations

BUT both of these problems caused the error when trying to run an 32 bit enabled web app in our browsers:

HTTP Error 503. The service is unavailable


So the solution for this problem is:

 in the file "applicationHost.config" located at:

C:\Windows\System32\inetsrv\config

add this line:  preCondition="bitness64"

Example in my case:

This is BEFORE CHANGE:
 <add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" />

And this is after the change, when we add the line as described above:

 <add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" preCondition="bitness64" />

than just start the AppPool again and 32 bit application will now work just fine.. and our AppPool wil not be stopped again....

So the point is only to add the line: preCondition="bitness64" behind the .dll file WHICH displays the error.

Best regards
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FalconQAuthor Commented:
issue fixed
0
LemansCommented:
Thanks from Switzerland
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.