Exchange 2007 Organization Forms Library Permission problems

I am creating a custom form in Exchange 2007, but i am recieve two errors when I try to publish to the "Organizational Forms Library" the first states:

"Cannot publish the form because of a MAPI error. The operation failed." So I click "ok". If I try to click on publish again i get the error: "Cannot publish the form because of a MAPI error. You do not have permission to create a message in this folder.

I used a powershell command to give myself owner rights to this folder:
Add-PublicFolderClientPermission -Identity "\NON_IPM_SUBTREE\EFORMS REGISTRY\mycompany Organizational Forms" -AccessRights owner -user my.name

I successfully because an owner but was still not able to publish my form.

Any help is appreciated. Thanks in advance

LVL 2
dlbenson1979Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Satya PathakLead Technical ConsultantCommented:
To use the MAPI Editor tool to create an organizational forms library
Log on to a client computer that is running Microsoft Office Outlook 2003 or later.
Download the Microsoft Exchange Server MAPI Editor from http://go.microsoft.com/?linkid=5684182.
Start the MAPI Editor (Mfcmapi.exe) from the MFCMAPI folder.
If required, create a MAPI profile.
From the Session menu, click Logon and Display Store Table.
From the MDB menu, click Open Public Folder Store, and then click OK.
Expand Public Root, expand NON_IPM_SUBTREE, and then right-click EFORMS REGISTRY.
Click Create SubFolder and type an appropriate folder name, such as Organizational Forms Library
Click the newly created folder.
From the Property Pane menu, click Modify 'Extra' Properties.
In Extra Properties, click Add, and then click Select Property Tag.
Click PR_EFORMS_LOCALE_ID in the list, and then click OK.
Click OK two times. A red mark is displayed next to the newly created PR_EFORMS_LOCALE_ID property.
Double-click PR_EFORMS_LOCALE_ID.
In the Unsigned Decimal box, type the required locale ID, and then click OK. For example, type 1033 for English, type 1040 for Italian, or type a different ID for a different locale. To determine the locale ID for other locales, see languagecode Field at the Exchange Server Developer Center.
Exit MAPI Editor.
To use Exchange Management Shell to configure limits and permissions for the organizational forms library folder
To set storage limits, run the following command:
 Set-PublicFolder
To set permissions for each user, run the following commands
Add-PublicFolderClientPermission
More Info :
http://support.microsoft.com/kb/933358
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dlbenson1979Author Commented:
Make sure that the organizational forms library that you are using is the primary library. While other libraries can exist, you can only pubilsh to the primary library. Once I changed ownership on the primary, it worked perfectly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.