Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1774
  • Last Modified:

[http error 400 - request is badly formed] appears randomly in .net application

hi experts,

[http error 400 - request is badly formed]  this error occurs randomly in my web application, this error is not regular,

Please help or suggest..
img.jpg
0
Dinesh Subramanian
Asked:
Dinesh Subramanian
1 Solution
 
MrunalCommented:
Have you used sessions in your web application?
If yes, please check for session expiration.

Also handle 400 error in application.
Refer:
http://stackoverflow.com/questions/342247/can-an-asp-net-httphandler-handle-an-http-400-bad-request
0
 
Dinesh SubramanianSenior Software EngineerAuthor Commented:
mroonal:

yes, session is used in my application, but this error is occurring all the sudden and random..
i checked the link and did at per that, but still i get same king of error in few pages....
0
 
MrunalCommented:
Hi dinudany,

Have you checked these links:

http://forums.webhostautomation.com/showthread.php?t=13719
http://forum.dotnetpanel.com/forums/t/5146.aspx

Try these solutions, your problem will get solved.
Also let me know that are you using AJAX in your application or not ?
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
Dinesh SubramanianSenior Software EngineerAuthor Commented:
hi mroonal:

the solution is not explanatory, what is "HELMWEBUSERS", i don't get any thing from that...

no AJAX in not used in this application...
0
 
Rupesh PCommented:
http://www.experts-exchange.com/Software/Internet_Email/Web_Browsers/Q_21929301.html

Can you please check the link mentions a similar problem. Will it help you?
0
 
arunallimuthuCommented:
Hi,

is this happen in dfferent browsers?
0
 
Dinesh SubramanianSenior Software EngineerAuthor Commented:
rupeshIndia:

i don't get any dispute conclusion from the above link...

but i found this....
http://www.checkupdown.com/status/E400.html

here the post says the key reasons are because of client system... so i am confused..
Experts please help me... am i right or is their any thing setting problem in IIS, but i have not changed in my code nor in the IIS for last few months, all the sudden this error occurs.  Only thing what I have changed is that I have included the default redirect setting in the customer error in the web config of the application...
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now