Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

port forwarding with cisco 2600

Posted on 2009-12-16
12
Medium Priority
?
272 Views
Last Modified: 2012-05-08
Hi, i want to use porforward for 25 ,22,80 from this router to another server
how can i do that ??

0
Comment
Question by:fosiul01
  • 6
  • 3
  • 3
12 Comments
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26061110
Hi

ip nat inside source static tcp Server.IP 22 interface WANinterface 22
ip nat inside source static tcp Server.IP 25 interface WANinterface 25
ip nat inside source static tcp Server.IP 80 interface WANinterface 80



0
 
LVL 29

Author Comment

by:fosiul01
ID: 26061126
Hi thanks
if i just type those command will it work ?? or do i have to do something else like
define source ..

here router ipaddress : 192.168.1.1 ( enterface1) which is connected to insdie

and Isp whic his conencted to interface2. 33.33.33.33


0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26061147
yes ,,
and if you have an ACL you need to allow those ports through it..

can you podt your configuration
0
The Growing Need for Data Analysts

As the amount of data rapidly increases in our world, so does the need for qualified data analysts. WGU's MS in Data Analytics and maximize your leadership opportunities as a data engineer, business analyst, information research scientist, and more.

 
LVL 29

Author Comment

by:fosiul01
ID: 26061156
ok give me 1 hour, i will past the ACL here
thanks
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26061255
and you need 'ip nat inside command' for outside leg and 'ip nat inside command' for inside leg
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26061429
Hi
this is my nat access list

ip nat inside source list NAT_ADDRESS interface Ethernet0/0 overload

and

ip access-list standard NAT_ADDRESS
 permit 193.132.0.0 0.0.255.255

also

EV-Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            192.168.1.66    YES manual up                    up   --------------- ISP
Ethernet0/1            193.132.234.1   YES manual up                    up -----------------  INTERNAL
(dont worry about the IP)

 , now how will i allow portfowarding ??

i am new to cisco, so please bare with me
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26061447
could you show us the whole config?
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26061476
here it is

EV-Router#show running-config
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname EV-Router
!
enable secret 5 xxxxxxxx/
enable password xxxxx
!
memory-size iomem 10
ip subnet-zero
ip name-server 192.168.1.254
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.1.66 255.255.255.0
 no ip directed-broadcast
 ip nat outside
!
interface Ethernet0/1
 ip address 193.132.234.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
!
ip nat inside source list NAT_ADDRESS interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
!
ip access-list standard NAT_ADDRESS
 permit 193.132.0.0 0.0.255.255
banner motd ^C
****************************
this is a secure router,Unauthorized logins are
restricted.
****************************
^C
!
line con 0
 password xxxxx
 logging synchronous
 login
 transport input none
line aux 0
line vty 0 4
 password xxxx
 login
!

Open in new window

0
 
LVL 16

Accepted Solution

by:
memo_tnt earned 2000 total points
ID: 26061655
same as i sent before just put the server IP,, and every thing will become ok

ip nat inside source static tcp Server.IP 22 interfaceEthernet0/0 22
ip nat inside source static tcp Server.IP 25 interface Ethernet0/0 25
ip nat inside source static tcp Server.IP 80 interface Ethernet0/0 80
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26061825
Hi, why you use private ip address on inside leg?

193.132.234.1
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26061849
thanks its works

by looking at my configuration file

is there any security conncern?? if i put this router to be public face
do i need take any extra action to make it secure?


also

does this router, by default close every incomming port rather then 22 ( now i defined it)
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26061870
@ikalmar

As i said, dont worry about my IP in my previous post, i know its looks like public ip, but its not

0

Featured Post

Get Certified for a Job in Cybersecurity

Want an exciting career in an emerging field? Earn your MS in Cybersecurity and get certified in ethical hacking or computer forensic investigation. WGU’s MSCSIA degree program was designed to meet the most recent U.S. Department of Homeland Security (DHS) and NSA guidelines.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question