Setting IIS permissions for use with Dreamweaver

Posted on 2009-12-16
Last Modified: 2012-05-08
I am wanting to create a simple login page for a website I have created in Dreamweaver. I understand that to do this I need to install IIS - I have tried doing this but don't seem to be able to get the permissions right to enable it. I am using Windows XP Pro (downgraded from Vista) and installed IIS via the control panel.
Following some instructions I found I have:
Installed all elements of IIS from the control panel
Created an Access database file in C:\inetpub\wwwroot\dreamweaver\_database\
Tried to give IIS permission to use my database by going into the folder (_database) properties, adding a user called COMPUTER\IUSR_COMPUTER (where COMPUTER is the name of my computer), checked Modify. I then went into Advanced and tried to select the Replace Permission Entries on All Child Objects... option, but when I clicked OK got a box saying "This will remove explicitly defined permissions on all child objects and enable propagation of inheritable permissions to thouse child objects. Only inheritable permissions propogated from _database will take effect. Do you wish to continue?"  - I clicked yes but it automatically unchecked the box again. I tried this several times but have not been able to get it to accept the setting.
My instructions then tell me to check whether IIS is enabled by typing http://localhost in my browser address bar - I get a "The webserver cannot display the page" message so assume it isn't!
I have AVG Internet Security installed on the computer. Don't know if this is an issue.
Can anyone help please? Thanks in advance
Question by:Fionder
    LVL 17

    Assisted Solution

    First make sure IIS is installed and working.

    Place a test hello world html page in the root of your website.

    See if you can get to this page via localhost.

    Once that is working look at the files from dreamweaver to get working.

    You will likely need scripting etc enabled for your site too Website properties home directory tab scripting.

    Author Comment

    I don't think IIS is working although it is definitely installed with all options ticked via the control panel. I have added helloworld.html into my _database folder but if I put http://localhost/helloworld.html in my browser it says "The page cannot be found".
    Sorry - I haven't much of a clue when it comes to working out software/settings etc so really appreciate any help you can give me preferably in layman's terms. Am increasing the points value as it seems to be more involved than I first thought...
    LVL 26

    Accepted Solution

    The defaut IIS installation will have a working site displayed when you access http://localhost.
    Things seems to have gotten confused somewhere during your implementation.
    I'd suggest going back and uninstalling IIS, and then re-installing it again...that way we know that you've not changed any settings.

    Once IIS is installed you can browse to http://localhost, and you should see a page.
    Next try setting up your site.

    The default site that loads on a clean IIS installation is saved in the default folder c:\inetpub\wwwroot.
    if you wanted http://localhost/helloworld.html to be displayed then you'll need to save helloworld.html in c:\inetpub\wwwroot.

    Author Comment

    That has worked  -  thanks!
    Do I need to do anything else regarding giving IIS permission to use my database? I still can't check the Replace Permisison Entries on all Child Objects... option.
    LVL 26

    Assisted Solution

    by:Leon Fester
    You shouldn't need to change any other permissions.
    I'm guessing that the database itself is not being published on the WWW, so only the neccessary scripting users(in your code) need permissisons to the database.

    If you want your site to be published then either copy the content of the folder to C:\inetpub\wwwroot
    Alternatively, in IIS you need to either create a new site and set the default folder to point to your folder C:\inetpub\wwwroot\dreamweaver.

    Are you getting an error message that is making you want to change permissions?

    Author Comment

    Thanks dvt localboy. Nearly there - have now successfully got Dreamweaver to connect to my database. However when I first tried to open the database panel I got a box entitled "Connect to COMPUTER" (COMPUTER = name of my computer) and then a form box requesting username and password. I also get the same box if I put http://localhost in my browser, but have no idea what my username and password would be. So far clicking cancel seems to have by-passed it but is it likely to worry me?

    Author Closing Comment

    I am still getting errors whilst trying to get Dreamweaver to connect to IIS so haven't been able to proceed with building my first dynamic website

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Join & Write a Comment

    Suggested Solutions

    If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
    When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    733 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    26 Experts available now in Live!

    Get 1:1 Help Now