Cannot ping  router from server.

Posted on 2009-12-16
Last Modified: 2013-12-05
Hello there, I have a problem that is driving me crazy.

I have a netgear router, which is connected to a switch - I have our server connected to the switch.  The server cannot ping the router ""request timed out".

I have a work station connected directly to the server, this has a connection and can ping the router fine.

What is going on, this is doing my head in.  I have the whole company waiting for an internet connection.  We cannot get our mail, or nothing.

I have tired a crossover cable, straight through.   Its like the server just will not recognised the routers IP.  

The default gateway of the server is not set as the routers IP, but this should not matter.

Any ideas.
Question by:SpencerKarnovski
    LVL 74

    Expert Comment

    by:Glen Knight
    If the default gateway is not set as the routers IP address then what is it set at?

    Do you have some security software on the server? firewall? Have you tried disabling it?

    Can you post ipconfig /all from the server and the client that can PING the router.
    LVL 2

    Assisted Solution

    Is the server and workstation on the same subnet? This can be aproblem also I would turn off any firewalls on the server for testing at least.

    How is the Workstation connected to the server directly? Does the server have dual NICs and the workstation is in Nic 1 and the server is connected to the switch in Nic 0. I would try pinging some sort of outside address like

    I think your problem is in the Ip settings.

    Author Comment

    Hey Dem -   I should say that we have just moved the server from one location to another.  The only thing that has changed was our range of static IP addresses, out public IP address.  These had to be reconfigured on the router, and the external IP address on the firewall.

    The default gateway in this instance (which all PC's, server connect too) is the firewall.

    Now, for the time being I have removed the firewall.  I just need to be able to ping the router, when its connected to the server - i.e, to get the server online.

    The server, router are connected to the switch.

    The workstation I was talking about is connected directly to the router interface, thus bypasses the switch, and server domain.  The workstation is getting its DHCP from the router.

    So, obviously I can ping the router from the attached workstation.  The router has been configured correctly, I'm sure.  As when I go to whatismyip it gives me the right static IP address. This the address i'm going to add to our domain host so we can get mail delivered.

    So, to recap the main problem.

    I have the router connected straight to the switch.   I have the server connected to the switch.

    I cannot ping the router.  Now, obviously the router cannot be on the same subnet as the server.

    The server has been give a static IP address of, with a default gateway address of the firewall.

    Now we have 5 static IP Address to which have been configured on the router,

    So, the subnet mask is different; .248 that on the server.  

    Even with the firewall turned off, the server connected directly to the router via the switch - still cannot ping the routers IP address.


    I should have said the workstation connects directly to the router interface, that is so I can configure it.  The server does have x2 NIC's, but we have only ever used one.

    Do router connections have to be put in any specific switch port - this is a bob standard 16 port switch, nothing fancy.

    Will update this more when I go in.

    BTW: if you live in the SE UK (business based in tonbridge) and could suggest an IT company to whom we could call out, please email me at

    Thanks for your help.
    LVL 74

    Expert Comment

    by:Glen Knight
    Make sure the server and the router have the same subnet mask?
    LVL 2

    Expert Comment

    Yeah the difference in subet would be the problem. unless you created routes in the router to make both subnets talk it will never see one another.
    LVL 74

    Expert Comment

    by:Glen Knight
    As per my first post "Can you post ipconfig /all from the server and the client that can PING the router"
    This will help to identify IP configuration problems.

    If they are on different subnets then they need to be on the same subnet, if not then they will not be able to communicate.

    Author Comment

    I will provide the ipconfig information.

    I must say though, with a similar setup, i.e the router being on a .248 subnet, and the rest of the clients being on an internal different subnt, the network worked fine.

    In fact, I did have it working in the morning time.  It was only when I added the new range of IP addresses it, configured the firewall to the new external IP address, the server didn't communicate.

    So, it was working fine during the morning.  This morning I'm going to reset the settings as it was, then start again.

    I should say as well, even though I didn't have the firewall connected and it worked this morning, the firewall has rules to push each static IP address packets through to the server.  Thats why I have to set the external IP address of the firewall config to that of our pubic IP address, it then sends smtp traffic through to our spam filter, then through to the firewall.

    So, its kinda like we have a specially configured router (because of the way BT send their static IP address encapsulated in a dynamic IP address, ie. a dynamic IP address (WAN SIDE) is all the 2wire router that they sent will see.  Its not possible to configure the 2wire (from BT themselves) with a public static IP address when you have 5+ in your range.  Therefore we had to get a router that will allow the assigned of a main static IP address, but allow us to push through, configure, our static IP address range, like in this image.

    I'm a first line, 2nd (nearly) line support personnel.   All i thought I had to do was copy the first configs over, then it would work.  The router + server have always been on a separate subnets.

    The system is slightly complex, this is also due to the owner not wanting to upgrade anything, nor pay for it.  But thats another story :)

    LVL 74

    Accepted Solution

    The only way it would work if the server was on a different subnet to the router would be if the server had 2 network cards and was being used as a router.

    But even then one NIC would need the same subnet as the LAN and the second would need the same subnet as the DSL router.
    LVL 8

    Assisted Solution

    Hi SK,
    Through your descriptions it is a little hard to visualize your setup.  I attached a graphic of how I see it through your descriptions.  I'm going to assume that this is correct for my comments.  I'm also going to assume that the router is a combination device that is a router with a built-in switch on the Lan side (ports C & E = Lan side switch-ports) and the switch is NOT a layer 3 switch.  
    You probably know most of this anyway, but I just want to cover all bases.

    1) Cable E-F should be a crossover cable and all the rest being straight through cables.

    2) Wan side of the router (port B) should have mask, But the Lan Side of the router (ports C & E) should be something more like

    3) The Server (assuming static settings) must have the same mask (also same as the workstation's mask) and be in the same subnet as the Lan side of the router.  The gateway IP on the server should be the Lan IP of the router.

    4) The workstation should work the same if plugged into the router port as if it were plugged into a port on the switch.  (This is a test you could do.)

    Dem is totally correct on what he says above, and the result it the ipconfig /all and the router's LAN side IP and Mask information is essential in diagnosing this problem.

    I'm wondering if the Lan IP address in the router and the server IP address might be the same with different masks?  Normally routers (gateways) have a .1 address and you say your server is the .1 address.  What does your workstation show for it's (DHCP) gateway address?


    Author Comment

    Hi All

    Thank you very much for your input Dosdet2 and Dematzer.  Your graphic is spot on there Dos.  But, after a morning of speaking to someone, a friend of a friend - we found the problem.  Basically our router pushes our range of static IP addresses to our firewall, which then forwards the relevant packets based on certain ports.  Now, I basically had to configure the firewall to allow communication between the router / router by entering in our new public static IP, gateway IP for the firewall.

    Now, here's where I went wrong.  As I had not used the firewall before, I didn't realize exactly how to load a "live" configuration file.  

    Instead I just clicked a configuration file in the recent documents, which indeed did ask for a password when it loaded.   So I amused that this was the right process to change the settings.  After this file was loaded, it indeed did let me change the configuration, and save it - showing progress bar for saving, for loaded etc..  So I did changed the firewall settings correctly.   However, instead of choosing a file from recent documents I should have gone File>Open>Open File option-Network.  Then entered in a user name and password.  

    Did this, then it loaded the "live" configuration.  Changed the settings again, and pow - the router became ping-able.

    Felt a bit of an idiot to be honest, all this hassle it was just because I had not loaded the live configuration file.   Because our server monitor is so small 15", I had the firewall full screen - if I had moved the filewall interface I surely would have seen the "OFFLINE" sign on the bottom.

    Still, its fixed.  Thank you both for your help.
    LVL 74

    Expert Comment

    by:Glen Knight
    At least it's sorted.

    Author Closing Comment

    Good answers.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Promote certifications in your email signature

    Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

    Suggested Solutions

    The question has been asked on multiple occasions as to how best to do printing in a remote desktop or terminal services environment.   It seems that this particular question has plagued several people and most especially as Terminal Services, as…
    Some time ago I faced the need to use a uniform folder structure that spanned across numerous sites of an enterprise to be used as a common repository for the Software packages of the Configuration Manager 2007 infrastructure. Because the procedu…
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now