• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1275
  • Last Modified:

Problem with networking from XP Mode VM in Windows 7

I have a XM Mode Virtual Machine runing on Windows 7 Ultimate (32 bit). The network settings or XPM is for a physical card on the Windows 7 host. It has an assigned IP address and I can access the Internet and other computers on the network from the XPM VM but cannot even ping the XPM VM from the Windows 7 host or any other computer on the network (It can see but cannot be seen).

How do I make the XM Mode Virtual Machine visible to the network?

Thanks
0
PugwashXP
Asked:
PugwashXP
  • 3
  • 2
1 Solution
 
zkayyalCommented:
This isn't possible. If you load a cmd prompt on the XP virtual machine, you will see it is on a completely different (virtual) subnet with a different IP range and a different default gateway.
0
 
theonlyallanCommented:
By default, the virtual machine is set to be on a different subnet than your Windows 7 PC.. (kind of like network inside a network, where your Windows 7 PC is acting like a router)

To change this: highlight the name of the virtual pc (Windows XP Mode) on the top is "Settings" , goto Networking > Adapter 1> Change it from Shared networking (NAT) to > Your Network Adaptor..
Start the VM and your VM will get an IP Address in the same subnet of your Windows 7 PC
0
 
PugwashXPAuthor Commented:
Not so -  I ran IPCONFIG on the WIndows 7 host and the XP Mode VM and they both have the same subnet mask and default gateway. Interestingly, they report different network cards. Also, using network explorer from a different XP box I can see the XP Mode VM but cannot ping it and cannot connect to it - it reports an error.

Any further thoughts?

Thanks

The host Windows 7 IPCONFIG reports:
Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 00-21-70-E9-F1-7E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::ad2f:6974:ea80:23d3%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.104(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 16 December 2009 16:04:40
   Lease Expires . . . . . . . . . . : 20 December 2009 16:04:39
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 234889584
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-B3-ED-49-00-21-70-E9-F1-7E
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

The XP Mode VM IPCONFIG reports:
Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel 21140-Based PCI Fast Ethernet
Adapter (Generic)
        Physical Address. . . . . . . . . : 00-03-FF-A4-90-51
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.110
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 192.168.1.1
        Lease Obtained. . . . . . . . . . : Wednesday, December 16, 2009 5:02:23
 PM
        Lease Expires . . . . . . . . . . : Sunday, December 20, 2009 5:02:23 PM
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
PugwashXPAuthor Commented:
To "theonlyallan"
See above, also I already set have set the network connection to a named adapter. I am puzzled?
0
 
theonlyallanCommented:
Make sure the windows firewall in your virtual machine is turned off. Is there a padlock beside the network adapter? If you don't want to completely disable the firewall, go into the config and check off the services/ports you want to allow.
0
 
PugwashXPAuthor Commented:
Thanks - leaving the firewall on but setting the required ports worked perfectly (I as tring to connect to an SQL server instance and setting port 1433 solved everything.

Thanks again
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now