• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1788
  • Last Modified:

Exchange RPC over HTTP Disconnected issues.

We are currently using Exchange 2007(Windows Server 2003 x64)/Outlook 2007(Vista Ultimate, Vista Home Premium).  

When trying to access the users email using a 3G card, Outlook will try to connect to the Exchange server but never does.  The status always shows disconnected.

As soon as I connect through LAN, I can access the email account with no problems.  The issue arises when I go offsite.

I've tried this fix to no avail:

http://support.microsoft.com/kb/913843

After multiple attempts I still cannot connect to Exchange.  I'm making the assumption that this has always worked as it just recently stopped working.

Much thanks,

Curtis
0
40hz
Asked:
40hz
  • 5
  • 4
1 Solution
 
40hzAuthor Commented:
I should also state that OWA and Active Sync to iPhones are working with no problems.
0
 
Narayan_singhCommented:
Have you enabled Outlook anywhere and installed RPC component ? if not please do so
See this article for Outlook anywhere configuration : http://technet.microsoft.com/en-us/library/bb123513.aspx

What kind of certificate do you have, make sure you have a valid certificate.

To check the connectivity you can use
https://www.testexchangeconnectivity.com/

Post the result.

0
 
Alan HardistyCommented:
Firstly, OWA and Activesync use completely different methods to communicate, so the fact that they work does not mean that HTTP over RPC (or Outlook Anywhere as it is known for Exchange 2007 / 2010) will necessarily work or not.
Do you have other users who connect externally using Outlook Anywhere, or is it just this user with the 3G card that cannot connect?
Are you sure that it ever worked?
In the Exchange account settings in Outlook for this user, is the Exchange Proxy server setup properly?  Please see the following web page for details (ame method for Outlook 2007 although you can use Autodiscover if setup):
http://www.msexchange.org/tutorials/outlookrpchttp.html
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
40hzAuthor Commented:
Ok here are the results from testexchange:


 Testing RPC/HTTP connectivity
  RPC/HTTP test failed
   Test Steps
   Attempting to test Autodiscover for curtis@edgewin.com
  Testing Autodiscover failed
 
 
I'm currently going through the setup deemed by MS.
0
 
Alan HardistyCommented:
Have you setup an A Record in your domains DNS records for Autodiscover pointing to the Public Facing IP Address of your mail server?
e.g., Autodiscover   A   123.123.123.123
Without an A record setup properly, Autodiscover will fail.
0
 
40hzAuthor Commented:
alanhardisty -

It had to work at some point in time because that is how the user would be able to check their email, not using a VPN or OWA.  It is just this user that is connected using outlook anywhere.

The proxy settings have not changed but when I try to replicate the setup, it does not want to connect. . .

I have checked exchange and the IIS Manager and all the components appear to be there and setup.  I'm unsure if they are setup correctly.
0
 
Alan HardistyCommented:
Sure - if it is the only user that user HTTP over RPC / Outlook Anywhere, it would be worth testing using the following site previously posted:
https://testexchangeconnectivity.com and run the Outlook Anywhere check.  Please post back the results and obscure any domain / IP detals that you don't want publicly available.
0
 
40hzAuthor Commented:
alanhardisty-

After everyone left last night I rebooted the email server.  This should have been the first thing I did but was not an option during working hours. After the reboot, i tested connection to exchange with the 3G card and it worked.  Apparently the reboot fixed it.  I'm still going to try to understand the setup and get autodiscovery to work, but for now the dust has settled.  I appreciate your rapid responses and your much needed advice.

-Curtis
0
 
40hzAuthor Commented:
Great person to work with, top notch Genius!
0
 
Alan HardistyCommented:
Ah, the old tricks are often the best! Glad the reboot worked and if you need any more help with autodiscover, just shout.

Thanks - Alan
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now