• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 971
  • Last Modified:

RPC over HTTPS on Exchange 2003 working for iphone but not outlook

were running exchange 2003 on one box and the DC is on another box.

Configured RPC over https using this article:
http://www/amset.info/exchange/rpc-http-server.asp as provided by the god sembee

I've also ran the tests on www.testexchangeconnectivity.com and it errors out with not being able to ping the rpc proxy.

Any ideas where I could look to find this solution.  The exchange server is running 2003, the domain controller is still running 2000.

To make this even odder, my iphones are able to sync with no problems.  
0
ibtaya
Asked:
ibtaya
  • 5
  • 4
  • 2
1 Solution
 
Glen KnightCommented:
There is a guide here on configuring RPC-HTTPS: http://www.petri.co.il/how-can-i-configure-rpc-over-https-on-exchange-2003-single-server-scenario.htm

Are you entering the proxy server into the exchange client?
0
 
Glen KnightCommented:
0
 
ibtayaAuthor Commented:
Thanks,  
Yes the outlook client is set up to point to the exchange in the connections tab.

This article is alot like sembee's article.  My confusion comes in why iphones are working but email clients are not.

This article also pertains to a single server deployment, I'm using multiple.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
Glen KnightCommented:
iphones use ActiveSync not RPC-HTTPS

Sorry you didn't make it clear you were in a multiple environment.

The Amset article covers it, is this the one you are looking at?
http://www.amset.info/exchange/rpc-http.asp
0
 
ibtayaAuthor Commented:
this is the article that I followed if you click on the server link from there.
0
 
MesthaCommented:
The way that iPhones connect and the way that RPC over HTTPS connect are completely different.

This is your problem: "the domain controller is still running 2000"

RPC over HTTPS has strict requirements - one of those is that the domain controllers must be at least Windows 2003. You cannot use the feature at all with Windows 2000 domain controllers. You will have to upgrade.

My article on setting up RPC over HTTPS does state that right at the start.

Simon.
0
 
ibtayaAuthor Commented:
had to mess with the registry but I got it to work.  Essentially pointed 6001-6002 to the exchange box and pointed 6004 to the dc.  Even though it was srv 2000 I was able to make it work during the setup of outlook.  Simply follow the normal instructions but when outlook opens and has trouble connecting, type the outside address in the server box and click check name.  It will change to the internal name and your inbusiness.
0
 
MesthaCommented:
That isn't a supported configuration and you will not get full functionality. It requires Windows 2003 domain controllers for full functionality.

No one should have Windows 2000 anywhere near production these days.

Simon.
0
 
Glen KnightCommented:
I missed the reference to 2000

Windows 2000 was officially unsupported in 2002.

Its easy enough to do an inplace upgrade to 2003 (which incidentally was unsupported as of April this year)
0
 
ibtayaAuthor Commented:
I agree with the 2000 comment, but what do you do?
0
 
Glen KnightCommented:
What was the solution?
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now