• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 773
  • Last Modified:

Email messages get stuck in queue

All our outgoing email messages get stuck in the Queue folder under mailroot, including the auto-generated Delivery Status Notification messages.

The application server (SharePoint) and the SMTP virtual server are running on the same machine, which is a local domain member. OS is Windows 2003 with IIS 6. Generation of email messages are triggered from within SharePoint web applications.
Running the SMTPDIAG , we cannot see anything wrong (please see the results below):

Searching for Exchange external DNS settings.
Computer name is WEB2.

Checking SOA for gmail.com.
Checking external DNS servers.
Checking internal DNS servers.
SOA serial number match: Passed.

Checking local domain records.
Checking MX records using TCP: xxxxx.com.
Checking MX records using UDP: xxxxx.com.
Both TCP and UDP queries succeeded. Local DNS test passed.

Checking remote domain records.
Checking MX records using TCP: gmail.com.
Checking MX records using UDP: gmail.com.
Both TCP and UDP queries succeeded. Remote DNS test passed.

Checking MX servers listed for chuansu@gmail.com.
Connecting to gmail-smtp-in.l.google.com [209.85.216.59] on port 25.
Successfully connected to gmail-smtp-in.l.google.com.
Connecting to alt1.gmail-smtp-in.l.google.com [209.85.217.16] on port 25.
Successfully connected to alt1.gmail-smtp-in.l.google.com.
Connecting to alt2.gmail-smtp-in.l.google.com [74.125.93.114] on port 25.
Successfully connected to alt2.gmail-smtp-in.l.google.com.
Connecting to alt3.gmail-smtp-in.l.google.com [74.125.79.27] on port 25.
Successfully connected to alt3.gmail-smtp-in.l.google.com.
Connecting to alt4.gmail-smtp-in.l.google.com [209.85.129.114] on port 25.
Successfully connected to alt4.gmail-smtp-in.l.google.com.
0
peuser
Asked:
peuser
  • 2
1 Solution
 
the_b1ackfoxCIOCommented:
Did this work before and stopped working, or are you trying to get this to work for the first time?
0
 
peuserAuthor Commented:
for the first time.
0
 
shauncroucherCommented:
Is everything ok with your IP address? Make sure you have a rDNS and that you are not on any blacklists.

What do the NDR's say? What happens if you manually try to complete a telnet test to gmail servers? What error do you get?

Check blacklist here for your external IP address: www.mxtoolbox.com

The reverse DNS (rDNS \ PTR) record is configured by the people who issued your IP address in most instances (so your ISP).
 
Below are two articles which explain the general requirements for reverse dns (rDNS\PTR) records for your IP address.
 
I try to adhere to the following when setting up a rDNS (PTR) record:
 
Be a Fully Qualified Domain Name (FQDN) such as server.domain.com (not just 'domain.com' or 'server').
Should not contain 'in-addr-arpa' and should not include words like pool or dyn etc.
Should match what you use in your SMTP HELO\EHLO hostname if possible.
 
For neatness and as a good rule of thumb, if your incoming mail is delivered to the same server that you use for Outgoing you should make sure all the following FQDN's match:
 
MX record
rDNS (PTR) record
SMTP EHLO hostname
 
http://www.simpledns.com/kb.aspx?kbid=1052
 
http://postmaster.aol.com/info/rdns.html 
 
http://www.amset.info/exchange/dnsconfig.asp (Courtesy of EE member Mestha)

Shaun
0
 
the_b1ackfoxCIOCommented:
Since this is being setup for the first time:

based on your information, I can already tell you you have basic connectivity...    So I think this boils down to one of two possible issues...   1) No reverse DNS and gmail is rejecting your emails because of it.  or 2) you mention sharepoint, and that could be misconfigured, but you aren't going to make much headwind until you verify the exchange server is running properly.  So test the basics first by sending an email into the exchange server (from like yahoo or something)...   if that works, half the battle is over... next, get on the exchange server and telnet to one of the ipaddresses from your first message...  if it connects to anything on port 25, you know you don't have anything blocking the communications out, and then you can concentrate on the virtual server and make sure the servers default gateway is pointing out of the network (and DNS is working properly)

Yeah, I tem 2 is bigger than Item 1
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now