Block List

I have Microsoft Exchange 2007 running smothly but lately I have been receiving complaints from a few employees that certain outside users cannot send them email. They receive this message

"550 5.7.1 Recipient not authorized, your IP has been found on a block list (in reply to RCPT TO command)

Is this problem on my exchange server? How can fix this?
Dennis JansonIT ManagerAsked:
Who is Participating?
 
leakim971Connect With a Mentor PluritechnicianCommented:
0
 
Burns2007Connect With a Mentor Commented:
Ok, sounds like they are on a blacklist on the web somewhere.

You have likely configued Exchange 2007 anti spam agents (http://www.exchange-genie.com/2007/12/exchange-2007-anti-spam/)  Which will check lists for IP addresses that are known to send spam, usually because they are poorly configured.


Grab the senders domain name, put it into http://mxtoolbox.com,
Once it returns the MX records, you can click on "Blacklist Check". This checks a large number of well known blacklists on the internet, you'll probably find they exist on one.

If you know the specific IP address they are getting lbocked from, you can just test it http://www.mxtoolbox.com/blacklists.aspx


If they are on blocklists, they need to fix it at their end. You can probably work around it if you do use the anti-spam feature by adding them to the White List, as per the first link: http://www.exchange-genie.com/2007/12/exchange-2007-anti-spam/
0
 
Dennis JansonIT ManagerAuthor Commented:
I ran through the check and neither there or my domains are on any black list according to the mxtool. I did get there IP address from there and added it to the IP allow list on the edge server. Maybe that will work?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
leakim971PluritechnicianCommented:
Hello GMSMRM,

It's not your IP which is blacklisted but the mx of the outside users.
You need to add their MX IP or their email in YOUR whitelist (IP allow list filter and sender filtering filters) : http://www.allspammedup.com/2009/01/managing-whitelists-and-blocklists-for-exchange-server-environments/

Regards.
0
 
shauncroucherConnect With a Mentor Commented:
It is the senders server IP that you need to check for blacklisting and\or add to your whitelist.

This MAY NOT be the MX record and so you cannot reliably use the MX record IP address for checking or whitelisting. This may be returning you invalid results.

You should check the IP in the NDR message that the sender receives OR ask the senders what IP they use to send mail, OR look in your Exchange protocol logs (if enabled) to get the external IP and check for blacklisting / add to whitelist.

Shaun
0
 
Dennis JansonIT ManagerAuthor Commented:
I did get the IP address and add it to mt IP allow list and now was able to receive email from that account. However before I assign points I found that Shauncroucher was correct where I looked up the MX record again and I received a different IP address. I looked up that one on the blacklist and it did appear on the "FIVETEN" black list. So most likely this will be blocked again. Is there a way to allow a domain on the IP list? OR get them off of the black list?
0
 
shauncroucherCommented:
If the IP is on the blacklist then it will be important for them to be removed.

You can email FIVETEN, go to their website and it gives instructions on how to get removed from the list.

You can whitelist a whole domain yes, see here:http://exchangepedia.com/blog/2007/01/exchange-2007-content-filter-whitelist.html

Shaun
0
 
Dennis JansonIT ManagerAuthor Commented:
Thanks for al your help. I had to divide points because you all gave steps I needed to resolve the problem. I found the IP and Blacklist issues from the MX  toolbox website. I needed add the IP to the allow list as well as the domain in the IP allow list providers. Thanks.
0
 
leakim971PluritechnicianCommented:
Thanks for the points and see you soon! Merry Christmas!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.