• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 796
  • Last Modified:

Setting up bindings / redirects on IIS7

I have IIS7 running on my server, along with Exchange. IIS is hosting a Default Web Site, which contains items such as OWA and so on.  The bindings on this a just as standard and handle all incoming traffic not handled by the second website I have set up (more on this later).  

The server is also part of my local domain, and can be accessed via "server.domain.local" or "domain.local".

In the DNS of my "external" .com domain, I  have an A record mail.domain.com.  I would like this domain to go straight to OWA, which as mentioned is an application under the default web site.  How can I do this?

The second  website set up  has a number of applications under it.  I am currently accessing this through a subdomain (sub.domain.com).  The applications are accessed via sub.domain.com/applicationname.  

This website is accessed internally and externally, although for internal access, I am having to enter the .com address.  I want to be able to access this website and related applications in the manner of "sub.server.domain.local" or even better "sub.domain.local".  

How can I do this?  If I access "domain.local " at the moment, I just get the default web site IIS7 page, and visiting sub.domain.local (even with a binding added for the site) I get an error.
0
pipelineconsulting
Asked:
pipelineconsulting
  • 2
1 Solution
 
Springy555Commented:
For your first question, ensure the A record for mail.domain.com points to your external web server IP.  Instructions here on how to redirect requests to the owa subfolder:
http://technet.microsoft.com/en-us/library/aa998359.aspx

You could also use the IIS URL Rewrite Module:
http://learn.iis.net/page.aspx/460/using-url-rewrite-module/

For your second question, you will need to add an internal DNS A record called sub, which will resolve to the internal ip address of your IIS server.
You can test this by pinging sub.domain.local.  If DNS is setup correctly it should resolve to the internal IP address of IIS server.

0
 
pipelineconsultingAuthor Commented:
Second question solved nicely - thanks.

For the first, was the advice on the TechNet page for IIS7? I cannot see a "properties" option when right-clicking "Default Web Site", neither can I find a "home directory" tab anywhere.
0
 
Springy555Commented:
Ah that might have been for IIS6.

To find that option in IIS7, open your IIS console, highlight your website, then on the right window double click the HTTP Redirect icon.

This will be the same place as what the technet page describes.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now