[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1386
  • Last Modified:

smtp instance fully-qualified domain name does not match DNS resolved server name

Hi guys

Unable to send emails or reply to emails. Ive run the Exchange troubelshooter tool and it comes back saying "smtp instance fully-qualified domain name does not match DNS resolved server name". One of the steps to fix is to enter the FQDN into the advance properties of the mailstore. The name in there at the moment is <domainname.com>. Im still a bit of a newb when it comes to this stuff but is the correct FQDN or how do I find this?

All help appreciated

Regards

Troy
0
P3admin
Asked:
P3admin
  • 4
  • 4
1 Solution
 
Glen KnightCommented:
It's explained here with instructions on how to resolve it: http://technet.microsoft.com/en-us/library/bb219058(EXCHG.80).aspx
0
 
shauncroucherCommented:
The FQDN should reflect the hostname you are using when you send mail. It should match what you have set for your IP Reverse DNS entry.

The reverse DNS (rDNS \ PTR) record is configured by the people who issued your IP address in most instances (so your ISP).
 
Below are two articles which explain the general requirements for reverse dns (rDNS\PTR) records for your IP address.
 
I try to adhere to the following when setting up a rDNS (PTR) record:
 
Be a Fully Qualified Domain Name (FQDN) such as server.domain.com (not just 'domain.com' or 'server').
Should not contain 'in-addr-arpa' and should not include words like pool or dyn etc.
Should match what you use in your SMTP HELO\EHLO hostname if possible.
 
For neatness and as a good rule of thumb, if your incoming mail is delivered to the same server that you use for Outgoing you should make sure all the following FQDN's match:
 
MX record
rDNS (PTR) record
SMTP EHLO hostname
 
http://www.simpledns.com/kb.aspx?kbid=1052
 
http://postmaster.aol.com/info/rdns.html 
 
http://www.amset.info/exchange/dnsconfig.asp (Courtesy of EE member Mestha)

Shaun
0
 
P3adminAuthor Commented:
Hi

ive done those steps already but im consufused on what is "msExchSmtpFullyQualifiedDomainName": and where can I find these details on our server

Thanks

Troy
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
P3adminAuthor Commented:
Ive also cehcekd the domain anme with "Check DNS" in the advacned delivery option for the SMTP virtual directoty and it says all is good. The server name is <domainname.com>
0
 
shauncroucherCommented:
Just make sure you EHLO fully qualified domain name MATCHES your rDNS record and make sure your rDNS record reflects a real hostname.

Then you won't have this problem anymore.

Follow the links and follow the instructions.

The 'Check DNS' is not a good indicator and unless you have 'domainname.com' pointing to the IP address you use to send mail, it will be misconfigured. Normally it is server.domainname.com and not just domainname.com.

Shaun
0
 
P3adminAuthor Commented:
Hi shauncroucher

Ive just taken over looking aftre the systems and im still newish to please bear with some of the basica questions. Ive had a look at the rDNS and there is nothing in there. What is a EHLO?

Regards

Troy
0
 
shauncroucherCommented:
ok. so for reverse dns you need to find out your public ip address. do this by navigating to a site like whatismyipaddress.com. once you have the ip you can run from command prompt the following:

nslookup -q=ptr xx.xx.xx.xx

now check the returned ptr is a valid host and references your domain.

now, ehlo references the fqdn on exchange smtp connector, see the amset article for screenshot of this. once you have ptr record (aka reverse dns) sorted out, see the ehlo fqdn to match it.

shaun
0
 
shauncroucherCommented:
I use ptr and reverse dns interchangeably as they mean the same thing.
0
 
P3adminAuthor Commented:
Thanks guys for your help. We have re-routed emails to our ISP to work around the issue whilst we build our new box.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now