Exchange 2007 DNSconnectordelivery queu

Posted on 2009-12-16
Last Modified: 2012-05-08
it is sbs 2008

10 outbound external domain mails are in DNSconnectordelivery queu

Checked my IP blacklist status

checked sembee article regarding this problem but lo luck. try this got report please see attachment

any ideas?

Question by:NarendraG
    LVL 7

    Expert Comment

    Try the telnet test from the Exchange server that is sending outbound to see what response you get from the remote mail server.
    LVL 14

    Accepted Solution

    Your mail domain is

    If so then your MX record is on a blacklist:

    IP Address is currently listed in the CBL.
    It was detected at 2009-12-17 02:00 GMT (+/- 30 minutes), approximately 3 hours ago.

    Follow that link above for a link to request removal.
    By the way, I found it by doing a blacklist check from against
    LVL 13

    Author Comment

    Requested removal from blacklist
    then wt could be the problem with dns error?
    LVL 14

    Expert Comment

    No idea why it is reporting that. The parent servers return fine from elsewhere:

    Actually, just tested my own domain on dnscolos and it failed parent servers too. so i think it's something at their end.
    LVL 13

    Author Comment

    i have this problem from last 5 days

    even dail i am checking for blacklist no problem

    today only i found it as blacklisted
    LVL 65

    Assisted Solution

    The DNS error that you have posted you need to take up with whoever runs your DNS servers. It will not be related to Exchange or email failure.

    LVL 13

    Author Comment

    got the solution problem fixed sembee

    Sending email to certian domains does not work when you run Exchange Server 2007 on a Windows Server 2008-based computer

    You may have trouble sending mail to certain domains while using Exchange Server 2007 on Windows Server 2008. The Queue Viewer displays the following status error for the domain in question:

    451 4.4.0 primary target IP address responded with 421.4.4.2 unable to connect.attempted failover to alternate host, but that did not succeed.Either there are no alternate hosts, or delivery failed to all alternate hosts.

    This problem occurs because routers do not support the TCP autotuning settings in Windows Server 2008.

    To disable autotuning, follow these steps:

    Run CMD as Administrator

    At the command prompt, type the following command, and then press ENTER:

    netsh interface tcp set global autotuninglevel=disabled

    This command disables the Receive Window Auto-Tuning feature.

    Exit the Command Prompt window.

    Restart the computer.

    Expert Comment


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Wish Marketing would stop bothering you?

    Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

    Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
    New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
    The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
    This video discusses moving either the default database or any database to a new volume.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now