[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 936
  • Last Modified:

Problems with services loading on SBS 2008, seems to be IPv6 related. Different scenarios..

Hi, I'm really stumped with a problem on an SBS 2008 and hoping someone can help. The problem came to light when I was trying to switchover from POP3 addresses to SMTP Exchange addresses. Mail was going out but not coming in so I tried a Telnet. When I initially ran NSlookup, then set q=mx (just to check the MX record) I noticed the DNS server address was an IPv6 address. I tried looking up a few domains but got no results; the DNS requests just timed out. I tried loading a few webpages (ones that I'd never visted before on the server) and they worked ok so DNS seemed to be working.

Next thing I thought to try was disabling IPv6. When I did this, I got this issue I see a lot of people have had where the machine hung on "Applying Computer Settings". Looking at the services remotely via another server, I can see the "Exchange Information Store" and "Exchange Transporter" services are trying to start/stop and this seems to be causing the hanging.

In the Event logs, I got lots of the following EventID's: 2141, 2114, 2102, 2501, 1031, 7005. The main messages being:

"2114 (Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=2248). Topology discovery failed, error 0x80040a02 (DSC_E_NO_SUITABLE_CDC). )..."

"2114 (Process MAD.EXE (PID=2388). Topology discovery failed, error 0x80040a02 (DSC_E_NO_SUITABLE_CDC).)"

Once I got logged in, I tried (as suggested elsewhere) disabling IPv6 via the registry. When I did this and rebooted, the user profile service won't load. This caused major issues logging in etc. so I had to change the registry back straight away.

At the minute, I've switched them back to the POP3 addresses while I work this out. Any help would be really appreciated.
0
wiggum83
Asked:
wiggum83
  • 8
  • 6
  • 2
  • +2
3 Solutions
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
When you have Exchange 2007 on Windows 2008 and is a DC\GC IPv6 has to be enabled for Exchange to be able to communicate with AD and DNS just correctly
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Firstly please enable IPv6 and tell me what you want next we can go ahead with just having SMTP and use your internal server for Routing mails "To and Fro"
0
 
wiggum83Author Commented:
Hi Rancy. Thanks, that clears up one thing...I know it needs to be enabled. What about the fact that I can't get nslookup to work when IPv6 is enabled? Any ideas?

Cheers.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Create a Send connector in HUB under Organization configuration as Internet ..... now in HUB under Server config go to the properties of the Default receive connector and properties "Permission Groups" and check the box for Anonymous users .....
Lastly but the most IMP restart the Microsoft Exchange Transpoprt service ....
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
IPv6 has nothing to do with Nslookup ... whats the DNS serevr that your Exchange server points to do you have any other entries in there as well ?? Are you using WINS ?? How many NIC cards do you have ??
0
 
wiggum83Author Commented:
Thanks again for the help. To answer a couple of your points; I have already checked Anonymous users under the default receive connector inside EMC as I read that elsewhere (and rebooted a few times since). The customer uses BT as their ISP so I'm using their DNS servers as forwarders. The server I'm working on is the domain controller, exchange server and DNS server.

I don't think I'm using WINS...

The server has 2 NIC's but I disabled one during the inital setup.

Any other ideas? I just don't want to go changing their MX record again in case no mails get through. Like I say, last time I changed mail would go out but nothing would come in.
0
 
Darius GhassemCommented:
If you are running Exchange on this box you need to have IPv6 enabled.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
You have to have your own DNS in the NIC card properties .... Your ISP has to be on the Forwarders tab in DNS Forward Lookup Zone ...
If you have 2 NIC's and one Disabled can you once check the Binding Order ?? and make sure the one working is at the Top ....
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Also if your Exchange is able to send means that the Send connector and everything is awesomely fine ..... Now for your mails comming in has few things ... ISP needs 24 hours for your MX record to be updated on the Internet .... get in touch if mails cannot be received from the internet .... ask them if mails are being received by ISP for your domain and then routed to your server ??
0
 
wiggum83Author Commented:
I have my own DNS server in the NIC properties (IPv4) and the ISP in the forwarders tab. I've just checked the binding order and the unused NIC was at the top. Do you think that could be it? Again, just don't want to go ahead without being fairly sure!
0
 
Darius GhassemCommented:
Yes, that is most likely part of the problem. Change the binding order and if you aren't using the second NIC disable.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Yeah that can cause issue as whenever any query is made it will check the binding order and try the NIC first in  the order and so on ....
0
 
McClaneCommented:
SBS 2008 needs IPv6 to work. It won't function properly without it.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Hi wiggum83 ..... any updates on the going scenario .....
0
 
crossfiredCommented:
As it turns out, The debate over weather IPV6 can or should be disabled rages on. As it turns out, there is a step missing from alot of the documents out there. Here is a good one:

http://blogs.technet.com/sbs/archive/2008/10/24/issues-after-disabling-ipv6-on-your-nic-on-sbs-2008.aspx

Now for the secret.... yes.. ancient ingredient... THe HOST FILE>>> in 2008 we go to c:\winddows\system32\drivers\etc\hosts. Open this with notepad and remove the "::1 localhost"
This eliminates confusion and the server forces IPV4.  

So much for your IPV6 issues.. This also fixes the "stuck applying computer settings" issue ... Ok. Happy trails :-)
0
 
wiggum83Author Commented:
Thanks for following this up everyone. Based on what I've read, I'm going to keep IPv6 on. Just switched the MX record back to the Exchange server now so I'll keep you all updated. Thanks again.
0
 
wiggum83Author Commented:
Ok, further update. Once again mail is coming out via Exchange but not in. The thing I find out is that it's not coming in to the POP3 boxes either. :( Surely, even if the MX update takes a while, it should be arriving somewhere eh?
0
 
wiggum83Author Commented:
Problem solved! :D Thanks to everyone who helped. Regarding the mail not coming in, I was being a complete idiot. Port 25 wasn't opened properly in the firewall. :)
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 8
  • 6
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now