Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2454
  • Last Modified:

Event id 10016 DCOM

Hi

We just started getting these errors on windows XP SP2 stations.  I follwed the link to a resolution (enclosed) but unable to find the offending program (Quartine Private SHA Binding Class) when I go to the DCOMCONFIG utility as described.

http://www.experts-exchange.com/Hardware/Networking_Hardware/Firewalls/Q_22416529.html?sfQueryTermInfo=1+10016+dcom+window+xp

Event Type:      Error
Event Source:      DCOM
Event Category:      None
Event ID:      10016
Date:            12/17/2009
Time:            8:45:24 AM
User:            NT AUTHORITY\SYSTEM
Computer:      DEV3111
Description:
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{24FF4FDC-1D9F-4195-8C79-0DA39248FF48}
 to the user NT AUTHORITY\SYSTEM SID (S-1-5-18).  This security permission can be modified using the Component Services administrative tool.


10016.jpg
0
Tech_guy
Asked:
Tech_guy
1 Solution
 
Brian BIndependant Technology ProfessionalCommented:
You may have to search the dcom config utility for that specific registry key. Sometimes it doesn't have a name.
0
 
flubbsterCommented:
Are you running server 2008?

If so, or even if not, check the startup mode of Network Access Protection Agent. If it is set to manual, change it to automatic and restart the server.
0
 
Tech_guyAuthor Commented:
I dont see any option to search the dcom config utility?  I find the registry key (screencapture) but when go to Dcomconfig no way to know what I am looking for, in the other solution it gave the name of the program he went into Dcomconfig and could locate the Dcom and change the security.  I have the thing that is causing the issue but unable to find how to change the security.

 I am getting this error on XPSP2 machines, I did check the Network Agent and changed to Automatic and will reboot the system see if that resolves the Dcom error  


expertexchange.NAgentjpg.jpg
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Brian BIndependant Technology ProfessionalCommented:
From your error message above, there is a registry key {24FF4FDC-1D9F-4195-8C79-0DA39248FF48}. You'll have to use regedit to go through the registry and then search for that key. Inside will be either a name or another key. Whichever it is, you have to go through the dcom config and find it. (Its a long process, sorry). Then edit the permissions of the object you find.
0
 
TrustWiseCommented:
Is there a reason you haven't updated to SP3, this might solve your problem?
0
 
Tech_guyAuthor Commented:
I will look harder for the registry key, when in there am I looking for this key (24FF4FDC-1D9F-4195-8C79-0DA39248FF48) in the Dcomconfig?  I will go one by one to see if I can find it.  I did upgrade our workstations to SP3 on Tuesday but the error is still present.
0
 
v2shahaCommented:
Hello Tech quy,

if you still facing the DCOM issue please do the following,

The current work around  is to double click on "Component
Services"/My Computer/DCOM/"NAP Agent Service" and right click and select
"Properties". Under the security tab, edit, check the box for Local Launch for
system.

Go to the link :-
http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2585993&SiteID=17 

Hope this will help you to resolve the issue.

Cheers
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now