?
Solved

need help to up line protol and nat address

Posted on 2009-12-17
17
Medium Priority
?
221 Views
Last Modified: 2012-05-08
HI
i am new to cisco
initially i setup this router with isp and a switch. which used to work nice
today i have put another Linux gateway router and change the  iP, now its showing line protocol down, i am gussing its for gateway ( i think) but i need help asap, rather then go by video tutorial

this the : show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            192.168.1.66    YES manual up                    up
Ethernet0/1            192.168.2.1     YES manual up                    down
and

EV-Router#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname EV-Router
!
enable secret 5 $1$xxxx$euBxxxxxxxxr1qdJVYBRi/
enable password 7 094ExxxxxxxA04
!
memory-size iomem 10
ip subnet-zero
ip name-server 192.168.1.254
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.1.66 255.255.255.0
 no ip directed-broadcast
 ip nat outside
!
interface Ethernet0/1
 description router-to-ipcop
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
!
ip nat inside source list NAT_ADDRESS interface Ethernet0/0 overload
ip nat inside source static tcp 193.132.234.6 22 interface Ethernet0/0 22
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!
!
ip access-list standard NAT_ADDRESS
 permit 193.132.0.0 0.0.255.255
banner motd ^C
****************************
this is a secure router,Unauthorized logins are
restricted.
****************************
^C
!
line con 0
 password 7 050xxxxxxxxxxxx5180D
 logging synchronous
 login
 transport input none
line aux 0
line vty 0 4
 exec-timeout 20 0
 password 7 104C5xxxxxxxxxxxxxxxxxD0C
 logging synchronous
 login
!
end



Here, i need help

(a) line protol up for 192.168.2.1
(b) how will i change the  permit address permit 193.132.0.0 0.0.255.255 to 192.168.2.1 ??
0
Comment
Question by:fosiul01
  • 10
  • 4
  • 3
17 Comments
 
LVL 1

Expert Comment

by:DjArioch
ID: 26072837
What is connected to 0/0 and what is connected to 0/1? I'm confused by the physical setup of the connections. You removed a switch, was that connected to 0/1? The linux gateway is now at 0/1? What is the IP of the linux box?
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26072865
Thanks

You removed a switch, was that connected to 0/1?  : yes,

The linux gateway is now at 0/1? What is the IP of the linux box?  : yes The ip of the Linux router : 192.168.2.2 , Gateway 192.168.2.1, ( which is conntected to cisco router Ethernet0/1  
 )

Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            192.168.1.66    YES manual up                    up      ::::::::: this with ISP
Ethernet0/1            192.168.2.1     YES manual up                    down    ::::::::: this is going to linux router (it will work as a firewall router)



0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 26072894
As for why it's down, we'll have to wait until we know what it's connected to.

As for changing the ACL, if you change the permit to that of the router, no traffic will be translated since no host traffic is originating from that address and the router's traffic doesn't need to be translated.
0
Shaping tomorrow’s technology leaders, today

The leading technology companies all recognize the growing need for gender diversity. Through its Women in IT scholarship program, WGU is working to reverse this trend by empowering more women to earn IT degrees and become tomorrow’s tech-industry leaders.  

 
LVL 1

Expert Comment

by:DjArioch
ID: 26072909
I dont think the acl needs to be changed, it's the same ip we just dont have a connection. Are you using the same ethernet cable from the switch? Is it a straight or crossover cable?
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26072919
As for why it's down, we'll have to wait until we know what it's connected to.  :
as i said , its Linux with 2 Ethernet card , One is connected to cisco router( where i am facing the problem), another one is connected to cisco switch ( internal network, which is working fine)

so basicaly, From linux box, if i ping 192.168.2.1 , it does not find any route and same in cisco , its showing , line protocol down

hope it will help
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26072932
Is it a straight or crossover cable?

it usd to be crossover cable, as it was connected to the switch , since it connected to linux box, i used straight cable

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 1880 total points
ID: 26072958
Wrong cable.

Router - Switch = straight through (unless the switch supports auto-mdx)
Router - PC = crossover

0
 
LVL 1

Assisted Solution

by:DjArioch
DjArioch earned 120 total points
ID: 26072979
Right I would try a crossover, line protocol shows a connection issue which is what a crossover/straight would explain.
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26073053
hahahahaha
thats BAD!!

yes , i used a wrong cable
so its showing both up
and each can ping each other

now just i need to change the ip of ACCESS from 193.x.x.x to 192.168.2..0
0
 
LVL 29

Author Comment

by:fosiul01
ID: 26073064
this line

ip access-list standard NAT_ADDRESS
 permit 193.132.0.0 0.0.255.255
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 1880 total points
ID: 26073098
Here ya go.

conf t
ip access-list standard NAT_ADDRESS
 no permit 193.132.0.0 0.0.255.255
 permit 192.168.2.0 0.0.0.255
end

Open in new window

0
 
LVL 29

Author Comment

by:fosiul01
ID: 26073141
thats sweet!!
its wokrs

is not there any way to delete  193.132.0.0 0.0.255.255
instead of putting No permit??

0
 
LVL 29

Author Comment

by:fosiul01
ID: 26073153
ohh, after putting no permit, its actaully delete that line!!

0
 
LVL 29

Author Comment

by:fosiul01
ID: 26073174
sorry i know its good to ask a new question, but just quick one

ip nat inside source static tcp 193.132.234.6 22 interface Ethernet0/0 22

if i type

no ip nat inside source static tcp 193.132.234.6 22 interface Ethernet0/0 22

will it delete that forwarding??

if yes, just say yes, if not just say , no, then i will create another question

0
 
LVL 29

Author Comment

by:fosiul01
ID: 26073259
its ok after typing the new command it automatically erased the previous command

thanks for you guys help
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 1880 total points
ID: 26073262
>will it delete that forwarding??

Yes
0
 
LVL 29

Author Closing Comment

by:fosiul01
ID: 31667345
thanks
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question