[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1481
  • Last Modified:

upload video on sharepoint

Hi Experts

,  I'm trying to upload video (FLV) files to a sharepoint document library and it just seems to time out.  Do I need to do any configuration to upload this format?  (Using MOSS 2007)

Thanks
0
jmsjms
Asked:
jmsjms
1 Solution
 
svgmucCommented:
There are blocked file types in the Sharepoint configuration. You need to enable FLV files there.
0
 
amolghanwatCommented:
Central Administration -> Operations -> Blocked File types.

Another possibility is that the size of the file is too large.
Check the maximum upload size allowed in Central Admin -> Application Management -> Web Application General Settings

You also need to make few changes in the web.config file and IIS timeout settings. (Check the kb mentioned below to change the web.config settings)

Also, if you are using Windows Server 2008 for hosting SharePoint, then you need to make the web.config changes.
http://support.microsoft.com/kb/944981
0
 
jmsjmsAuthor Commented:
Looked in Central Administration -> Operations -> Blocked File types.and FLV isn't listed...

The file I try to upload is 11 Megs.

I've got direct server access and loading the files from the servers desktop as opposed to over the Internet seems to work.

Is it a time out thing?  If so how do I fix it.  I've increased the points as looks like it's a bit more complex thatn I thought.  Thanks Guys.

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
jmsjmsAuthor Commented:
For info.  I've now managed to upload all flv files from a folder located directly on the server.  It was the size of the files.  Admin had it set to 50MB and some of the files I tried to upload were over that.

However, I still cant upload from a remote connection (over ASDL)  It seems like it's trying and I can see the bar getting green at the bottom of the brower but it never seems to complete...
0
 
StevenMulkerrinsCommented:
That definitely sounds like a timeout issue. One thing to keep in mind is that with ADSL your upload speed is most likely much much slower than your download speed. Another potential problem is that some network device in between you and the server is rejecting the transfer. I'm assuming you are trying to upload them from home to a server in work or something similar, is it possible that your corporate network has some kind of filter/firewall which may block flv/video content?
0
 
amolghanwatCommented:
If you see the progress bar and if after some time, you see a 404 page not found, then it is an issue either the time out or the browser that you are using.

There are still three things to try:

1- Try using a different browser and see how that works. This is because of the "type" of data that is sent across to the server.

2- If you are able to upload files from the server, then most relevant thing that comes to my mind, is that you are using Windows Server 2003 with SP2. If that is the case, disable the chimney offload feature (or update your network card drivers, most probably it will be Gigabyte NIC).

To disable, run this on the server:
netsh int ip set chimney DISABLED

Refer: http://support.microsoft.com/kb/951037

3- As mentioned in http://support.microsoft.com/kb/944981, increase the time out value to 99999 in the web.config file (This kb is for use if you are using Windows Server 2008 to host SharePoint)
0
 
jmsjmsAuthor Commented:
I'm using 2003.  Is there a timeout in MOSS 2007 on 2003?

I'm uploading from my home office PC to the remote server.  I can ftp the files to the server no problem.
0
 
amolghanwatCommented:
Windows 2003 (with SP1 or SP2 ???)
NIC ??

Have you tried the above three steps? What was the outcome of those?

And yup, timeout can occur if you have chimney offload feature enabled on Win2003 server. So check with the above 3 points and let know what happened.
0
 
jmsjmsAuthor Commented:
Windows 2003 SP2

Two Network cards one disabled.

I will try points 1 and 2 but point 3 only applies to 2008 so doesnt seem to be useful here.

Is there a timeout feature in MOSS2007?
0
 
amolghanwatCommented:
For time out settings in MOSS. check:
Central Admin -> Application Management -> Web Application General Settings

0
 
jmsjmsAuthor Commented:
Thanks.  WIll check this coming Monday and report back.
0
 
jmsjmsAuthor Commented:
Sorry, got caught by the Xmas break.  WIll try this Thursday.  Thanks.
0
 
jmsjmsAuthor Commented:
Hi GreatGerm,

I've not had time to test amolghanwat's suggestion.  Will do this week.

Cheers
John
0
 
jmsjmsAuthor Commented:
Sorry got caught up with another issue.  This week!
0
 
jmsjmsAuthor Commented:
not yet please! Cant say wether this is a solution or not.  Apologies for not yet checking.. :-(

J
0
 
jmsjmsAuthor Commented:
Anyone viewing this please be aware that I have not confirmed this as the answer (though it might well be!)  Thanks to amolghanwat and the other experts for their suggestions.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now