• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1151
  • Last Modified:

Default Document Not Showing IIS 7

I have used IIS for years but as of now only have 2 IIS 7 web servers. Of the sites I have setup, I have not used a default document, until now. I setup a site yesterday with index.html in the root. If I access the site without typing in a page name, it doesn't default to any start page and instead acts as though the document is not found. If I type in the index.html it loads fine. I went into the default documents and promoted index.html to the first document and even removed all except that one and still no luck.

On this server I have a site www.mysite.com without a default page. The new site I setup is actually in a sub dir, www.mysite.com/docs. I tried just leaving it as a folder, creating a virtual dir for that folder and also converted to an application for that same folder and all are the same results. Is there some strange trick that I am just not aware of for IIS 7?
0
doby48
Asked:
doby48
  • 4
  • 3
1 Solution
 
meverestCommented:
Hi,

do you have default document module enabled in the IIS config?

http://technet.microsoft.com/en-us/library/cc754807%28WS.10%29.aspx

Cheers.
0
 
doby48Author Commented:
Yes default document is enabled. I reordered the list of default document so my index.html is the top one. That made no difference so I removed all but index.html and still no go.
0
 
meverestCommented:
Hi,

are you sure that you are looking at the right web site?  note that you can set default document properties on directory, web site, and server - the 'topmost' setting takes priority, so if the server setting says 'index.html' and the virtual directory say 'no default document', then the latter applies.

Also check the server bindings properties on the relevant web site to make sure that it has the right hostname and/or ip address set.

Cheers,  Mike.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
doby48Author Commented:
Yes I am sure I am looking at the right site and yes the host name and bindings are correct too. The primary site loads fine at http://mysite.com and site I am trying to load is http://mysite.com/docs. The primary loading fine, the new one with the subdir is the one that loads ony when specifying the web page, no defaulting to the page.
0
 
meverestCommented:
OK, so if I understand it correctly,...

you see the same result when you enter http://mysite.com OR http://mysite.com/index.html, but...

you see the page ok with http://mysite.com/docs/index.html but NOT with http://mysite.com/docs

If so, then in the IIS manager, expand the navigation tree and (left) click (once) on the virtual directory 'docs'.  At the bottom of the main frame, make sure that you have 'features view' selected, and double click on the 'default document' item.

Make sure those settings include the index.html and it is at the top of the list.

Cheers,  Mike.
0
 
doby48Author Commented:
Yes that is correct.

And yes I have already done what you mention and I see my default document listed at the top of the list. I even removed all documents other than my default so only index.html shows in the list and yes I am certain that I am looking at the correct folder and not making the changes to my default site or any others on the server.
0
 
doby48Author Commented:
Found a solution and not sure why this site is working this way...  In the default documents I added a / before the name of doc. So I put "/index.html" as the default document in stead of "index.html" Works with no issues now.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now