Server will not recognize more than 1Thermaltake USB external drives

When plugging in a 2nd USB Thermaltake Max 4 Esata & USB Combo external enclosure (Western Dig 1TB eSATA drive in the enclosure), the "safely remove hardware" icon and/or the drive letters for the two external drives disappears.  These are for backup purposes.

1.  In computer management, the first USB will be visible and accessible.  The second is not present even after rescanning the drives.  All other "brands" of external drives are visible (other brands Addonics external enclosure, Maxtor one touch, etc... - don't have other Thermaltake models to try)
2.  The "Safely Remove Hardware" icon is visible only if I have another(s) USB device plugged in (i.e. Addonics external enclosure, Maxtor one touch, etc...).  No Thermaltake drives are present for safe removal.
3.  In "My Computer", the first thermaltake drive is available and useable.
4.  With more than 1 Thermaltake plugged in Rundll32.exe will shows only the non-Thermaltake drive(s) (Addonics, Maxtor, etc...).  

As an added twist, we a another Thermaltake Max 4 connected via eSATA port (though this appears to not have any different results for the USB drives, whether plugged in or not).

Any suggestions since I have 10 of these enclosures for daily and weekly backup purposes?
alfredmgaAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
gikkelConnect With a Mentor Commented:
I think you may have done it again...reinstall, but do not move the drive to other usb ports.  You'll likely have no problems if you reinstall windows server, but I don't think that's something you'd want to do.  If the drive is still being identified with a drive letter, remants are in the registry.  Did you remove the driver from the "disk drives" area as well?  
In all honesty, I can guarantee you we will get this to work, but it may take more time than its worth...I think picking up a sata controller like we discussed before would solve your problem and as an added bonus, allow faster data transfers...
0
 
gikkelCommented:
Reinstall device driver
http://thermaltakeusa.com/Product.aspx?C=1285&ID=1660#Tab4
Is the drive recognized correctly when its attached by itself?  External hdd devices go bad quite often...I would suspect it was a usb issue, but if it doesn't work with esata that wouldn't be the culprit.  The safely remove device hardware will not appear if the device doesn't have the removable media bit set - this is normal.  Try restarting with all devices attached.  What is shown in your bios?  If all drives are shown, make sure your boot order is correct and reboot to windows.   Also, if availalbe, update your motherboard bios.
0
 
alfredmgaAuthor Commented:
Individually each Thermaltake Max 4 USB enclosure is recognized correctly, including "Safely Remove Hardware", Computer management, etc...  These Max 4 enclosures can be attached via eSATA or USB.  A Max 4 enclosure attached via eSATA cable and a sinlge Max 4 enclosure attached via  USB also work perfectly together.  It is only when I add a second Max 4 USB enclosure that I encounter this problem.

I will see if both of these USB devices are recognized in the BIOS at reboot.  I suspect that at least one is since I see one of the drive letters flash on the BGInfo Screen then disappear when logging on.

This a new server and I believe that all motherboard bios updates have been complete but will check that as well.

0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
alfredmgaAuthor Commented:
I want to make this clear:  I am actually adding a 3rd Max 4 device, but one is eSATA and the other 2 are USB.  I only have the problem when adding the 2nd Max 4 USB.
0
 
gikkelCommented:
If you wouldn't mind, lets work with the main issue before you try to connect 3 of the same drives (just use two of the max 4 devices on USB)...way too many variables.   Did you try cycling through different USB ports? Can you connect any other two hdd devices via usb? If so, uninstall both max 4 (or one if the other isn't present, which would make much more sense) devices from your machine...
set devmgr_show_nonpresent_devices=1
start devmgmt.msc
View -> show hidden devices
Reinstall with thermaltake device drivers.
Is this your board?
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Server+Products&ProductLine=Intel%c2%ae+Server+Boards&ProductProduct=Intel%c2%ae+Server+Board+S3200SH&ProdId=2869&LineId=3161&FamilyId=37
Reinstall chipset driver.  
Let me known how you make out...you may just want to avoid this altogether and purchase a sata controller with external ports - it'll be much faster than usb and you really don't need all that great of card - $30-$50 should suffice.  Did you build the server yourself?
0
 
alfredmgaAuthor Commented:
I can connect any 2 USB (actually up to 4 devices - all the USB ports available) devices to the system, including one Max 4 device.  Any combination works fine.  I just can't connect a second Thermaltake Max 4 USB device.  It appears that they conflict with each other or the system in some manner.

Our board is actually a Intel 3210SH.  It is essentially the same as the link you provided.  Just one of the 2 PCI x4 slots is not found on this board.

Tell me more about the external sata.  Our current sata is a dongle that runs from the mother board sata pins to a bracket slot in the back of the computer.  Then it is connected to the external eSATA drive via an external eSATA cable.  It is not hot swappable nor is the sata drive listed in removable drives.

Would a SATA controller card with 2 or more ports be able to switch out SATA disks without restarting the server?
0
 
alfredmgaAuthor Commented:
My apology for the time to implement all of the possible solutions.

A local company who helps with our network built the server.
0
 
gikkelCommented:
Can you send me a link to your motherboard info?  If you buy a pci/pci-x/pcie sata II controller, you shouldn't have a problem with hot swapping.  Your current motherboard probably supports the function, but you need to enable ahci or raid from the bios.  If your OS is on a drive connected to your sata controller, you'll need to do some modifications before you enable advanced features (or else it won't boot until you set back to ide emulation mode).  
http://www.newegg.com/Product/ProductList.aspx?Submit=ENE&N=2010150410+1193218488+1193328388&QksAutoSuggestion=&ShowDeactivatedMark=False&Configurator=&Subcategory=410&description=&Ntk=&CFG=&SpeTabStoreType=&srchInDesc=
http://www.newegg.com/Product/ProductList.aspx?Submit=ENE&N=2010150410+1193218488+1193328636&QksAutoSuggestion=&ShowDeactivatedMark=False&Configurator=&Subcategory=410&description=&Ntk=&CFG=&SpeTabStoreType=&srchInDesc=
 
0
 
alfredmgaAuthor Commented:
The mother board is in the S3200SH family.  
The board is a:
Table3. IntelĀ® Server Boards S3200SH-L / S3200SH-V Component Layout Reference

Documentation found here:
http://download.intel.com/support/motherboards/server/s3200sh/sb/e14960008_s3210sh_tps_r1_7.pdf

Also this has some specifics
http://www.intel.com/support/motherboards/server/S3200SH/ 

I had assumed that I would be able to swap the SATA drive off one of the 6 SATA ports on the motherboard without having to shut the sever down.  At this point, I have not come up with a solution for "hot swapping" an external eSATA connected via a bracket to the mother board, so I like the idea of the PCI eSATA controller card.

I have work to do.
0
 
alfredmgaAuthor Commented:
Okay.  The 2 USB MAX 4 devices are clearly listed and recognized in the BIOS.  

After reboot, the Device Manger shows one of the 2 USB mass storage devices with a Yellow Exclamation and the following message:

Windows cannot load the device driver for this hardware because there is a duplicate device already running in the system. (Code 42)

The other USB Mass storage device works correctly.

For some reason, the various Max 4 USB drives are seen as the same drive.  Limitation on this enclosure or the Western Digital 1 TB hard drives?
0
 
gikkelCommented:
It may be from duplicate serial numbers...but its more likely that you moved one of the drives from one usb port to another before using the other drive.  
Review my previous comment - ID:26084298
Remove the drives from the USB ports and restart.  Completely uninstall all max 4 drives from device manager and uninstall the USB Mass Storage Device driver for the enclosure (under Universal Serial Bus controllers)...make sure you follow previous guidelines for showing nonpresent devices.  If you can't determine which drivers are used by your max 4 drives under USB controllers (properties -> details), you may have to uninstall all that are greyed out.  
Double check this value:  open regedit and navigate to HKEY_LOCAL_MACHINE/SYSTEM/Setup.  If there is an entry FactoryPreInstallInProgress, look at the data value...if its 1, let me know.
Make sure you have all your Server 2003 updates and service packs installed.  Restart with no devices attached.  Plug in one the max 4 drives.  Use driver from website.  Restart.  Install other drive...
Have you tried using a different port?  It may work on another hub...
0
 
alfredmgaAuthor Commented:
I have made sure that all windows updates and appropriate service packs have been installed.
- Windows Server 2003 Domain Controller, Standard Edition Service Pack 3 in effect
- Windows update version number 7.4.7600.226  Latest update (KB971737)

I uninstalled all USB mass storage devices, leaving only the USB Composite device (IOGear switchable keyboard/mouse/monitor).  Reboot. There are 7 USB Root hubs seen and appear to be functioning correctly after reboot.  No other devices hidden or otherwise.

I plug in the first MAX 4 USB device.  Found new hardware and indicated ready for use.  Recognized by the system, found in "Disk Managment"  and found the "Safely remove hardware" notification.  I can "safely remove" the drive and plug it into any of the 3 available USB ports with the same result and function.  However, I notice the drive is assigned "H:" (its former designation) rather than the next drive letter available which would be "G:".  I am able to change the drive letter to "G" in computer management.  Functions as it should.  Left it "G:"

I plug in the second Max 4 device.  Found new hardware process started.  Received bubble notification "A problem occurred during installation.  Device may not be able to be used". now have the following results:
- in "Safely remove hardware" the "G:" drive has disappeared and "H:" drive is now present.
- In Computer Management, only the "G:" drive appears, even after rescanning drives.  "H:" is not present
- In "My Computer" I can see both the "G:" and the "H:" drives and access both.  The backup files on each are the appropriate (and different) dates that they should be. I can copy files to each drive.

Decided to add one more USB external backup drive of a different brand (Addonics External USB).  It automatically installed and was assigned the next drive letter which is "I:".  It functions perfectly, can be seen in "Computer management" after rescan, and is present in "Safely remove hardware".

I now remove the Addonics USB mass storage device.  The results are still the same as above:  "G:" shows in computer management and "H:" shows in "Safely remove hardware".

I now go to "Safely remove hardware" and remove "H:".  Both "G:" and "H:" are removed at the same time and are no long seen anywhere.

After this,  the "G:" or "H:" drives I can be added back individually and will appear under "Safely Remove Hardware".  

By the way, I don't have this issue with multiple Max 4 / WDigital Sata drives on another computer with XP Pro.  Drives work fine.


0
 
alfredmgaAuthor Commented:
Thanks for the help.  I will move toward the SATA controller route.  I am sure that this can be done but narrowing it down will be time consuming.
0
All Courses

From novice to tech pro — start learning today.