• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 673
  • Last Modified:

unable to start apcache on SLES 10 sp2

I am unable to start apache after migrating the apache from redhat 4 apache2 To SLES 10 sp2

I am getting an error ..
#:/etc/apache2/vhosts.d # /usr/sbin/apache2ctl start
Syntax error on line 133 of /etc/apache2/vhosts.d/abc.com.conf
Invalid command 'JkMount', perhaps misspelled or defined by a module not included in the server configuration
0
kaka123
Asked:
kaka123
1 Solution
 
InsoftserviceCommented:
hi,

Please send the htpdf.conf file last lines where it defines the virtualhost
0
 
kaka123Author Commented:
<VirtualHost *>
    ServerAdmin webservices@99.com
    DocumentRoot /dir1/dir2/home.ear/
    ServerName abc.99.com
    ServerAlias
    ErrorLog /dir/log/apache/xyz-error_log
    CustomLog /dir/log/apache/xyz-access_log common
    Options Indexes FollowSymLinks MultiViews
    JkMount /* ajp13
</VirtualHost>

<VirtualHost * >
    ServerAdmin webservices@99.com
    DocumentRoot /dir1/dir2/dir.ear
    ServerName xyza.99.com
    ServerAlias
    ErrorLog /dir/log/apache/xyza.99.com-error_log
    CustomLog /dir/log/apache/xyza.99.com-access_log common
    <Directory "/dir1/dir2/dir.ear/">
        AllowOverride None
        Options Indexes ExecCGI
        Order allow,deny
        Allow from all
    </Directory>
    Options Indexes FollowSymLinks MultiViews ExecCGI
        RedirectMatch ^/$ http://xyza.99.com/dir/admin/
    JkMount /dir/* ajp13
</VirtualHost>
0
 
sardiskanCommented:
Did you ensure that you installed the JkMount module when you installed apache? If not you'll have to install it manually.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
uaynebCommented:
jkmount is a tomcat thing.  YOu need to load the tomcat module before you do a jkmount

0
 
kaka123Author Commented:
i am still unable to start the apache on SLES 10
./apache2ctl start
 [warn] VirtualHost 127.0.0.1:80 overlaps with VirtualHost 127.0.0.1:80, the first has            precedence, perhaps you need a NameVirtualHost directive
 [warn] VirtualHost 127.0.0.1:80 overlaps with VirtualHost 127.0.0.1:80, the first has            precedence, perhaps you need a NameVirtualHost directive
 [warn] NameVirtualHost *:80 has no VirtualHosts
 [warn] NameVirtualHost *:80 has no VirtualHosts
 [warn] NameVirtualHost *:80 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
0
 
sardiskanCommented:
Looks like the config file has two loopback virtualhosts configured. I don't see a virtualhost with 127.0.0.1 configured from the above so I must assume it isn't listed. Comment out the virtualhosts with 127.0.0.1
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now