[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2849
  • Last Modified:

Cannot open .xls file attachments in Outlook

I have a user who gets 2-3 .xls attachments in an e-mail a day and she is unable to open any of them, it gives her the following error: Cannot create file: Offspec.xls. right click the folder you want to create the file in, and then click Properties on the shortcut menu to check permissions for the folder.  She can forward the e-mail to me and I can view it no problem, and if I save the file to my computer, open it with excel, then save it and rename the file offspec.xlsx then attach it to an e-mail and send it to her she can view it.  How and what do I need to correct so that she's able to open the .xls attachment?  I have also checked folder options and made sure the proper program was selected to open the file with and it is set to 97-2003 Worksheet.

Thanks

mwtn35
0
mwtn35
Asked:
mwtn35
  • 19
  • 15
  • 9
  • +3
3 Solutions
 
roeibCommented:
well this is a known issue, in order to fix this you will need her todo the following :

GO to -> My Computer -> Tools -> Folder Options ->

goto the FileTypes Tab

find the Xls Extention, stand on it, and click on the Change Button.

now just select Excel as the application.

good luck
0
 
mwtn35Author Commented:
I have tried that and it still doesn't work.
0
 
Lunda_ConstructionCommented:
Have you loaded the latest service pack for Office 2007 on her PC.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
mwtn35Author Commented:
Office version is 12.0.6425.1000 is that the latest version or is there one newer than that?
0
 
Lunda_ConstructionCommented:
No that would be it, as long as it says Service Pack 2 also.

Have you tried, adjusting the Save settings to save files in this format: Excel 97-2003 Workbook choice.  Change it to that and see if she can open the files after that is selected.  If the choice is not there I would do a repair on the instillation.
0
 
Lunda_ConstructionCommented:
located in the office button, Excel Options, save section.
0
 
mwtn35Author Commented:
Adjusting the Save setting in Excel or through Outlook?
0
 
Lunda_ConstructionCommented:
Excel
0
 
Lunda_ConstructionCommented:
See if she can open the file if the file is saved in .xls format to her computer.
0
 
mwtn35Author Commented:
I went to excel and changed it to 97-2003 Workbook and checked everything again tried to open the file through outlook and I am still getting the same error.
0
 
mwtn35Author Commented:
I can't open nor can I save the file, I get errors when I do either one, it won;t save the file to her computer either.
0
 
Lunda_ConstructionCommented:
Restart outlook, save the file to her desktop then try and open it.  What we are trying to determine is, is the problem with Outlook or Excel.
0
 
mwtn35Author Commented:
I've restarted Outlook several times already and each time it doesn't give me the ability to save the file to her desktop it gives the same error that was in my initial posting.
0
 
mwtn35Author Commented:
I also created a folder on the desktop called Attachments and used the Save Attachements heading under Outlook, and it wouldn't save it that way either it also gave me the same error as my initial posting.
0
 
Lunda_ConstructionCommented:
Sounds more like a problem with outlook permissions.  I'll think on that for a moment.  

To resolve on weather or not Excel is playing a part.  Copy the xls file she sent you to a disk, and try to open the xls version of the file on her computer just using Excel.   This will help us rule out Excel as a culprit.
0
 
Limey1212Commented:
Hi,
I have had this exact same problem with a report I get regularly, here's how I've got things working again.

Click Start > Run and enter regedit into the run box
Follow the thread:
HKEY_CURRENT_USER > Software > Microsoft > Office > (Choose the ACTIVE version of Office, see Key for versions) > Outlook > Security.
In the Security folder look for the entry OutlookSecureTempFolder this is the path to the files you need to find and delete or move.
Open a window, and type the path information into the address bar OR double click the OutlookSecureTempFolder entry and ctl+c to copy the path from the open form.
n.b. do not try to open the path via folders, as most are hidden.
Once the folder is open, find the offending files and delete/move.
Office Versions Key:
Version 8 = Office 97
Version 9 = Office 2000
Version 10 = Office 2002 (aka XP)
Version 11 = Office 2003
Version 12 = Office 2007

I can't emphasize enough that you must look in the office version that's active on your machine.

hope it helps.
Dave
0
 
Lunda_ConstructionCommented:
Have you tried rebuilding the users Mail Profile?  It's possible that hers is corrupted.  or the .xls extension was somehow added to the blocked attachments list.

To recreate the profile go to Start, Control Panel, Mail, create a new profile, and go through the wizard to create a new profile, name it outlook new or something.  Logon with that profile and see if it does the same thing.  
0
 
acurreyCommented:
Tools|Options|General|Ignore other applications (uncheck it)

--- or ---

Close Excel and
Windows Start Button|Run
excel /unregserver
then
Windows Start Button|Run
excel /regserver


This is from a similar questions posted here: http://www.eggheadcafe.com/software/aspnet/31432668/cannot-open-xls-attachme.aspx
0
 
acurreyCommented:
Go to Tools>Options>General in Excel, not Outlook.
0
 
mwtn35Author Commented:
I was able to open other Excel spreadsheets from other departments, but when she gets an Excel Spreadsheet from the receiving department, she can't open, so I have a feeling it has to do with the way in which they are saving the spreadsheets....so we are going to check that tomorrow.  Do you have any other things I can look at or try that I might be overlooking?

Thanks

mwtn35
0
 
Limey1212Commented:
Hi,
here's what we noticed here, that if the same person receives a file with the same name constantly, and has to open it all is fine until the file count exceeds 99, (when you open the attachment any file of the same name is given a number in brackets).
When we cleared older versions of the files, we could open the new ones no problem.
0
 
Lunda_ConstructionCommented:
Mwtn35,

Boy that sure sounds like an Excel issue.  Especially if the file is being saved to a department she does not have permissions for.  The file would take on the permissions of the folder.   Seeing you have admin rights being tech support, you would more than likely have permissions to open.  

You may have found your own answer.  Please post back what you find, it may help others.  If not, we'll keep looking.
0
 
mwtn35Author Commented:
Well I am still not sure if it's a permissions issue, there are multiple people on the same e-mail and only this one person can not open the .xls file, everyone else can open it just fine, and she was able to open them in the past but over the last few months she hasn't been able to.  Limey suggests clearing the older versions of that file name to reset the counter, so how would I be able to go about doing that first to see if that fixes the issue?
0
 
Lunda_ConstructionCommented:
Check in her inbox to see if she has received the same attachment numerous times.  The attachment file name would have a number in brackets I believe.
0
 
mwtn35Author Commented:
Nope no number next to it, just says QLOG.xls (146KB) that's it nothing else there.  If it was an Excel issue I would think she wouldn't be able to open any Excel file, but she received 3 other Excel Files and I was able to open all of those with no problem.  I am checking with her now to see what she's been able to open or not open today I will respond shortly.
0
 
Lunda_ConstructionCommented:
Try saving the file to the same location with a different name.  Then send her the attached new named file to see if she can open that one.  This may shed some light on Limey's answer.
0
 
mwtn35Author Commented:
She can forward me the e-mail and I can save it to my computer, open the file in Excel, save the file as an XLSX file, send it back to her and she can open it fine no problem.  So you are wanting me to try to save the file to her computer, but use a different file name to save it as and see if that works, then try to open that new file name with Excel?
0
 
Lunda_ConstructionCommented:
Do not change the format or extension of the file, just the file name.  Like, ExcelFileNew.xls and see if she can open it.  To test the numbering theory.
0
 
mwtn35Author Commented:
Tried renaming the file and saving it to her desktop and it says Cannot create file : NewQlog.xls.  Right Click the folder you want to create the file in and then click Properties on the shortcut menu to check permissions for the folder.  
0
 
Lunda_ConstructionCommented:
Don't create the file on her desktop.  Create it before it is attached and sent.  For example.  Qlog.xls is saved in a Department folder.  Go to your workstation, open the file, save the file as NewQlog.xls, then attach that file to an email and send it to her to see if she can open that one.

This would test if the file name/numbering as Limey suggested is what is preventing her from opening.
0
 
mwtn35Author Commented:
I just had her send me today's Qlog and I saved it to my computer, then opened it in Excel, saved it as NewQlog.xls and then sent that to her and she's able to open that, so sounds like to me this confirms Limey's theory that she's reached the maximum for opening Q-log so it needs to be a different file name in order for her to open it?
0
 
Lunda_ConstructionCommented:
Or find a way to reset the counter.  

Limey1212, can you send the steps to reset the counter?
0
 
mwtn35Author Commented:
I appreciate your help so far up to this point, hopefully Limey can get me the steps to reset the counter or I am going to try looking for them and if I find them before I hear from Limey I will post here.
0
 
Lunda_ConstructionCommented:
After rereading what Limey sent, It appears they cleared the old files.  Check her inbox for emails with this particular file name attachment.   Delete the old or move them to a separate PST data file.
0
 
acurreyCommented:
The most likely place for the files to be is in a temp directory that Excel is uisng to call the file.
0
 
Lunda_ConstructionCommented:
Try emptying the Temp folder located here:

C:\Documents and Settings\username\local settings\Temp

0
 
Lunda_ConstructionCommented:
Or if running Vista or Win7 the file would be located here:

C:\Users\username\AppData\Local\Temp
0
 
acurreyCommented:
Try C:\Documents and Settings\User\Application Data\Microsoft\Excel

Tbis is the default autosave location for Excel.
0
 
acurreyCommented:
User = Username
0
 
Limey1212Commented:
To explain a little better.
There appears to be a bug/limitation/feature in Outlook that when you receive attachments with the same name, AND you attempt to open those attachments at the same computer, Outlook will give the opened attachment a new index number, (even if you open the attachment from the same email twice, (after closing the email and reopening it)).
e.g. the second time you open a new instance of "Offspec.xls" this will now open "Offspec (2).xls", and so on, until you reach "Offspec (99).xls", after that you get the message Cannot create file: Offspec.xls. right click the folder you want to create the file in, and then click Properties on the shortcut menu to check permissions for the folder.
Even if you try to either open or save the file, Outlook won't do it, until you've cleared the folder, outlined in the solution I gave to you, of all the OLD files of that name.
After you do you are good to go for another 99 instances of that file name again.
Hope that helps more, let me know if something is not still clear.
0
 
Lunda_ConstructionCommented:
Limey1212,

I'm really interested in this solution, so to be clear, could you send the exact path to where this folder is located we need to clear.  (i.e. C:\etc\etc.)

0
 
mwtn35Author Commented:
Limey, so I need to empty the old files out of Outlook or Excel?  I am going to go ahead and go in and empty out the other two folders that have been suggested as well.
0
 
Limey1212Commented:
Lunda Construction:
the path varies computer to computer, that's why you have to go into the registry to find the exact location of where office created the "OutlookSecureTempFolder" on your computer at install time. Follow the instructions I outlined, it will take you there, be sure that if you have had multiple version of office on the computer, (you've upgraded), that you open the thread in the registry to the latest OR active version of Office.
mwtn35:
See my instructions earlier, you are clearing a folder that was created when Outlook was installed on your computer.
0
 
acurreyCommented:
Outlook 2007: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Security

Check this registry key for the path to the folder that you need to clear.
0
 
Limey1212Commented:
Here's a PDF of a screen shot on my computer of the registry, and the thread where the "OutlookSecureTempFolder" entry.
if you notice, circled it says "Office" > 10 > 11 > 12. Ok they are the different office version I've had at one time or another on this computer. I presently run Office 2007 which is Office 12.
Hope that makes it more clear.
registry.pdf
0
 
Limey1212Commented:
Right, once in the "Security" folder, look for an entry "OutlookSecureTempFolder".
double click on it, and a form opens, the file path with be highlighted Ctl + C and paste that path into a new window.
once the folder is open, clear the old files.
0
 
Limey1212Commented:
Also, don't try to follow the file path outlined in the registry, PASTE it into the address bar of a new window. otherwise you will not be able to find the folder.
0
 
Limey1212Commented:
I also found this same instructions as I gave plus, they have tools they say will do the same job. Not tried them, don't know how good they are.

http://www.howto-outlook.com/faq/securetemp.htm

Hope it solves your problem.

Dave
0
 
Lunda_ConstructionCommented:
Yes, these instructions are much better.  Kudos to you!
0
 
Limey1212Commented:
Yeah I was looking for them earlier, but of course couldn't find them LOL
0
 
Daza_WIlliamsCommented:
I found that to fix the problem on our Vista PC's running Office 2007 we had to delete the following folder from the users PC :-

C:\Users\<login name>\AppData\Local\Microsoft\Windows\Temporary Internet Files\content.Outlook\
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 19
  • 15
  • 9
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now