troubleshooting Question

sql_trace

Avatar of sam15
sam15 asked on
Oracle Database
8 Comments2 Solutions1119 ViewsLast Modified:
I am tryin to set sql trace for a procedure that runs slow first time it is called in the morning.

So i added

begin
execute immediate 'alter session set sql_trace = true;'

...code

execute immediate 'alter session set sql-trace=false';

end;

When i run it from the web using mod_plsql i see
ORA--01031 ORA-01031: insufficient privileges

When i run ti using sql*plus it runs but i see no trace file in the dump directory.

any ideas what to do to get a trace file for TKPROF for the slow request of the procedure.
ASKER CERTIFIED SOLUTION
sventhan

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 2 Answers and 8 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 8 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros