• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2048
  • Last Modified:

Ad-Hoc Wireless connection and FireWall Problems

I have successfully (well almost) set up a wireless connection between my iTouch and Laptop.

The laptop connects to the internet through a dongle.

I create an ad-hoc wireless connection on my PC (running Windows 7).

Now the issue starts with my Firewall.

The iTouch cannot access the internet, because my PC's firewall is blocking the connection.

In PC Tools Firewall, if I look at the History is displays that the rule 'All Other TCP and UDP Packets' has blocked the TCP type from the source 192.168.?.?.

So I go to Profiles, and in my Trusted IP List, I add the IP Address range 192.168.0.0 to 192.168.0.255.

But alas its still being blocked with the same rule as before.

I cannot seem to change the rule on the 'All Other TCP and UDP Packets' to specifically allow these IP address through.

The only way to do this is to turn off the All Other TCP and UDP Packets, but I thought that this would leave my PC open to all undesirable traffic.
pctools-firewall-1.JPG
pctools-firewall-2.JPG
pctools-firewall-3.JPG
0
deluk20
Asked:
deluk20
  • 3
2 Solutions
 
profgeekCommented:
Turn off your firewall temporarily and then see if your setup works without it turned on.  If it does, then the firewall configuration is, indeed, the problem.  If it doesn't, then it's not the firewall.

Assuming it's the firewall, as you surmise, does the packet being blocked have the address of your iTouch or your Windows 7 system?  Is your Windows 7 system set up for Internet connection sharing?  How is your iTouch getting its IP?  
0
 
deluk20Author Commented:
Hi Profgeek,

When I have the firewall on my PC turned off, the itouch has full access to the net. When turned on ... Nothing!

The PC's Wireless Adapter has been 'told' to use the IP address of 192.168.0.1 and the Subnet mask 255.255.255.0 (Picture 1).

Reading the History of the Firewall program the IP address being block is exactly that of the ITouch (picture 2), even though I specified the entire IP range to be a 'Trusted IP' address 192.168.0.0 to 192.168.0.255 (Picture 3). Currently on the current connection the Itouch has the IP of 192.168.0.207.


Capture-1.JPG
Capture-2.JPG
Capture-3.JPG
0
 
deluk20Author Commented:
Slight change now.

I noticed that the very first network picked up by PC Tools Firewall is one that it uses. In this case the one that connects to the internet

So I deleted the network, connected to the ad-hoc network. This is now stored in the Network settings on PC Tools.

I re-connect the internet connection and all is well.

As I am unsure if PC tools is now covering my internet access, I have enable the Windows 7 firewall - well better than nothing..

How can I check my firewall for the internet connection?
0
 
QlemoC++ DeveloperCommented:
Checking your firewall is easy. Go to e.g. ShieldsUp! (https://www.grc.com/x/ne.dll?bh0bkyd2, might change), and do a "Common Port" scan (or type in any special port you would like to test).
0
 
deluk20Author Commented:
Having contacted PC Tools, they advise to switch off the Packet Filtering - works but unsure how well

Thank for your input guys
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now