IIS6 windows 2000

I have a website on a windows 2000 server which is basically a database with a GUI.  The programmer is trying to upload a URL.  I he uses local host it works.  If it uses the server name it errors.  I've included a picture of the form and error. The first attachment is what it should be and the second one is the error.

The programmer was telling me it was a proxy error so I added 8080 in the host header but still nothing.  Does anyone have any idea?

Lastly I can access the site from IE with the server name and name of the site with no issue.
localhost.JPG
form1error.JPG
WellingtonISAsked:
Who is Participating?
 
WellingtonISAuthor Commented:
This issue was solved when I moved the program to a 2003 server.  Thanks everyone for you hard work.
0
 
RovastarCommented:
This I think is IIS related.

Can you go to localhost normally in the browser?

When there is no website defned at an address it normaly means IIS cannot resolve it to a hostheader.

Make sure the website you want to listening the local host is doing so ,this is the one without a host header defined. So check all your site settings host headers.

0
 
WellingtonISAuthor Commented:
So put the website in on the host header?
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
RovastarCommented:
Yeah from the application. Try that is probably better.

Or set a default site to listen for the IP address as well.

IIS will direct to the set site based on IP address, host header and port.
0
 
WellingtonISAuthor Commented:
I think that did the trick.  I'l let you know later. Thanks.
0
 
WellingtonISAuthor Commented:
the only way I can get the site to come up is if I have a blank hostheader with 80.  Then if I do that I can't get the form to work???

I've tried different combinations but the only way the site works is if I put in a blank host header.  Maybe add in DNS?
0
 
WellingtonISAuthor Commented:
The sites are virtual sites.
0
 
RovastarCommented:
So the sites you have setup on the server do not resolve to a domain name.

Well DNS is one option get that setup.

The other more crude but may be quicker is to edit your hosts file (on your client and maybe your server - if it is doing internal calls)

You need to make sure you have the correct connectivity.

What error are you getting now? Another error? The original error was 'Site not found' 'No websites configured at this address'.  I would have hoped that setting 'no IP' in the host header for the site you want to connect to would have solved that error.

What error are you getting now?

Also try this code on the server itself so you don't get proxies and other junk in teh way.
0
 
WellingtonISAuthor Commented:
When I take out the default header which has nothing on it the form's works, that's the picture I sent you.  However if I add the sites to the host head files the sites do not come up.  

The site is as follows:
http://servername/cesireportexec/login.aspx
http://servername/cesireportexecadmin/login.aspx

Maybe I'm adding the names wrong?

I'm adding servername/cesireportexec with no ip and port 80
I've tried http://servername/cesireportexec/ that doesn't work either
0
 
WellingtonISAuthor Commented:
The only way I can get that form to come up is if I take out the default host header. The form will only resolve localhost not the server name.
0
 
RovastarCommented:
Can you not fix your app to process it via a host header? That would make most sense to me.
0
 
WellingtonISAuthor Commented:
That's what I'm trying to do but I'm not sure how.
0
 
WellingtonISAuthor Commented:
Stupid question but I'm going to ask.  If the site resolve as follows:

The site is as follows:
http://servername/cesireportexec/login.aspx
http://servername/cesireportexecadmin/login.aspx

then what should the hostheaders say?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.