?
Solved

Every time I start my laptop Num Lock or Number lock is automatically turned on

Posted on 2009-12-18
15
Medium Priority
?
1,725 Views
Last Modified: 2013-11-17
Every time I start my laptop Num Lock or Number lock is automatically turned on and i do not want it on by default because i have to turn it off in order to enter a password to login to my computer
How do I turn it off so it does not come on automatically every time i start up my laptop
0
Comment
Question by:cdubbcisco
  • 5
  • 5
  • 2
  • +2
15 Comments
 
LVL 16

Expert Comment

by:medvedd
ID: 26081193
There should be option for this in BIOS settings. What is your laptop make/model?
0
 
LVL 10

Expert Comment

by:moon_blue69
ID: 26081230
I agree with medvedd the numlock is turned on from bios. When your laptop starts as soon as the manufacturer logo apprears press f2 on your keyboard press f2 repeatedly to make sure you are in the bios settup. There you will find the setting. I cant guide you further without knowing bios manufacturer.

0
 

Author Comment

by:cdubbcisco
ID: 26081353
laptop is a Panasonic CF-50
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 30

Expert Comment

by:flubbster
ID: 26081632
Many laptops do not have an option in BIOS for this. Hopefully, your will. I looked at the manual and the setup options in the BIOS, but did not see. Not sure if the manual shows every option though. If you can't turn it off in BIOS, then try this little reg trick:

Click Start, click Run, and type regedit to open the Windows registry editor.
In the registry, open the below folders.

HKEY_CURRENT_USER\Control Panel\Keyboard\
 
Within the keyboard folder, you should have a string value named "InitialKeyboardIndicators" with a value of 0, 1, or 2. Below is the explanation of each of these values.

0 = Num Lock is turned OFF after the logon.
1 = Disable Num Lock.
2 = Numlock is turned ON after  the logon

Double click on the InitialKeyboardIndicators key on the right side and change the value to either 1 or 2 as desired. Exit the registry, reboot to test.
0
 
LVL 16

Expert Comment

by:medvedd
ID: 26081964
If looks like in Panasonic CF-50 there is no option to turn off numlock during boot.
0
 

Author Comment

by:cdubbcisco
ID: 26082080
BIOS IS V3.01L12
0
 

Author Comment

by:cdubbcisco
ID: 26082085
did not see any setting in the bios
0
 
LVL 30

Expert Comment

by:flubbster
ID: 26082142
That's what I stated in my earlier post. Many laptops DO NOT have this option, while most desktops do. Try the registry hack I detailed above and see if that works.
0
 

Author Comment

by:cdubbcisco
ID: 26082828
i tried that but each time i reboot the setting is changed back to 0 in the registry
0
 
LVL 30

Expert Comment

by:flubbster
ID: 26082932
OK.. try this:

Start Notepad.
Copy the following code, and then paste the code into the text file:

set WshShell = CreateObject("WScript.Shell")
WshShell.SendKeys "{NUMLOCK}"
                              

Save the file as "numlock.vbs" (including the quotes). This properly creates the file with the .vbs extension. The icon changes from a Notepad icon to a script icon. Save to your desktop or anywhere you can find it easily.

"Start" "Run" type gpedit.msc

Under "Computer Configuration" "Windows Settings"
Double click "Scripts(Startup/Shutdown)"
Double click "Startup" in right pane.
Click "Add" button and browse to your program and then click "ok" then Click "Ok" again.

you can now exit out of all the Group Policy editor..

Reboot and test
0
 
LVL 30

Accepted Solution

by:
flubbster earned 2000 total points
ID: 26083154
If you still have trouble, follow this process to see if it sets the registry correctly:

1. - Log on to Windows normally. Turn off numlock, and use Ctrl-Alt-Del
and LOGOFF, NOT Shutdown.

2. - Notice now that you are back to the login window and NumLock is ON again. Turn
it off and then hit Ctrl-Alt-Del again and choose Restart.
0
 

Author Comment

by:cdubbcisco
ID: 26108702
i will give those a try.\
i do not have access to this guys laptop so i will try it when he brings it into work tomorrow
thanks
0
 

Expert Comment

by:bccraig
ID: 26202153
i just tried what flubbster recommended and it worked for me.  similar model Panasonic laptop (CF-Y2)

thanks for the tip.
0
 

Expert Comment

by:bccraig
ID: 26202162
to clarify, it was this comment:

If you still have trouble, follow this process to see if it sets the registry correctly:

1. - Log on to Windows normally. Turn off numlock, and use Ctrl-Alt-Del
and LOGOFF, NOT Shutdown.

2. - Notice now that you are back to the login window and NumLock is ON again. Turn
it off and then hit Ctrl-Alt-Del again and choose Restart.
0
 
LVL 30

Expert Comment

by:flubbster
ID: 26202483
Glad it helped you.... I wonder if it helped the poster. lol

For some reason, following that exact sequence seems to create the proper egistry entries without them being reset again.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As hardware bugs go, this is a strange one! I upgraded a laptop in December 2011 with a 512GB Crucial m4 2.5-inch/9.5mm SATA Solid State Drive (SSD), Crucial part number CT512M4SSD2: http://www.crucial.com/store/partspecs.aspx?IMODULE=CT512M4SSD2 …
For some time some of our users experienced package loss on a couple of our Lenovo Thinkpad S531 machines running Windows 8 or Windows 8.1 64-bit OS. I was not able to find many answers online, but did after some investigation I began to suspect Blu…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question