?
Solved

Reading Vista OS Hard Drive On USB Connection for Recovery - Can't See Files

Posted on 2009-12-18
17
Medium Priority
?
589 Views
Last Modified: 2016-10-27
Im trying to repair a Windows Vista PC laptop that wont boot. We get an error message that says that winload.exe is missing or corrupt. I put in the installation disk as instructed and ran repair& but I get a message that says theres no problem with the system.

Id like to back up the users files (in the Documents and Pictures folders) before going any further but when I remove the hard drive and connect it externally to the USB port on a desktop PC I can see almost everything except the users files. It appears to me that Vista security makes the user files invisible to an external OS. Also, when I look at the properties of the hard drive, it indicates 99.7% free space.

Can anyone tell me why I cant see the files and what I can do to back up the users data? I tried taking ownership of the Q:\users folder and subfolders and I tried using Acronis TrueImage 10.0 to back up the drive from the laptop  still dont see any user files.
0
Comment
Question by:Concentus
  • 6
  • 5
  • 4
  • +1
17 Comments
 
LVL 3

Expert Comment

by:ringw
ID: 26082404
Try to take ownership on the Users Directory and all subdirectories: Right click the Users folder, Properties, Security, Advanced ..... You should then be able to acces the users directories.

0
 
LVL 3

Expert Comment

by:ringw
ID: 26082449
0
 

Author Comment

by:Concentus
ID: 26082670
ringw,

Thank you for your response. I tried taking ownership and still didn't see the files but I will try again following the guide on the link you listed. I may have overlooked something concerning the UAC.
0
 
LVL 52

Expert Comment

by:Jackie Man
ID: 26085867
You are correct. Taking ownership cannot solve your problem.

You need to download a Vista Recovery Disk or use your Vista Setup Disk to start your PC and launch command prompt to copy files inside the user folder.

A downloadable version of Vista Recovery Disk is as follow.

http://coblitz.codeen.org/neosmart.net/downloads/guides/Vista_Repair/Vista_Recovery_Disc_x86.iso

(I assume that your computer is of Vista 32 bit.)

You can put back the hard disk in the Windows Vista PC laptop and launch System Recovery and select the Vista installation in C drive. Or if you launch the System Recovery from Desktop, you need to select the Vista installation in the USB drive of the laptop hard disk.

A tutorial of System Recovery is in the URL below.

URL: http://www.bleepingcomputer.com/tutorials/tutorial142.html

You can select "Command Prompt" in Figure 5 from the above URL and use DOS command to navigate to the users folder.

For example, when you are in the root directory, type cd user and press enter and type dir and press enter, you will see a list of folders for all users. Then, you can type cd friend_name and press enter to go inside the particular user folder. (Assume friend_name is the folder name you see when you type dir command.)

Then, you can attach a USB drive in your Vista PC laptop to copy all user data and the command is as follows:.

xcopy source_folder destination

You need to find out by trial-and-error which one is the USB drive attached by switching to that drive by using the DOS command below.

g:

Maybe the drive will be of a letter name from any alphabet (except a, b, c ,d and e)

Then, type dir and press enter, you will see the content inside so you will know whether it is the USB drive or not.

Afterwards, go back to the user folder c drive by:-

c:

cd Users

cd friend_folder

Then you can use xcopy command to copy the document, pictures, music folders by:-

xcopy document g:

Do the above command one by one and all user data will be copies to the USB drive.


0
 
LVL 3

Expert Comment

by:ringw
ID: 26086252
If talking ownership does not work why would you think then, jackieman, that you would see any files with the recovery DVD? Please explain.

If the files are there and you take ownership of the users directory (with all subdirectories), you should also be able to access the files.

If the files are not there, then also a recovery DVD would not help you.
0
 
LVL 93

Expert Comment

by:nobus
ID: 26086297
i had the same problem when i connected a VISTA OS disk to an XP PC for troubleshooting.
i was Unable to access or even view some files - not all.
impossiblke to get to them -  but once i connected the disk to a Vista system; all problems vanished.
So that is my suggestion : troubleshoot from a Vista system (or later, W7)
0
 
LVL 52

Expert Comment

by:Jackie Man
ID: 26086317
ringw:

If it is so easy to take ownership, there is no security at all- Imagine the scenario below:

Steal a hard disk from a computer and attach it to another computer -> Take ownership  -> Can access and copy the file?

When you boot a Vista computer by Vista Recovery Disk and select the Windows Installation to repair, you will be asked to supply the user name and password of the local administrator of the Vista computer before you can proceed with the repair. (unless the hard disk is crashed and the user credential is lost.)

What has explianed in your URL for explaining a detailed procedure how to take ownership, it is used only if there are multiple users on the same Vista system and when you login in as local administrator, you can take ownership of certain folders and files which is belonged to other users and you are not breaking the Vista security.

Finally, you have violated the EE membership agreement in mentioning Hiren's Bood CD, which is a tool which has infringed the intellectual properties of a number of software which can be bought on the market.

0
 
LVL 3

Expert Comment

by:ringw
ID: 26087980
@jackieman:

If you steal a hard disk, connect it to a different Windows machine, take ownership of all files, then you can access all data!!!

Just proved this by doing the following:
- created a testuser on one of my Vista test machines
- logged in with testuser
- created a file in My Documents
- shut down the machine
- unplugged the harddisk from the test machine
- connected the harddisk to a different Vista machine via USB
- could easily browse the Users folder
- could easily take ownership of the \users\testuser and subdirectories
- could easily access the test file I created

There is no Windows / NTFS mechanism that prevents you from doing that! The only would be is if you encrypt your data.

@Concentus:
What was the Windows Version of your original machine, what was the version of the machine you plugged in the disk via USB? If it is an earlier version of Windows, it could be a NTFS Version incompatibility.
0
 

Author Comment

by:Concentus
ID: 26089613
Thanks  for all the suggestions. So far, I haven't been able to  make  the  files visible. I have Vista Home Premium on my PC and the Version of the PC that  won't boot is Vista Home Premium  also.
One of  the main things I'm noticing is that  when I try to  access the  unbootable hard drive I'm   never asked to  provide the  user name or password for  the   profile that has the files we can't see.
I tried  taking  ownership through right  click properties  and then I  tried the command prompt. It  looked like it gave  ownership,  but I  still  couldn't see  the user's profile  or his files in the  c:\users folder.
I  tried booting from an installation disk on the user's laptop and on my desktop. With  the  command prompt  (and dir  command), I still  don't see the user's profile name  or files.

I  don't believe  the  user did  anything abnormal  or  unusual, such  as adding  any extra security. Seems like I  should see his   folder  under  the  user's folder  and should   be prompted to  provide his  user name and  password when I try to  access it. I tried  typing in c:\user\User'sName, even though I  could  see it but it is as  if  the  folder's and files  don't exist.
0
 
LVL 3

Expert Comment

by:ringw
ID: 26090006
Concentus, so you see the x:\users directory, you see also the x:\users\username directory, but under c:\users\username you don't see any files?

For a local NTFS drive, Windows will never prompts you for a password, either you can access the files (if you have permissions) or you cant (if you dont have). Password prompts only occur if you access a share via network and you dont have sufficient permissions with your current user.

Could you send us a screenshot of the x:\users\username directory (or whatever drive you are using) from your other Vista PC. Right click on, x:\users\username, properties, Security. (Screenshot), then Advanced, Owner (Screenshot).

When you took ownership, are you sure that you checked "Replace owner on subcontainers and objects"?
0
 

Author Comment

by:Concentus
ID: 26098924
I apologize for taking so long to get back to you. My cable modem is on the blink.

I will try to send a screenshot asap. Mainly, I just see c:\users\ ... administrators , default , and public. there should be a david folder, I think. The Default folder was hidden. I took ownership of the users folder and made sure that I checked the subfolders checkbox. According to the folder properties, I did get ownership for administrator.

I booted the systems (both my desktop and his laptop) with a bootable linux CD (knoppix). First I had his hdd connected via usb. I could see my desktop files but not his hdd files. When I booted his laptop from linux, I still could not see his files. Then I looked around and realized I couldn't see hardly any files on his hard drive, just a few system files and a bunch of folders. I'm thinking there must be something unique about his system.

It's occurred to me that, perhaps his hard drive is encrypted or has some other security since it is a laptop (?). Does that sound possible? I talked to the user again. He hasn't done anything but use it in a normal fashion. He got an error with the winload.exe and hasn't used it since.

I really appreciate your help. I hope we can recover his files.




0
 
LVL 3

Expert Comment

by:ringw
ID: 26100156
If you don't see the user's subdirectory under the users folder then something/somebody has deleted this subdirectory. Maybe an administrator has logged in and deleted the user, or maybe a virus has destroyed the data. If you have really important data on that disk, the I'd recommend sending the disk to a professional data recovery service.
0
 
LVL 93

Expert Comment

by:nobus
ID: 26102741
if you suppose problems with accessing the drive, i suggest you boot from a live Knoppix cd - then you have a fresh OS, AND no access problems (and it serves you well for backup of laptops too) :
ftp://ftp.kernel.org/pub/dist/knoppix/KNOPPIX_V6.0.1CD-2009-02-08-EN.iso
0
 

Author Comment

by:Concentus
ID: 26104332
Thank you for the replies. This is very strange. I did boot with Knoppix v6.0 (It's a great tool and I reallly like the newer interface) and that's when I noticed that I couldn't see hardly any files on the entire drive - just folders.
Last night I ran recuva by piriform - data recovery. It didn't find any files in the users folder. Tonight I'll try a deep scan. I have a few other data recovery programs to try, also.
This is a very perplexing problem. And it's a hard search: "can't see files on vista external drive" and similar searches turns up all kinds of results.

 
0
 
LVL 93

Expert Comment

by:nobus
ID: 26105746
and keep Knoppix around, it's very handy for backup and troublehooting non-booting pc's
lets you access usb, network, internet..
0
 
LVL 93

Accepted Solution

by:
nobus earned 2000 total points
ID: 26105797
then you'll need recovery software i'm afraid; here some links - check what they show to recover :
      http://www.pcinspector.de/file_recovery/UK/welcome.htm      pc Inspector - free -
http://www.stellarinfo.com/                              Stellar
http://www.runtime.org/                              GetDataBack
http://www.ontrack.com/                              Ontrack
http://www.recovermyfiles.com/                              RecoverMyFiles
0
 

Author Comment

by:Concentus
ID: 26191681
Thanks, everybody, for your help with this.

Nothing I tried, within normal use, worked.

The faulty PC was a laptop running Vista. I connected to it with a Knoppix, Vista, and Windows 7 system and could never see any folders under Users other than Administrators, Default, and Public. In fact, with the exception of two or three system files (I forget which ones, now), I could not see any files on the entire drive  only folders. The folder structure appeared to be intact.

The Windows Vista Setup Disk provided a system repair function, but didnt work. When I clicked on the repair option, it scanned the system briefly and said there were no errors. So it didnt try to repair or replace any files.

We didnt have much time left to work on it, so I did a data recovery with PC Inspector and used his recovery disks to recover the OS.
0
Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ransomware - Defeated! Client opened the wrong email and was attacked by Ransomware. I was able to use file recovery utilities to find shadow copies of the encrypted files and make a complete recovery.
Today as you open your Outlook, you witness an error message: “Outlook is using an old copy of your Outlook Data File…”. Probably, Outlook is accessing an old OST file.
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question