[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

ActiveSync will not provision devices, even when it is configured to allow non provisonable devices

Posted on 2009-12-18
77
Medium Priority
?
8,182 Views
Last Modified: 2012-06-27
I cannot add an iPhone that was already syncing correctly.Receive the following from the mobile device logs:

RequestTime :
12/18/2009 10:32:47

ServerName :
SRV3

AssemblyVersion :
08.01.0393.001

Identifier :
320F1693

RequestHeader :
POST /Microsoft-Server-ActiveSync/default.eas?User=rgeissler&DeviceId=Appl5K92865xxx&DeviceType=iPhone&Cmd=FolderSync
Connection: keep-alive
Content-Length: 13
Content-Type: application/vnd.ms-sync.wbxml
Accept: */*
Accept-Encoding: gzip, deflate
Accept-Language: en-us
Authorization: ********
Host: mail.ne-obgyn.com
User-Agent: Apple-iPhone/704.11
Ms-Asprotocolversion: 12.1
X-Ms-Policykey: 0

RequestBody :
<?xml version="1.0" encoding="utf-8" ?>
<FolderSync xmlns="FolderHierarchy:">
<SyncKey>0</SyncKey>
</FolderSync>

ResponseHeader :
HTTP/1.1 449 Retry after sending a PROVISION command
MS-Server-ActiveSync: 8.1

ResponseBody :
[No XmlResponse]

ResponseTime :
12/18/2009 10:32:47

This is in the iis logs:

2009-12-18 14:50:42 192.168.100.246 POST /Microsoft-Server-ActiveSync/default.eas User=User&DeviceId=Appl5K92865WY7H&DeviceType=iPhone&Cmd=FolderSync&Log=V121_LdapC0_LdapL0_RpcC11_RpcL31_Ers1_Pk0_Error:DeviceNotProvisioned_ 443 domain\user 166.205.10.131 Apple-iPhone/704.11 449 19 13 202

I have reoved the device, re-added, and I can see it in Exchange, it simply won't sync.

has anybody seen this issue before?

Thanks,
Rob

0
Comment
Question by:RGEIS2000
  • 27
  • 26
  • 10
  • +4
77 Comments
 
LVL 6

Expert Comment

by:ob1_
ID: 26087836
What about event viewer on the server - do you have any ActiveSync errors in the Application log if so please post them..
0
 

Expert Comment

by:Nancy Villa
ID: 26087989
There are two:


MLog Name:      Application
Source:        MSExchangeTransport
Date:          12/19/2009 12:32:28 PM
Event ID:      12014
Task Category: TransportService
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERVER1.domain.msft
Description:
Microsoft Exchange couldn't find a certificate that contains the domain name mail.domain.com in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector Default SERVER1 with a FQDN parameter of mail.domain.com. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchangeTransport" />
    <EventID Qualifiers="49156">12014</EventID>
    <Level>2</Level>
    <Task>12</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-12-19T18:32:28.000Z" />
    <EventRecordID>39937</EventRecordID>
    <Channel>Application</Channel>
    <Computer>SERVER1.neob.msft</Computer>
    <Security />
  </System>
  <EventData>
    <Data>mail.domain.com</Data>
    <Data>Default SERVER1</Data>
  </EventData>
</Event>



Log Name:      Application
Source:        MSExchange ActiveSync
Date:          12/19/2009 12:46:52 PM
Event ID:      1040
Task Category: Requests
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      SERVER1.domain.msft
Description:
The average of the most recent [314] heartbeat intervals used by clients is less than or equal to [540].
Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and Direct Push technology. Specifically, make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed.

For more information about how to configure firewall settings when you use Exchange ActiveSync, see Microsoft Knowledge Base article 905013, "Enterprise Firewall Configuration for Exchange ActiveSync Direct Push Technology" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905013).
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchange ActiveSync" />
    <EventID Qualifiers="32772">1040</EventID>
    <Level>3</Level>
    <Task>1</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-12-19T18:46:52.000Z" />
    <EventRecordID>39941</EventRecordID>
    <Channel>Application</Channel>
    <Computer>SERVER1.domain.msft</Computer>
    <Security />
  </System>
  <EventData>
    <Data>314</Data>
    <Data>540</Data>
  </EventData>
</Event>


Thanks for your help.

0
 
LVL 6

Accepted Solution

by:
ob1_ earned 500 total points
ID: 26088008
Change the timeout setting on your HTTPS policy in your firewall.
Also increase the settings for HbiSampleSize and MaxHeartbeatInterval (both DWORD values, you may need to create them if they don't already exist) in HKLOCAL_Machine\System\CurrentControlset\Services\Massync\Parameters
read more about the registry settings and this issue in general here: http://support.microsoft.com/kb/905013
 

 
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 12

Assisted Solution

by:Saakar
Saakar earned 500 total points
ID: 26089845
The KB suggested is applicable only when Direct Push is not working but is irrelevant if someone is not able to add a Mobile Device to Exchange to use with Exchange ActiveSync.

To the Author: -
1. What is the version of Exchange the mailboxes are hosted on??
2. Is any Windows Mobile Device able to sync properly?
3. Post the results from www.testexchangeconnectivity.com for a Exchange ActiveSync test
4. What kind of Certificate you are using? If its an Internal then you have to manually import the certificate chain from the Server and install it
5. Try disabling WiFi on iPhone and check if you can configure..
6. iPhones ONLY works if you have Exchange 2003 SP2 and Exchange 2007 SP1 atleast installed
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26090869
Saakar_Rao - what you say about the kb is not correct because I just used it to resolve a similar issue on my domain where several iPhones weren't syncing yet other devices were.
0
 

Expert Comment

by:Nancy Villa
ID: 26091743
Unfortunately, I'm the only person that is having this particular problem.

I don't think the https timeout is an issue, I have many users that are not experiencing any issues at all.

It may be of note to mention that I have two Windos Mobile users that suddenly cannot sync either.

Please explain more about the certificate chai. My company does not want to pay for a trusted certificate, but this shouldn't be an issue.

Thanks.  
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26092202
If you try to fetch data manually on the phone does it sync then?
0
 
LVL 74

Assisted Solution

by:Glen Knight
Glen Knight earned 500 total points
ID: 26092524
IPhone's will sync with any version of Exchange from 2003 SP1 onwards SP2 is recommended.  And all versions above that work without problem.

Have you got the following setting configured:

Organisation Configuration > Client Access > Exchange ActiveSync Mailbox Policies

"Allow non-provisioned devices"

also are you having problems with all users or just this 1 user? Is the user a member of any built-in security groups? Domain Admins for example?  If so in Active directory Users and computers find the user right click and select properties then the security tab, click advanced and make sure the Allow Inheritable permissions is selected click apply then try your Sync again.

There is also a free App available from the AppStore on the iPhone called ActiveSync test, can you download this, install it then run the test and see what happens.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26092562
Also if your not using a trusted certificate then you will continue to experience problems and for the sake of $60 for a UCC/SAN certificate from GoDaddy.com your better of buying one.

Not that I am suggesting this is the cause of your problem but it's certainly not going to help.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26095820
I'm running Exchange 2007 SP1.

I am the only person experiencing this issue, so far.  

Allow non-provisionable devices is checked.

Thanks,
Rob

0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26096126
Are you a member of any built in groups?
Did you check the security setting I mentioned?

Are you in a position to apply SP2?
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26096479
I am not a member of any built-in groups. The security settings are the same. The Active Sync test failed, but I am the only user currently experiencing these problems.

I could try and make myself an Domain Admin.

R
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26096704
If you can fetch the data and it's just not syncing then its probably the heartbeat and/or https timeout setting: http://support.apple.com/kb/TS1868
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26096785
OB1,

A fetch would be the same as simply refreshing correct? This is not working at all. I receive no data. The phone acts as if it is syncing, but I receive the same error in on the Server application log everytime:

2009-12-21 15:40:47 192.168.100.246 POST /Microsoft-Server-ActiveSync/default.eas User=User&DeviceId=Appl5K92865xxxH&DeviceType=iPhone&Cmd=FolderSync&Log=V121_LdapC0_LdapL0_RpcC11_RpcL0_Ers1_Pk0_Error:DeviceNotProvisioned_ 443 domain\oser 166.205.xxx.xxx Apple-iPhone/704.11 449 19 13 140

I'm really at ends here. It's this Device Not Provisioned part. I even installed the cert on my phone, but this didn't help either.

Rob
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26096844
Can you try syncing with a different user?

Delete the exchange profile on the phone, cycle the power then create a new one with a different account then cycle the power again
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26096864
Demazter:

I have done this about 50 times...nothing.

Thanks though.

Rob
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26096889
So you gave tried it with a user that is working on another device?
I would suggest it's the phone, have you tried a factory reset?
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26096961
I've already reset the phone as well.

Why would I receive an error stating "DeviceNotProvisioned" when the default ActiveSync Policy is set to "allow non-provisionable devices?"
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26096988
Have you tried removing that setting from Exchange and then applying the setting then resetting it back on and applyng the setting?

Which version of the iPhone software are you using?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097012
There was a problem I recall a few months ago where the check box for "Require encryption on the device" was checked under the password tab of the mobile policy.

Can you check if it's checked and if it is uncheck it.
0
 

Expert Comment

by:Nancy Villa
ID: 26097038
All good suggestions, but we do not require a password, so the settings for device encryption are not available.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097085
Nancyvilla > please advise what your position in this question in?
It's a bit confusing when other experts post responses on behalf of the author.

can you try the user that is having this problem on another device?

If that works and a user that works on another device is will not work on this one then it MUST be the device!

The only other thing I would suggest is apply SP2 for exchange, perhaps a mismatch in the software versions on the iPhone
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097128
I apologize, nancyvilla is my manager. She gave me her log on some time ago before I had my own account. I must have replied logged in as her on accident, but for all intent and purpose, she is me.

Rob

0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097155
I was logged in as her on my phone, but I have corrected this.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097212
As for your question regarding a different user. I created a different user - same problem. I cannot see how the phone could be causing this problem. I have the latest OS, I have restored it once already, and it was syncing fine for over a month until I removed my account and attempted to re-add it.

As mentioned previsouly, I have two Windows Mobile Users that were syncing until two weeks ago, and now they cannot. I don't see how these could be related, but something's happend preventing user from accessing activesync.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097228
Can you please apply SP2 for Exchange.
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26097416
Fetch is a button in the iPhone - go into the Account Settings, I think it's under Fetch New Data > Advanced.
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26097436
Or it could be Settings > Fetch New Data > Account Name > Fetch.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097443
If it's happening to more than 1 user then it could be server related.
Apply SP2 and we can go from there.
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26097493
Understood - what I am suggesting is a test to see if it is a known server-related issue. If fetch works then adjusting heartbeat and hbisample registry settings as well as https timeout settings on the firewall may fix it as indicated in the MS and Apple KB's. The ActiveSync error posted earlier by the author from Event Viewer indicates this may be the issue.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097508
The fact it's happening on Windows phones an iPhones then it points to the server.

I have asked anothe Expert to have a look at this question as well.
He's a bit of a wiz with Exchange and iPhone
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097524
Did you try the activesync test application on the iPhone?
It provides quite a lot of diagnostic information and may well help!
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097556
Fetch does not work either. I have made the firewall configurations, but this did not work. I believe the  warning I posted about the heartbeat interval is ambigous. In fact, the warning clearly states the following:

"The average of the most recent [314] heartbeat intervals used by clients is less than or equal to [540]."

This is an ideal configuration, if the average heartbeat intervals were greater than 540, that would be a problem I suspect.

I appreciate the help
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097576
I think that's a red herring!

Can you put Exchange SP2 on?
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 26097616
Please delete the Exchange account on the iPhone and then on the server click on Start> Run> adsiedit.msc.
Select the Default Naming Context and then navigate to where your user account resides and then under this you should see a section titled ExchangeActiveSyncDevices.
In this section, you should see a list of devices that you have used to sync with that the server knows about.  Please either delete them all if you don't have any other devices syncing or just delete the iPhone(s) one(s) and then close adsiedit down and try adding the Exchange account again.
Any improvement?
(Thanks Glen)
0
 
LVL 6

Expert Comment

by:ob1_
ID: 26097620
You are right if fetch doesn't work then the KB's probably don't apply.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097621
I would agree.

I'm downloading it now. I have no purchasing power here, however. I can install it, but I would have to seek approval for purchase at some point.

Thanks.



0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097654
SP2 is free as is the ActiveSync Test application.

Welcome Alan (thanks :-))
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26097680
Not sure if anyone has posted this before (apologies if they have) but this is what demazter is referring to.
FREE Activesync Test Application for Windows or Mac:
https://store.accessmylan.com/main/diagnostic-tools 
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097729
alanhardisty,

There is no ExchangeActiveSyncDevices attribute to modify.

Thanks.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097755
The problem with the testers is they will always fail, because I do not have a trusted cert installed for SSL.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26097792
Ah - that's a new feature in 2010 - will check to see if it elsewhere in 2007.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26097795
You can tell them to ignore this.

You should really consider a trusted SSL certificate!
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26097843
I know, there's nothing I can do about that.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26097950
There does not seem to be a DS key for Activesync devices - which is probably why it has been added to 2010.
Can you please remove the Activesync policy - try to hook the phone up again and see if it allows it to sync.
If it does, you can then add a new policy and see if the phone continues to sync.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26098358
If you use the Exchange Management Shell to assigne a device ID to a specic user, I noticed that it enters the device ID in an attribute similar to the attribute you described. I manually removed the data from the attribute, which removed the attribute entirely; however, this did not work.

I have already tried to utlize an alternate ActiveSync policy, and it did not work either. I'm going to apply SP2 within the hour. I'll post the results.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26098431
That's a shame :-(
Are you able to remove the Activesync policies completely - test and if successful - add a new policy back?
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26098871
Successful upgrade to SP2...no change. DeviceNotProvisioned_
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26098950
I don't know if it helps, but it looks like Exchange is not receiving all the information from my device either.


Exchiphone.jpg
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26098959
Interesting.
Have you tried factory resetting the iPhone?
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26098965
Yes, I've done that.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26105382
OK, So I've eliminated the system externals such as firewalls, NAT, etc., by connecting via internal DNS over our wireless, and I am receiving the same errors.

Is it possible this could be an IIS permissions issue? Does anyone know a good resource for appropriate IIS permissions?

Thanks,
Rob
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26105552
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26106193
I created a test activesync policy and assigned it to me, but according to this IIS error, it looks like, I'm still getting the default policy, would I be correct?


2009-12-22 16:52:43 192.168.1xx.xxx POST /Microsoft-Server-ActiveSync/default.eas User=user&DeviceId=Appl5K92865xxxx&DeviceType=iPhone&Cmd=FolderSync&Log=V121_LdapC0_LdapL0_RpcC10_RpcL0_Ers1_Pk0_Error:DeviceNotProvisioned_ 443 domain\user 166.205.10.224 Apple-iPhone/704.11 449 19 13 124
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26106285
That is the way it looks to me.
Have you rebooted the server recently or restarted the Exchange services?
0
 
LVL 12

Expert Comment

by:Saakar
ID: 26113466
Check the discussion on this thread

http://msexchangeteam.com/archive/2009/09/22/452592.aspx

This talks about the same 449 error that you are getting in the IIS logs
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26113853
Thanks, saakar_rao. Unfortunately this does not pertain to the problem, because this is applied only if passwords are required, we do not require them, and therefore do not require encryption.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26113905
Which I believe I had already covered anyway???

Can you try setting the require password just for fits and giggles and see what happens?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26113913
But make sure the checkbox I mentioned in my previous post is not checked.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26113991
No, I can't risk effecting other user's. I have created a test policy, and assigned it to my mailbox. I could test it that way, but it would appear that I am still accessing via the default policy. I can't seem to get it to change over.

I have to say, I really liked this version of Exchange when it first came out, but it seems that I've hit a glitch that no one can resolve. I have already had users getting new iphone's for Christmas wanting to sync, but can't. It's going to be a nightmare next week.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26113996
oh, the checkbox is not checked.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26114024
How many users do you have that are working?

I have checked 3 2007 servers and 3 2010 servers and they all have the require password set and all have working iPhones and Windows Mobile Phones.

It could be possible this policy is a requirement.

It's got to be worth a try?

Have you run the Exchange Best Practice Analyzer?
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26114069
It doesn't make any sense. Users could connect, now they can't. Nothing's changed. I'd love to try it, but if clients start losing access and can't re-connect I'm screwed. That's what happened to me.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26114079
How many have you got that work?
What phones are they using?

I am going to disable the policy on my 2010 server and see what happens
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26114161
Nope, made no difference!
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26114307
Did you download the activesync test app to the iphone?
What did the logs on that show?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26114381
The only other thing I can think of is a repair install of the CAS role.
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26114557
Activesync tester won't work because of the Certificate issue.

Whenever I get the opp to take down Exchange again, I'll re-install CAS. I was going to do that next.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26114573
The Activesync test will work with a trusted cert or you can tick the ignore trust for SSL to stop it checking for Trusted Root certificates.
Either way, you can still use the Exchange Activesync Test on https://testexchangeconnectivity.com
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26114624
I think my next step would be re-installing the CAS I have exhausted all my options now!!
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26115142
Me too!! Thanks for your help though!
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26174125
This is still an ongoing issue. my org. decided to purchase an SSL certificate which has been activated for all Exchange services and appropriately installed. There are no more internal/external certificate warnings, but the problem still occurs. We only have one CASServer, so we're extremely wary of re-building it. We are actively working this with Microsoft as well, but they have been unable to provide a solution.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26174176
Try installing a second CAS on a temporary server and then reconfigure your firewall rules to point to this server, that will at least eliminate the CAS as being the problem.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26181689
What fixed it in the end?
0
 
LVL 3

Author Comment

by:RGEIS2000
ID: 26181844
Well, it would appear that the basic authentication was corrupted somehow. Something I would have never considered. Resetting it on all the Virtual Directories and togglong IIS a few times resolved the problem.
0
 

Expert Comment

by:-Manlytrash-
ID: 36188445
Can you post the exact steps for resolving this issue? I'm having the same issue with stock iPhone/Android phones.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to effectively resolve the number one email related issue received by helpdesks.
Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question