[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

mounting to sco openserver unix

Posted on 2009-12-18
10
Medium Priority
?
1,381 Views
Last Modified: 2013-12-16
hello experts,

not a unix type here. i've had a linux box mounted to my sco openserver for some time now.
without explanation... the mount now has failed.
linux was running samba. i'm not sure how the file share was accomplised on the unix side.
it looks to me like nfs isn't running on sco. don't think samba is on the sco box.
it has visionfs but.. dosn't look like that is completly installed
 i've attempted to mount from windows using nfs. i can mount the share but cannot access it.
access is denied.  

jim
0
Comment
Question by:dgdfgssfdgs
  • 5
  • 4
10 Comments
 
LVL 14

Expert Comment

by:mikelfritz
ID: 26083683
If you can mount from windows using NFS then nfs must be running.  The shares would be defined in /rtc/exports,  there are permission settings that can be made there (man exports).  You may also need to put the client into the SCO box's /etc/hosts.equiv (man hosts.equiv) file so you don't need to specify the client in the exports file.
0
 
LVL 14

Expert Comment

by:mikelfritz
ID: 26083686
that's supposed to be /etc/exports

"exportfs -av" will re-export the directories.
0
 
LVL 1

Author Comment

by:dgdfgssfdgs
ID: 26087155
hi mike,

thanks for helping me.

exports has this:


/usr/lspeed     -rw=dbload

thats the directory i want. on the network it's called "Backup"

curious as to where the share name is established.

i looked at hosts.equiv and its empty. im thinking i'd like to move from the linux box and now mount to the sco box using nfs/windows.  probably will need an entry in the hosts.equiv..
so like this:

172.16.25.1    WindowsPC

?

hold on.. now i see it.. the linux box was called dbload! so the entry in exports is giving dbload read/write..

getting some where now joy.

i can't seem to get this command to run:

"exportfs -av"

in the etc and / directories i tried ./exportfs -av and exportfs -av

not found

i tried it from scoadmin... i looks like its disabled?

(Export                          )    <- notice the parens...

jim












0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 4

Expert Comment

by:already_used
ID: 26087344
If this used to run, and now doesn't, and the 'exportfs' is missing from /etc then I would try re-installing nfs
Does /etc/nfs exist?
If visionfs is installed, then just run "visionfs setup"  to configure it, if you would rather run SMB than NFS
0
 
LVL 1

Author Comment

by:dgdfgssfdgs
ID: 26087386
hi,

/etc/nfs dosn't exist. don't have the os setup disks so.. i think re-installing nfs isn't an option.
ill take a swing at vision fs...
0
 
LVL 1

Author Comment

by:dgdfgssfdgs
ID: 26087487
it looks to me now like visionfs is the method that was used to accomplish the share.

when i list shares if vision i see "backup" and that is the directory name i'm trying to mount to.

i have a vision password, also called backup. i did an --amend to reset the password. attempted to mount the directory and got an invalid password error...
0
 
LVL 14

Expert Comment

by:mikelfritz
ID: 26087858
You could try
nsf stop
nfs start

That would re-export the dir as well.  Modify the exports file to give permissions to the PC.  I think if you remove the "-rw=dbload" then it gives rw permission to any connecting machine.  That does open up security issues that may or may not matter to you.

The exportfs command should work. Here's an ls of mine:
lrwxrwxrwx   1 root     root          35 Feb 18  2009 /etc/exportfs -> /opt/K/SCO/nfs/2.1.1Hw/etc/exportfs

So it's a link to /opt/K/SCO/nfs/2.1.1Hw/etc/exportfs

###########################################################

VisionFS stinks on ice.  You'd be better off installing samba instead if nfs won't work.

http://www.sco.com/skunkware/samba/

You would need to uninstall vision to get samba going though.

###########################################################

Could be an issue between windows and visionfs with encrypted passwords:
http://aplawrence.com/SCOFAQ/FAQ_scotec2visionpass.html

Visionfs may not be compatible with newer versions of windows (anything after win98) without mucking with windows to turn off encrypted passwords.  You could try this:
http://www.richardsramblings.com/2002/11/disabling-encrypted-passwords/

###########################################################

What command did you try on the linux box?

mount -t cifs //SCOBOX/backup /mnt -o user=backup,pass=backup

or something like that should work...



0
 
LVL 1

Author Comment

by:dgdfgssfdgs
ID: 26099206
hi,

pretty sure dfs isn't installed.

nice to hear visionfs stinks. that explains much :)

sadly.. i have to use it. got a vendor program on the box and it's their call.

you did tho.. get me in a much happier place. agreeing with you on the encryption boondoogle

i went back to the linux box. looking at fstab i was able to discern the mount point and what username was being employed.
then...
mount -l shows my mount.
df hangs where it would normally show the mount i'm looking for.
ok.
i commented out the line in fstab that did the mount and restarted
so then this command:

mount -t smbfs /mnt/new_ls/usr/lspeed
after giving it a password it works. good and bad i suppose....

how could i be doing a manual mount and yet the automount fails?


j







 
0
 
LVL 14

Accepted Solution

by:
mikelfritz earned 2000 total points
ID: 26099406
Maybe leave it out of fstab and do a rc script instead:

mount -t smbfs /mnt/new_ls/usr/lspeed -o user=backup,pass=backup

Or whatever the user/password is. Test that this works from the command line.

You could get away with adding that line to the rc.local file and it should run at startup.

Some more info on startup scripts here:
 
http://www.experts-exchange.com/OS/Linux/Distributions/Red_Hat/Q_24912950.html

Here's one on getting the fstab entry to work:
http://forums.fedoraforum.org/showthread.php?t=2197
0
 
LVL 1

Author Closing Comment

by:dgdfgssfdgs
ID: 31667905
hi,

mike.. you've given good direction to the issue as stated. it appears the issue is deeper than the issue of making the mount. having achieved the mount manually i'm finding now that it fails over time. mtab dosn't show the mount as active. if i attempt the df command the terminal locks. this is an old installation and i'm starting to think i should set up another box.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. jgh@FreeBSD.org Please see http://www.freebsd.org/doc/en_US.ISO8859-1/articles/freebsd-update-server/ for the updated article. It is avail…
If, like me, you have a lot of Dell servers in the estate you manage this article should save you a little time. When attempting to login to iDrac on any server I would be presented with two errors. The first reads "Do you want to run this applicati…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Suggested Courses
Course of the Month20 days, 5 hours left to enroll

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question