Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 453
  • Last Modified:

cisco router change from dhcp to static WAN address

hello;

i am changing a cisco 871w from having a Dynamic address to a static. for some reason i can't seem to get it to work. i can ping my default gateway nothing seems to go anywhere after that. i have plugged the connection directly into a computer and configured the addresses and the computer gets on just fine.

what am i missing?

i have attached the current config
Building configuration...

Current configuration : 4131 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$oqkf$8c0Hu54pGisqrfB1Tlars/
enable password 7 030748025D1D2C4A43174854
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
!
aaa session-id common
!
resource policy
!
ip subnet-zero
ip cef
!
!
ip domain name (hidden)
ip name-server 69.145.232.32
ip name-server 69.144.49.29
!
!
crypto pki trustpoint TP-self-signed-3821962232
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3821962232
 revocation-check none
 rsakeypair TP-self-signed-3821962232
!
!
crypto pki certificate chain TP-self-signed-3821962232
 certificate self-signed 01
  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33383231 39363232 3332301E 170D3039 30373038 31363236 
  33305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38323139 
  36323233 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  81009917 2D27B19C E36ADDC9 5EC6C290 85353FA2 DB34C1AD 0F8EFA42 AE28C4B8 
  331EDDCC 456BE2B6 2D462E8B D2424A1E 1F0C33B3 74FD5842 23E2AEDF D54E27DD 
  4278B2D7 27354801 2D93140D DAD93E8E 2D06A156 19CCE1BF 5950E812 3237EF55 
  6161AB7D DAD268B9 35AFCC27 E1D716E9 58319335 33C5731A 6DCBD127 CBDA61A1 
  B7C30203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603 
  551D1104 0F300D82 0B526F75 7465722E 524D464D 301F0603 551D2304 18301680 
  1483313D 084F19DE 2CDC04E6 3BAC0BF6 5DA02ECB 4B301D06 03551D0E 04160414 
  83313D08 4F19DE2C DC04E63B AC0BF65D A02ECB4B 300D0609 2A864886 F70D0101 
  04050003 81810028 FA69022B 08B0E488 FE996FA9 81B810CB 2C8C3E95 28C06E49 
  B1D92B01 17CC54F0 242E8EF0 F8805382 2611F640 BC5EA314 08D482AF 61111483 
  8ED73865 D8A7917B 6ADF84EA 6EBEF4EC 5761C481 F294FFA4 8BDF69CF 2C26C55F 
  EFBC7360 2E239469 C766D87A 2A4DF0BF BA900408 6D04809D 1187BF13 CF1EC561 
  45ECFFCD 649516
  quit
username admin privilege 15 password 7 141401025716272D293662
!
! 
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 description WAN interface to ISP using STATIC IP
 ip address 69.146.5.114 255.255.255.252
 ip access-group IPFW-ACL in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers tkip 
 !
 ssid RMFM
    vlan 1
    authentication open 
    authentication key-management wpa
    wpa-psk ascii 7 094F5D0042171A14061255
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 channel 2412
 station-role root
 no dot11 extension aironet
 no cdp enable
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description Internal Network
 no ip address
 ip nat inside
 ip virtual-reassembly
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 description Bridge to Internal Network
 ip address 192.168.10.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 69.146.5.113
!
ip http server
ip http secure-server
ip nat inside source list NAT-ACL interface FastEthernet4 overload

!
ip access-list extended NAT-ACL
 permit ip 192.168.10.0 0.0.0.255 any
!
!
control-plane
!
bridge 1 route ip
!
line con 0
 password 7 151118055F382622252D64
 no modem enable
line aux 0
line vty 0 4
 password 7 151118055F382622252D64
!
scheduler max-task-time 5000
end

Open in new window

0
costrack
Asked:
costrack
1 Solution
 
memo_tntCommented:
hi

change default GW to the following
no ip route 0.0.0.0 0.0.0.0 69.146.5.113
the

ip route 0.0.0.0 0.0.0.0 FastEthernet4

also remove this ip access-group IPFW-ACL in ,, 'cuz you domt have any ACL
interface FastEthernet4

no ip access-group IPFW-ACL in

try and reply
0
 
costrackAuthor Commented:
i apologize.

i power cycled the cable modem and all was working after that. i didn't think it was something to do with the config because i had looked it over 100 times.

thanks for your help i will adjust the ACL
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now