?
Solved

joomla homepage problem

Posted on 2009-12-18
15
Medium Priority
?
507 Views
Last Modified: 2013-11-10
Hi,

I have a homepage that is currently set as an article with text. I now created a slideshow in a module that I now want to show on the home page. I no longer need the text/article homepage. So now my homepage would consist of the slideshow and different menus with no text.

How do I make this homepage? The page has to be some type of link which is associated with an article or something.

How do I solve this problem?
0
Comment
Question by:wingcat
  • 6
  • 5
  • 2
  • +1
15 Comments
 
LVL 11

Expert Comment

by:j-b-t
ID: 26083945
Try this:
 - Make the default menu item point to / of eth type frontpage
 - But do not publish any articles on teh fornt page - ie. if you go to article manager - no articles should hav a tick in front page column
0
 

Author Comment

by:wingcat
ID: 26084476
not sure I understand what you mean by point to /of the type frontpage.
0
 
LVL 11

Expert Comment

by:j-b-t
ID: 26085928
ok go to yousrsite.com/administrator and login
 - go to menu  - select the menu with an asterix
 -  click on the menu link that has a star  to eth right of it - this is the default home page
 - click on change type button - middle  page about 6 cm from top
select articles - front page blog layout
 - SAVE (top right)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Expert Comment

by:Jesse Matlock
ID: 26086338
Here's an easier way.. Create a new article.. name it whatever you want ('blank home', maybe ?) and ONLY put this code in the page <span></span>  (MUST be in HTML view - if you use the WYSIWYG editor, click the HTML or <> button to show the HTML, it will be empty of course, and then just type in <span></span> )

This will allow you to save an article that is empty, in essence. Now, go to your Menu Manager and select the menu link for the home page (Home??) change the type to Article > Article Layout and then select the article you created in the step above. Now, you have a blank home page and can assign modules to fill it with content that way. :D

If that works for you please remember to click the 'Yes' button on the top right of this comment :D Thanks!
If you need any thing else or this doesn't work, etc.. please reply back, we're happy to help.
0
 
LVL 7

Expert Comment

by:techsathish
ID: 26086476
Hi,

In the article manager just do sort Front page(Click on the Front page heading). After that disable the article which are all published as Front page.

After that change the position of the slide show module. (By default banner position is in the above position of the article. So u can select the banner position for the slide show module.)

If banner position not displaying correctly then u can create ur own module position.

Plz add the following code in the index.php file (In the template folder)

And then add this code

<jdoc:include type="modules" name="slide_show" />

above this line

<jdoc:include type="component" />


An finally ur own module position is ready.
Then go to module manager and then select ur slide show module and type ur own position name "slide_show" in the position box. Then save it.

I hope its useful...


Cheers....
0
 
LVL 7

Expert Comment

by:techsathish
ID: 26086479
Hi,

Sorry for the above mistake Plz refer this answer.

In the article manager just do sort Front page(Click on the Front page heading). After that disable the article which are all published as Front page.

After that change the position of the slide show module. (By default banner position is in the above position of the article. So u can select the banner position for the slide show module.)

If banner position not displaying correctly then u can create ur own module position.

Plz add the following code in the index.php file (In the template folder)

And then add this code

<jdoc:include type="modules" name="slide_show" />

above this line

<jdoc:include type="component" />


An finally ur own module position is ready.
Then go to module manager and then select ur slide show module and type ur own position name "slide_show" in the position box. Then save it.

I hope its useful...


Cheers....
0
 

Author Comment

by:wingcat
ID: 26087132
Hi,

Cloud9mangager...

This does not work because the empty article still shows up as a small horizontal piece. I want nothing in that area. I don't even want to see the article.

I have already positioned my homepage slideshow in a showcase position which is fine. The only issue I have is that I don't want an article showing. I don't want that space filled with anything.

Below that space, I haev added menues in the user positions but I still can't get rid of the article.
0
 
LVL 8

Expert Comment

by:Jesse Matlock
ID: 26087244
Hello Wingcat,

Ok, that makes sense.. there are two ways around this:

1) Place your slide show in a 'custom' module position - To do that, instead of selecting a module position from what is available in the list, TYPE one in, something like 'slideshow' and click SAVE. Now you can use the Include Content Plugin (http://extensions.joomla.org/extensions/4809/details) to place that module IN that article that is appearing blank now... You will need to remove the <span> code I gave you earlier and replace it with the plugins code to show that module. So, you will not be using the regular module position for the module, but instead will use the article to hold the custom slideshow module.

If for whatever reason you don't like that look/layout, etc.. then use option below

2)  This step is more technical, but gets around the problems you may run into using overrides in your index.php file (this is what Joomla! recommends for modifying the frontpage correctly).. here we go. Make sure your 'Home' menu link is set to frontpage blog layout.
Take the files that end with ".php" from \components\com_content\views\frontpage\tmpl and copy them into \templates\{your template}\html\com_content\frontpage. If the folder doesn't exist, create it. From there you can do 2 things:
       1) Remove the base joomla 'article' code: <jdoc:include type="component" />
       2) add your slideshow by applying to a custom module position as described above and add that module position to the template using something like this (note: <div> tag is added for ease of styling):

<?php if($this->countModules('name of module position')) : ?>
      <div class="slideshow">
            <jdoc:include type="modules" name="name of module position" style="xhtml" />
      </div>
<?php endif; ?>

This will allow you to control the slideshow to ONLY show on the frontpage, as the index.php won't have this module position in it, nothing can conflict. To place the slideshow on other pages within the content of the site, just duplicate the slideshow module and publish it to a standard module position..

Hope that makes sense... I know it's kinda hard to explain this in a short text, so if it would help for me to clarify anything, please let me know.. ;)

Cheers
0
 

Author Comment

by:wingcat
ID: 26087298
Hi,

The slideshow that I am using is actually a module and not an article. I really love solution one but the extension appears only to be good for articles and not modules. Is this correct?
0
 
LVL 8

Accepted Solution

by:
Jesse Matlock earned 2000 total points
ID: 26087410
Yes, I understand your slideshow is a module.. my bad on the mis-step there.. all you need to do is include this code IN your otherwise blank article.. this will call your slideshow that you have published to the 'custom' module position 'slideshow'

{loadmodule slideshow}

So, you will have the article on the front page, but without content and it will contain the slideshow.. does that accomplish the look and feel you want for the site?
0
 

Author Comment

by:wingcat
ID: 26087471
I did what you suggested:

Positioned it in a custom module position called homeslide
inserted {loadmodule homeslide} in the homepage article.

All I see in the position are the words {loadmodule homeslide}.

I did add them in the html page and not the wysiwyg.

It almost seems like this plugin is not active but i did activate it.
0
 
LVL 8

Expert Comment

by:Jesse Matlock
ID: 26087579
Ok.. sounds like you are doing it correctly... and the plugin I mentioned DOES NOT need to be installed for this to wrok.. again, my apologies for the brain lapse in grabbing that link.. that is for article inside of another article placement.. not module inside article.

Ok,, here are the things to check:
1) Module is enabled even though custom position is entered
2) Module is set to display on ALL pages..
3) Ensure the spelling of the module position in both the module and the {loadposition } code is the same - can't tell you how many times a typo has caused this :D

4) Check your page and see if the slide show is rendering

I'll be looking forward to a reply with great news :)
0
 
LVL 8

Expert Comment

by:Jesse Matlock
ID: 26087834
@wingcat:

If that solved your module placement problem, please click the 'Yes' at the top right of this comment, stating that it was useful to you.. I'd greatly appreciate it.. Also, if this did not achieve the results you wanted.. please post back and let me know so I can work with you until it's resolved to your satisfaction :)
0
 

Author Comment

by:wingcat
ID: 26088045
It did work however, I there is 15 pixel padding around the slideshow. I assume that's the css doing that. Can it be changed for just this one page or not?
0
 
LVL 8

Expert Comment

by:Jesse Matlock
ID: 26089361
Hmm.. not sure about the padding, I would need a link to view the page.. but, it's possible. And, yes you could control the padding by adding an ID to your article page around the {loadposition } code..
Like this:
<div id="slideshow-home">
{loadposition homeslide}
</div>

FIND THE CLASS OR ID OF THE SLIDESHOW using Firebug or Web Developer Tools (Firefox) or by viewing the source of the page and then adding a more specific line to your CSS like so:

#slideshow-home .Class-Here .Maybe-Other-Class {padding:0;margin:0 auto;}

This will zero out the padding and margin as well as center the slideshow.

Let me know how it goes. :)
Also, for more direct feedback, connect with me at jm 07202007 at g mail
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to write a Context Sensitive Help (an online help that is obtained from a specific point in state of software to provide help with that state) ,  first we need to make the file that contains all topics, which are given exclusive IDs. …
Ready to get certified? Check out some courses that help you prepare for third-party exams.
This video teaches users how to migrate an existing Wordpress website to a new domain.
The viewer will get a basic understanding of what section 508 compliance can entail, learn about skip navigation links, alt text, transcripts, and font size controls.
Suggested Courses
Course of the Month17 days, 12 hours left to enroll

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question